VirtualBox

Ticket #17463 (closed defect: fixed)

Opened 4 months ago

Last modified 3 months ago

Linux Guest Additions 5.2.6 regression of 3D display -> fixed after 5.2.6

Reported by: BertiN45 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.2.6 Keywords: 3D
Cc: Guest type: Linux
Host type: Linux

Description

Host: Ubuntu 17.10 up-to-date with Nvidea propriety driver 340.104 Guest1: Ubuntu 17.10, 3D enabled and Guest2: Ubuntu Mate 17.10, 3D enabled

Both flash the screen a few times. The last activity of Ubuntu was the start of the Gnome display manager and afterwards it starves of any visible activity. Basically both guests just hang. Without 3D enabled it works, with 3D enabled it hangs just before reaching the login screen.

I reinstalled 5.2.4 and now everything is fine again also for 3D.

Change History

comment:1 Changed 4 months ago by BertiN45

Virtualbox 5.2.6 is missing in the drop down menu of the bug tracker! I only re-installed the Guest additions 5.2.4 not the Host part that is still 5.2.6. System HP: dc5850 (oct 2008) with an AMD Phenom II X4 B97 at 3.2GHz, 8GB. The VMs are 1.5GB or 2GB.

Last edited 4 months ago by BertiN45 (previous) (diff)

comment:2 Changed 4 months ago by BertiN45

Using Guest Additions 5.2.6 Linux Mint 18.3 runs into a login loop with 3D enabled, with the following error message:

initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused syndaemon: no process found /etc/mdm/Xsession: Beginning session setup... localuser:bertadmin being added to access control list OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.

Last edited 4 months ago by BertiN45 (previous) (diff)

comment:3 Changed 4 months ago by billznn

I have the same exact issue on 2 guests: a Mint and a Fedora 25.

In both I need 3D acceleration enabled, they both worked perfectly with VirtualBox 5.2.4 and respective extension / guest addition.

After updating to 5.2.6, they both can't start if 3D is enabled, after I installed the new guest additions.

Both work again normally after downgrading guest additions to previous 5.2.4 version.

comment:4 Changed 4 months ago by leachim6

I can confirm this is a widespread issue I tested with ubuntu 16.04 and fedora 27 and had the same results as those above. Turning off 3d acceleration is a temporary workaround for 5.2.6 extensions.

comment:5 Changed 4 months ago by socratis

Host OSX 10.11.6 (that seems to be rather irrelevant)

Guests

Fedora 25

Doesn't even reach the login window.

4.11.12-200.fc25.x86_64 #1 SMP
4.13.16-100.fc25.x86_64 #1 SMP

Mint 17

Cinnamon crashes and goes into fallback mode. For ever...

3.13.0-24-generic #47-Ubuntu SMP
3.13.0-139-generic #188-Ubuntu SMP

Ubuntu 16.04.1

Blank screen.

4.4.0-87-generic #110-Ubuntu SMP
4.4.0-109-generic #132-Ubuntu SMP

Disabling 3D acceleration works as others have reported. I do not want to start spamming the post with logs, but if anything is required, please say the word. Everything is reproducible, I have a base snapshot from 2017-07-28, VirtualBox 5.1.26, that's why I was able to test the guests with and without the kernel updates. So, pretty much the kernel version is not an issue.

I'll keep updating the guests, as the investigation/testing is ongoing...

comment:6 follow-up: ↓ 7 Changed 4 months ago by michael

Please try the updated Additions builds on the downloads page:

wiki:Downloads

comment:7 in reply to: ↑ 6 Changed 4 months ago by ionioni

Replying to michael:

Please try the updated Additions builds on the downloads page:

wiki:Downloads

I confirm working properly with the new additions. Tested with guestes Ubuntu 16.04 & 17.10 (both were having issues before, 17.10 not reaching login screen). Thank you.

comment:8 Changed 4 months ago by michael

  • Summary changed from Linux Guest Additions 5.2.6 regression of 3D display to Linux Guest Additions 5.2.6 regression of 3D display -> fixed after 5.2.6

comment:9 Changed 4 months ago by BrendanSimon

I can confirm that the updated guest additions iso fixes the problem for me too.

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_5.2.7-120528.iso [URL edited by klaus 2018-01-29, was pointing to an older revision before which is outdated]

Two things.

  1. The additional additions iso is not obvious enough on the Downloads wiki. I missed if the first few visits (and even when I knew to look for it, I had to search hard).
  1. will you rollout a new platform package with the new guest additions built-in? If not, I suspect you will get lots of unnecessary bug reports and forum questions, etc.
Last edited 4 months ago by klaus (previous) (diff)

comment:10 Changed 4 months ago by michael

  • Version changed from VirtualBox 5.2.4 to VirtualBox 5.2.6

comment:11 Changed 4 months ago by fkbreitl

I agree with Michael. The "important" note would be better placed in the extension pack section and the updated version might be better as default.

Thanks for reporting and solving this issue which affected me too.

comment:12 Changed 4 months ago by crash0veride007

The issue is resolved with the new GA's on Fedora 27 in that the X-Server/Wayland starts. However running a Fedora 27 guest + latest updates/kernel on top of a Windows 10 host with an Nvidia card the 3D-acceleration is still not functioning correctly.

Running anything 3D related in the guest results extremely slow performance. A quick dirty test of glxgears yields frame rates in the low 50's. Additionally observing the GPU activity whilst running 3D related tests in the guest shows very little to no GPU activity versus prior versions where it was vastly different in terms of GPU utilization.

glxgears OpenGL Warning: vboxCall failed with VBox status code VERR_BUFFER_OVERFLOW

274 frames in 5.0 seconds = 50.787 FPS 300 frames in 5.0 seconds = 51.948 FPS 300 frames in 5.0 seconds = 52.949 FPS 299 frames in 5.0 seconds = 51.748 FPS XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"

after 10020 requests (10020 known processed) with 0 events remaining.

--> Fedora 27 (+ latest updates) 4.14.13-300.fc27.x86_64

glxinfo output of guest with the latter 5.2.7.x GA's loaded and running Mate:

name of display: :0 OpenGL Warning: vboxCall failed with VBox status code VERR_BUFFER_OVERFLOW

display: :0 screen: 0 direct rendering: Yes server glx vendor string: Chromium server glx version string: 1.3 Chromium server glx extensions:

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig

client glx vendor string: Chromium client glx version string: 1.3 Chromium client glx extensions:

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig

GLX version: 1.3 GLX extensions:

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig

OpenGL vendor string: Humper OpenGL renderer string: Chromium OpenGL version string: 2.1 Chromium 1.9 OpenGL shading language version string: 4.60 NVIDIA OpenGL extensions:

GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program, GL_ARB_fragment_shader, GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_pixel_buffer_object, GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shader_texture_lod, GL_ARB_shading_language_100, GL_ARB_shadow, GL_ARB_texture_border_clamp, GL_ARB_texture_compression, GL_ARB_texture_cube_map, GL_ARB_texture_env_add, GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos, GL_ATI_texture_mirror_once, GL_CR_bounding_box, GL_CR_cursor_position, GL_CR_head_spu_name, GL_CR_performance_info, GL_CR_print_string, GL_CR_readback_barrier_size, GL_CR_saveframe, GL_CR_server_id_sharing, GL_CR_server_matrix, GL_CR_state_parameter, GL_CR_synchronization, GL_CR_tile_info, GL_CR_tilesort_info, GL_CR_window_size, GL_EXT_blend_color, GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_blit, GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays, GL_EXT_secondary_color, GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_texture3D, GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map, GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_sRGB, GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat, GL_NV_fog_distance, GL_NV_fragment_program, GL_NV_fragment_program2, GL_NV_fragment_program_option, GL_NV_register_combiners, GL_NV_register_combiners2, GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_NV_vertex_program, GL_NV_vertex_program1_1, GL_NV_vertex_program2, GL_NV_vertex_program2_option, GL_NV_vertex_program3, GL_SGIS_generate_mipmap

1 GLX Visuals

visual x bf lv rg d st colorbuffer sr ax dp st accumbuffer ms cav

id dep cl sp sz l ci b ro r g b a F gb bf th cl r g b a ns b eat


0x021 24 tc 0 32 0 r y y 8 8 8 8 . . 0 24 8 16 16 16 16 0 0 None

1 GLXFBConfigs:

visual x bf lv rg d st colorbuffer sr ax dp st accumbuffer ms cav

id dep cl sp sz l ci b ro r g b a F gb bf th cl r g b a ns b eat


0x021 24 tc 0 32 0 r y . 8 8 8 8 . . 0 24 8 0 0 0 0 1 1 None

Last edited 4 months ago by crash0veride007 (previous) (diff)

comment:13 Changed 4 months ago by CBSA

Dear developers,

I am sorry to inform you but this bug is not resolved with the GA 5.2.7.

My Ubuntu guests sometimes does not start properly and ends up in a black screen, even after updating the guest additions from version 5.6.6 to 5.2.7.

comment:14 Changed 3 months ago by socratis

@CBSA

You don't have to post to all the related tickets, especially one that has been triaged as a duplicate, like #17474. And the issue does not deal with "sometimes it doesn't work", it's a more... permanent state of being. ;)

Finally, without logs, I don't expect that anything can happen. Mainly because it fixes the problem that all the other users have been seeing. You also might considering having this discussion in the forums, that's where mostly discussions take place.

comment:15 Changed 3 months ago by tomasth

It appears this fix has caused some other issues See Ticket #17577

comment:16 Changed 3 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use