VirtualBox

Ticket #17543 (closed defect: fixed)

Opened 9 months ago

Last modified 7 months ago

5.2 - bridged WLAN adapter not working (worked in 5.1) -> fixed in 5.2.10

Reported by: MatthewSabin Owned by:
Priority: major Component: network
Version: VirtualBox 5.2.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Started the conversation here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=85345

I run a security testing VM which can't have access to my live network but needs access to the Internet, so I remove the IPv4 configuration from my host's WLAN adapter and associate it with an SSID.

Under 5.1, the guest's NIC bridged to the host WLAN NIC gets an IP address from DHCP on the WLAN and everything worked.

Under 5.2, no IP address is ever received from the DHCP server.

There were several tests performed and a fair amount of data gathered in the forum topic referred to above, let me know what you want to have me collect anew.

I've been following the test builds and development snapshots hoping to find a version where it started working - briefly I was able to get it to work by changing NIC and NIC type, enabling and disabling IPv4 on the host, but haven't been able to do that since December.

Currently on 5.2.97 r120712

Change History

comment:1 Changed 9 months ago by vushakov

I guess #17186 added to the confusion initially. So, to see that I understand the current problem...

If you have IPv4 enabled for the interface, then the guest bridged to that interface works ok.

If you start the guest with IPv4 enabled and get it to work and then disable IPv4 on the interface the guest still works ok.

If you start the guest when Ipv4 on the interface is already disabled, the guest doesn't work.

Would that be a correct summary?

comment:2 Changed 9 months ago by vushakov

We can reproduce the problem, including variations of the working/non-working workaround.

comment:3 Changed 7 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from 5.2 - bridged WLAN adapter not working (worked in 5.1) to 5.2 - bridged WLAN adapter not working (worked in 5.1) -> fixed in 5.2.10
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use