VirtualBox

Ticket #17186 (closed defect: fixed)

Opened 2 years ago

Last modified 23 months ago

Bridged over WiFi networking: no IP assigned on Win hosts, with a variety of guests/WiFi cards. => Fixed in SVN

Reported by: socratis Owned by:
Component: network Version: VirtualBox 5.2.0
Keywords: Bridged, WiFi, no IP, Windows hosts Cc:
Guest type: all Host type: Windows

Description

A variety of Windows Hosts report failure in getting the Bridged over WiFi to successfully get an IP address. The same setup works fine with any 5.1.x VirtualBox version, even 5.1.30 that was released 2 days before 5.2.0. Reporters have been using any Windows version from Win7 to the latest fast-ring pre-release of Win10.

Guests can be virtually anything, so can be the affected WiFi cards. The only common denominator seems to be a Windows host and VirtualBox 5.2.0.

The VBox.log shows absolutely no signs of anything going wrong. Almost identical logs between successful 5.1.30 runs and failed 5.2.0 runs. I believe that lower level debugging must be enabled, if the developers cannot reproduce the issue (highly unlikely).

More about the discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=6&t=85083

Change History

comment:1 Changed 2 years ago by socratis

I've tried to summarize/consolidate the reporters' setups. See  this summary post in the forums.

comment:2 follow-up: ↓ 3 Changed 2 years ago by aleksey

A small bit of implementation of HostNetworkInterface::Wireless flag was missing. The fix will be included into the next maintenance release. Build 118475 (or more recent) can be downloaded for testing from 'Development snapshots' section of test builds page.

comment:3 in reply to: ↑ 2 Changed 2 years ago by socratis

Replying to aleksey:

A small bit of implementation of HostNetworkInterface::Wireless flag was missing.

Aleksey, if you're talking about changeset 69164, it works on my two test case scenarios: Win7-32 (SP1) and Win10-64 (1607) with VirtualBox rev. 118475. I didn't update the ExtPack, no need to. The "VBoxManage list bridgedifs" works just fine as well...

I couldn't test my Win7-64, because out of the blue it started complaining about hardening issues (?!?).

EDIT: I finally got my Win7-64 to cooperate, it didn't like the fact that wireless was enabled (?!?), so I enabled the wireless after the VM started. And it does work there as well...

Last edited 2 years ago by socratis (previous) (diff)

comment:4 Changed 2 years ago by aleksey

  • Summary changed from Bridged over WiFi networking: no IP assigned on Win hosts, with a variety of guests/WiFi cards. to Bridged over WiFi networking: no IP assigned on Win hosts, with a variety of guests/WiFi cards. => Fixed in SVN

comment:5 Changed 2 years ago by socratis

Aleksey, I've only seen one report besides mine. I'm considered an optimist in general, but I think that you've outdone me with closing this one... :D

I hope you're right... ;)

comment:6 Changed 2 years ago by aleksey

Socratis, given the symptoms I am 99.99999% sure that VirtualBox was treating wireless interfaces as wired ones (due to the missing piece), failing to replace source MAC addresses on outgoing packets, which prevented unicast replies from reaching the guests. Thanks a lot for composing the summary post btw! It helped immensely in establishing a root cause.

comment:7 Changed 23 months ago by vushakov

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use