VirtualBox

Ticket #17486 (closed defect: duplicate)

Opened 18 months ago

Last modified 18 months ago

Guest Additions break Ubuntu 17.10.1

Reported by: Jimav Owned by:
Component: guest additions Version: VirtualBox 5.2.6
Keywords: hang Cc:
Guest type: Linux Host type: Linux

Description

Installing GA in Ubuntu 17.10.1 reports no build errors, but says "modprobe vboxsf failed" and the system can not be rebooted (hangs).

After the GA install, dmesg shows

vboxsf: loading out-of-tree module taints kernel.
vboxsf: module verification failed: signature and/or required key missing - tainting
 kernel
vboxsf: Unknown symbol VBoxGuestIDC (err 0)
VGDrvCommonIoCtl: Unknown request iFunction=....
(and many similar)

I will attach a screen-shot with details

After reboot, OS hangs with "A start job is running for Hold until boot".

This does not occur when rebooting before trying to install GA.

It also did not happen with the original Ubuntu 17.10 release. Maybe it has something to do with the work-arounds for Meltdown & Spectre?

STEPS TO REPRODUCE:

1. wget http://releases.ubuntu.com/17.10.1/ubuntu-17.10.1-desktop-amd64.iso
   (sha1sum: 002d059716f0d0ef33fedd1711f6c86671427747)
2. Create new VM (I took all defaults, except 4GB memory)
   Mount ubuntu-17.10.1-desktop-amd64.iso to Optical Drive and start the VM
3. (boots from iso) Click "Install Ubuntu"
   Do not check any extra download options. Click Continue
   Check "Erase disk and install Ubuntu",  "Install Now"
   Create test user, check "Log in automatically"
   When prompted, click "Restart Now", then press ENTER when prompted.
   (Hangs as it always does, due to some unrelated issue)
   Machine->Reset
4. (OS boots from virtual disk)
   Click dot-grid-icon, type "updater", click the "A" icon, install updates
   (Note: It will appear to hang with "Waiting for packagekitd to exit" but
    continues by itself after several minutes)
   Click "Restart Now"
5. dot-grid-icon->"terminal"
      sudo apt-get update
      sudo apt-get install build-essential
   PowerIcon(upper right)->PowerIcon->Power Off
6. Take a snapshot so you can get back to this state.
   Restart the VM
7. Devices->Insert Guest Additions CD image...
   Click "Run" and enter pw when prompted

RESULTS: 
   VirtualBox Guest Additions: modprobe vboxsf failed
   dmesg shows many errors, e.g. "Unknown symbol VBoxGuestIDC"
   (see screenshot)
   System hangs during subsequent reboot

Attachments

vbox.png Download (43.4 KB) - added by Jimav 18 months ago.
dmesg.png Download (146.8 KB) - added by Jimav 18 months ago.
output from "dmesg" in guest after GA install error

Change History

Changed 18 months ago by Jimav

Changed 18 months ago by Jimav

output from "dmesg" in guest after GA install error

comment:1 Changed 18 months ago by socratis

Please use the search functionality before creating a new ticket. This is a known issue, just go to the Downloads page, see the "Important" part and the new, updated additions (the actual filename starts with 5.2.7...).

Duplicate of #17463.

comment:2 Changed 18 months ago by vushakov

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use