VirtualBox

Ticket #17221 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

mount.vboxsf: mounting failed with the error: No such device

Reported by: TheITGuy Owned by:
Component: other Version: VirtualBox 5.1.16
Keywords: Centos, RHEL, shared Folder Cc:
Guest type: Linux Host type: Windows

Description

Trying to mount a shared folder on Centos & RHEL guests:

# mount -t vboxsf sharedfolder /hostfiles/ /sbin/mount.vboxsf: mounting failed with the error: No such device

but works like a dream on Solaris & Oracle Linux virtual boxes.

Please note the the virtual guest addition is installed on all boxes and on Centos/RHEL by running: VBoxLinuxAdditions.run

This is evident by the fact that the mount command recognizes the vboxsf file system type. Prior to installation I tested the command and the error was different. Then the error was about FS type being invalid.

Host is a Windows 7 Machine and Virtual box is 5.1.16.

Centos is:

# uname -a Linux centos 3.10.0-693.el7.x86_64 #1 SMP Tue Aug 22 21:09:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

# cat /etc/system-release CentOS Linux release 7.4.1708 (Core)

Change History

comment:1 Changed 5 years ago by socratis

May I suggest something? It's usually better and faster, if issues like this one (configuration, question) get first addressed in the  VirtualBox forums. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

So, if you can, please open a new thread in the  Linux Guests section of the forums. Please be sure to mention that you came from the bug tracker and include the ticket number.

comment:2 Changed 5 years ago by TheITGuy

Thanks Socrates.

I finally managed to have this working both on Centos 7 and RHeL 7.

You were right I needed a recent update. I have Version 5.2.0 r118431 (Qt5.6.2) on Windows 10 now.

I also needed to do a few more things as well. I had to ensure the following packages were installed and up-to-date also or else VBoxLinuxAdditions.run would fail, complaining about them:

  • kernel-devel
  • kernel-devel-3.10.0-693.el7.x86_64

I also made sure perl, gcc and make are installed and working properly.

Good thing is now bidirectional clipboard is also working.

comment:3 Changed 5 years ago by socratis

Thank you for the feedback. I guess this ticket can be closed then.

comment:4 Changed 5 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use