VirtualBox

Ticket #172 (closed enhancement: fixed)

Opened 7 years ago

Last modified 4 years ago

Support more than 1 CDROM drive

Reported by: Reiner030 Owned by:
Priority: major Component: DVD
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Hi,

it would be nice to have a 2nd cdrom (or perhaps like hard drives 4 ones)

Greets Reiner

Change History

comment:1 Changed 7 years ago by alexef

I have the same opinion, there must at least one more CDROM drive. Given the situation I run a LiveCD (mounted as ISO) and I want to test GuestAdditions I can't do that without unmounting the livecd, but then I lose the guest so. Got it?

Greets

comment:2 Changed 6 years ago by frank

  • Component changed from other to DVD

comment:3 Changed 6 years ago by damidalla

I think this enhancement should be an important feature with the increased popularity of liveCDs (also from SUN's OpenSolaris). If it can be implemented with LAN, why not enabling it with CD/DVD drives?

comment:4 Changed 5 years ago by kookyman

I'll agree that having only one Optical Media is kind of limiting. I am thinking it is simply an implimented limitation since you can theoretically add as many hard drives as you need, you should be able to use similar code for Optical Media. Just choose the image, or physical drive.

Two would should be the new minimum.... but is there any real limitation beyond the number of interfaces available?

comment:5 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.3.6 to VirtualBox 2.1.2
  • Summary changed from 2nd or more cd drives to Support more than 1 CDROM drive

comment:6 Changed 5 years ago by Donuts

The current one-CD-drive-only restriction causes a misfeature. For example, boot from e.g. the Xubuntu 9.04 CD, then choose to install guest additions. If you then reset the Xubuntu VM, it does not boot because the guest additions CD is in the virtual drive, instead of the bootable Xubuntu CD. The user is not explicitly told that, so may not immediately figure out what the problem is.

More generally, VirtualBox would ideally support any number of emulated CD drives, which the user could configure as connected to any IDE or SATA port.

comment:7 Changed 5 years ago by talbot

I have the same request. I wanted to install Guest Additions on Ubuntu runned from CD, but I was unable to do that. Thank you for the implementation.

comment:8 Changed 5 years ago by michael

People interested in using Guest Additions with live CDs might want to look at the way Kanotix does this.

comment:9 Changed 4 years ago by Technologov

I am happy to say, that this wish is now fulfilled with VBox 3.1

-Technologov

comment:10 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use