VirtualBox

Ticket #17189 (closed defect: fixed)

Opened 7 months ago

Last modified 3 months ago

New addons 5.2.1 Issues -> fixed in 5.2.2

Reported by: chad Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.2.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

1) the VBoxLinux.run script is no longer executable 2) I received an errror"failed: modprobe vboxsf ..." something like that

Change History

comment:1 Changed 7 months ago by chad

Scratch the 1st issue, I was looking at the wrong thing

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.2.1 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 5.1.28 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: modprobe vboxsf failed

comment:2 Changed 7 months ago by mrchin4da2009

I am having the same issue and I have tried using the other two images that are provided on the download page.

Host: Windows 7 Guest: Linux 4.4.90-28-default x86_64

dmesg output:

vboxsf: Unknown symbol VboxGuestIDC (err 0)
Last edited 7 months ago by mrchin4da2009 (previous) (diff)

comment:3 follow-up: ↓ 4 Changed 7 months ago by michael

The message "modprobe vboxsf failed" is just cosmetic, not a real problem, but I agree that it is confusing and should be fixed.

@mrchin4da2009 I am guessing that your issue is completely different, but you do not provide any information to let me tell, such as your distribution (wild guess: openSUSE?)

comment:4 in reply to: ↑ 3 Changed 7 months ago by mrchin4da2009

Replying to michael:

The message "modprobe vboxsf failed" is just cosmetic, not a real problem, but I agree that it is confusing and should be fixed.

@mrchin4da2009 I am guessing that your issue is completely different, but you do not provide any information to let me tell, such as your distribution (wild guess: openSUSE?)

Yes - OpenSuse Leap 42.3

I received the same error as stated for the modprobe. Additionally, none of the shared clipboard or shared files work. I have downgraded back to 5.1.30 and has corrected my issues.

Last edited 7 months ago by mrchin4da2009 (previous) (diff)

comment:5 Changed 6 months ago by ech68

Last edited 6 months ago by ech68 (previous) (diff)

comment:6 Changed 6 months ago by michael

Please try 5.2.2. Note that there are still problems with Linux VMs with 3D enabled, ticket #17190 is for that. And the message about "modprobe vboxsf failed" may still appear, as it is caused by the old Guest Additions which are being removed, not the new ones being installed.

comment:7 Changed 5 months ago by michael

  • Summary changed from New addons 5.2.1 Issues to New addons 5.2.1 Issues -> fixed in 5.2.2

Regarding the 3D issues, I hope that they are solved in the most recent development (not 5.2 series) test builds[1]. If not, please continue on ticket #17190, or open a new ticket if your issue is unrelated.

[1] https://www.virtualbox.org/wiki/Testbuilds

comment:8 Changed 5 months ago by TGOS

I'm having the same problem as mrchin4da2009. Installing guest additions also say

VirtualBox Guest Additions: modprobe vboxsf failed

So I ran "sudo modprobe vboxsf" and it says

modprobe: ERROR: could not insert 'vboxsf': Unknown symbol in module, or unknown parameter (see dmesg)

When calling "dmesg" it says:

vboxsf: Unknown symbol VBoxGuestIDC (err 0)

Since I also had the 3D problem, I'm running 5.2.97 r119529 withe the appropriate extension pack and I installed the guest additions included with that version. The guest system is a debian latest: SMP Debian 4.9.51-1 (2017-09-28) with all packets being up-to-date.

Last edited 5 months ago by TGOS (previous) (diff)

comment:9 Changed 5 months ago by michael

Please see comment 8. That is a problem of the old Additions version which is already installed, not the new one being installed, and should be fixed by a reboot.

comment:10 Changed 4 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:11 Changed 3 months ago by jcrben

Came here from  https://superuser.com/questions/1268741/virtualbox-ubuntu-guest-additions-not-installing-modprobe-vboxsf-failed

Is this really fixed? I was booting this up from the latest version of packer  https://www.packer.io/docs/builders/virtualbox-iso.html and got the error today.

Even cosmetic errors will fail the packer build by default...

I decided to not mess around with the VBoxGuestAdditions.iso and instead used apt to virtualbox-guest-dkms (didn't seem to throw an error). May also try installing virtualbox-guest-utils

Last edited 3 months ago by jcrben (previous) (diff)

comment:12 Changed 3 months ago by michael

I think that is probably an issue for Packer, not for us. The issue should be fixed, but the message comes from the old installed Additions, not for the new ones replacing them, so you will still see it when you upgrade from a version with the message.

comment:13 Changed 3 months ago by jcrben

START UPDATE 2: OK, so I ended up figuring this out. Turns out Ubuntu 17.10 does have vboxvideo and vboxguest installed, altho not via a package. So that line in the installer (lsmod | grep -q vboxguest) was failing. My fix:

echo "blacklist vboxvideo" >> /etc/modprobe.d/blacklist.conf

On reboot:

modprobe -r vboxguest
sed -i '$ d' /etc/modprobe.d/blacklist.conf

At that point I could install without failure. Also, just noticed that the 5.2.7 Guest Additions file is recommended.

END UPDATE 2

START UPDATE:

looks like the offending line of code is https://www.virtualbox.org/browser/vbox/trunk/src/VBox/Additions/linux/installer/vboxadd.sh?rev=69564#L245 - after reading this I was able to avoid the message with INSTALL_NO_MODULE_BUILDS=true ./VBoxLinuxAdditions.run - but somehow running ./VBoxLinuxAdditions.run is still returning a non-zero exit code? seems like 2 but I don't see that, maybe https://www.virtualbox.org/browser/vbox/trunk/src/VBox/Additions/linux/installer/vboxadd.sh?rev=69564#L535 which returns 1? if you want to see the code you can request access to  https://gitlab.com/jcrben-play-learn/packer-desktop/tree/17.10

    virtualbox-ovf: Installing additional modules ...
    virtualbox-ovf: VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
    virtualbox-ovf: VirtualBox Guest Additions: Starting.
==> virtualbox-ovf: Deregistering and deleting imported VM...
==> virtualbox-ovf: Deleting output directory...
Build 'virtualbox-ovf' errored: Script exited with non-zero exit status: 2

END UPDATE

I did everything but the installation of the Guest Additions in Packer. I then started up the VM to install the Guest Additions as root in Ubuntu 17.10 server  http://releases.ubuntu.com/17.10/ubuntu-17.10.1-server-amd64.iso (basically enountering the same as  https://forums.virtualbox.org/viewtopic.php?f=3&t=85186).

I then installed the Guest Additions and saw the same error:

VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: modprobe vboxsf failed

I then executed ./VBoxLinuxAdditions.run uninstall and saw:

Removing installed version 5.2.6 Guest Additions for Linux

Then I reinstalled again immediately after (without restarting) and saw the same modprobe error.

At this point, I had to run VBoxClient --clipboard to enable the shared clipboard. VBoxClient --version reports 5.2.6r120293 - altho the shared clipboard seems surprisingly finicky especially from guest to host.

Last edited 3 months ago by jcrben (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use