VirtualBox

Ticket #17022 (closed defect: worksforme)

Opened 3 months ago

Last modified 3 months ago

Host-only networking breaks if BridgedInterface is listed under DisabledModes

Reported by: Prolixium Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.26 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by vushakov) (diff)

When switching between networking modes on a VM, VBoxManage will apparently store the previous modes under the <DisabledModes> tag in the .vbox file. I recently ran into a situation where the BridgedInterface mode was still being erroneously applied even though it was listed under DisabledModes and caused host-only networking to break (unidirectional connectivity). This required me to manually edit the .vbox file and remove the BridgeInterface line from DisabledModes.

For example, the following prevents all packets from guest -> host:

<Adapter slot="2" enabled="true" MACAddress="0002BC56CB29" cable="true" promiscuousModePolicy="AllowAll" type="virtio">
  <DisabledModes>
    <BridgedInterface name="tap0"/>
    <InternalNetwork name="intnet"/>
    <NATNetwork name="NatNetwork"/>
  </DisabledModes>
  <HostOnlyInterface name="vboxnet1"/>
</Adapter>

Removing the <BridgedInterface name="tap0"/> line under DisabledModes allows host-only networking to work correctly.

It seems some items under DisabledModes are still processed, which sounds like a bug.

Change History

comment:1 Changed 3 months ago by Prolixium

Some additional information about the setup is available here:

 https://www.prolixium.com/blog?id=1029

comment:2 Changed 3 months ago by vushakov

  • Description modified (diff)

comment:3 Changed 3 months ago by vushakov

Does the bug return when you add back the BridgedInterface element back under DisabledModes? If it does, please attach the log file from the run that demonstrates the problem.

I have many VMs like this and I don't see this problem.

comment:4 Changed 3 months ago by vushakov

  • Status changed from new to closed
  • Resolution set to worksforme

I have tried to recreate your setup and I still can't reproduce the bug. For good measure I tried adding interface to the bridge in different order, switching VM from host-only to bridged and back, etc, etc.

Are you sure deleting that BridgedInterface line was not just a coincidence?

Please, reopen if you can identify steps to reproduce.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use