VirtualBox

Ticket #16957 (closed defect: obsolete)

Opened 5 years ago

Last modified 2 years ago

VBox Hypervisor Crash if Windows Server 2012 R2 has WiFi USB2.0 device driver installed but not wlanapi.dll

Reported by: kumba Owned by:
Component: VMM Version: VirtualBox 5.1.24
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

Okay, this one's a tricky one. I am not 100% confident that these are the trigger conditions, but here goes:

  • Host: Windows (any kind?)
  • Guest: Windows Server 2012 R2
  • USB Filter: 2.0 (EHCI)

Steps:

  1. Plug a USB2.0 WiFi dongle into the host
  2. Do not install driver software on the host.
  3. In VBox, select the Win2k12 guest and add the USB WiFi device so it can detect it.
  4. Start the guest up.
  5. Make sure that the "Wireless LAN service" Feature in Server Manager is NOT installed (e.g., wlanapi.dll should not be present on the system).
  6. Install driver software for the WiFi USB2.0 dongle and try to start it.
  7. The Hypervisor should crash hard with an invalid access attempt message trying to access a random memory location.

The key triggers here seem to be:

  • Win Server 2012 R2
  • USB 2.0 filter driver from the VBox Extensions pack.
  • WiFi USB dongle
  • Missing "Wireless LAN service" Feature in Win2k12.

I ran into this a few days ago trying to hijack the old Nintendo WFC adapter into working as a soft AP and went through the usual rounds of disabling the Windows Driver Verifier, so when I saw that 5.1.24 had been released, the fix from Bug #15741 sounded eerily familiar. But, I was still able to crash the hypervisor hard, even in 5.1.24. I upgraded to 5.1.26, but haven't tried crashing it there yet.

I also discovered that choosing the USB 1.0 filter driver defeats the crash, because the Wifi dongle I tested (Realtek RT8811AU 802.1ac) can't do USB 1.0. I then tried USB 3.0, which does not crash the hypervisor, so I was able to try and run the Realtek wireless program, which then complained about a missing "wlanapi.dll" file. That's how I discovered that I was missing the "Wireless LAN service" feature.

This suggests the bug is possibly in the USB 2.0 filter driver included in the extensions pack. However, because it crashes the hypervisor pretty hard, I selected "VMM" as the component, because I think that's the hypervisor core? Feel free to change to whatever is appropriate.

I looked through the logs and all, but nothing gets left behind, hence why I am calling it a hard crash. I could *maybe* get a crash dump, as I do have the Windows Debugger kit loaded, but I don't know if the debug symbols for the VBox components are available anywhere (not that I've looked real hard).

Change History

comment:1 Changed 2 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still an issue with a recent VirtualBox release and provide at least a VBox.log

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use