VirtualBox

Ticket #16921 (closed defect: fixed)

Opened 3 months ago

Last modified 3 months ago

auto_logon fails on win7 guest

Reported by: Bard0 Owned by: pentagonik
Priority: major Component: guest additions
Version: VirtualBox 5.1.24 Keywords: auto_logon
Cc: Guest type: Windows
Host type: Linux

Description

Using vbox 5.1.24 from debian-jessie (host), i noticed (only since upgrade from 5.1.22) the autologon fails. When trying to make use of it, the screen flickers endlessly (maybe failing to log in and retrying to in an endless loop). Manual login works fine though, but that is not intended.

The last time, i did complain about this feature being broken was after 5.1 did appear (see https://www.virtualbox.org/ticket/15904) Behavior was different though. Now this feature is disfunctional once again.

Attachments

logfiles.zip Download (259.5 KB) - added by Bard0 3 months ago.
reg files + 1 logfile

Change History

comment:1 Changed 3 months ago by pentagonik

Just tried to reproduce this but wasn't unable so far:

  • Have you also upgraded the Guest Additions for that VM to 5.1.24 and rebooted the guest?
  • Do the credentials contain any non-latin / special characters?
  • Is a domain being used?
  • Which Win7 version (guest) is this exactly?

comment:2 Changed 3 months ago by Bard0

Oh, that is surprising!

  • Yes, GA have been upgraded to 5.1.24 (with the install-switch) prior to testing autologon.
  • Credentials do contain no special character
  • No domain is being used
  • I am using Win7 home edition (still) ;-)

This time, i did not roll back to the older release of vbox, but logging in manually - for the time being - which is nasty (several times a day, was not necessary before). I just redid the test, but after issuing

VBoxManage controlvm "9eb701e9-7e1e-4931-af97-53cbb54ab628" setcredentials "USERNAME" "PASSWORD" "DOMTEST"

the endless flickering begins and i dont get past the login screen.

comment:3 Changed 3 months ago by Bard0

more information:

while writing above text, i let the machine flicker in the background, and after returning, it surprisingly did log in successfully. Unfortunately, i could not reproduce this behavior for unknown reasons. maybe memory has a say in this, as i am making use of memory pooling for the VM's. I cant say.

even, if the Win7 VM is the only one, it does NOT always log in, but i could see, that it did so at least once (after 2 minutes though). I am sorry, i can sense, how this information is not useful but confusing. I am willing to let you guide me - eventually - through questions...

comment:4 Changed 3 months ago by pentagonik

To get more information about this issue I need some more logging in order to analyze this further:

In the guest, open regedit.exe as Administrator and add/edit the following keys:

HKLM\SYSTEM\CurrentControlSet\Services\VBoxGuest\LoggingEnabled = 0xFF (REG_DWORD) HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions\AutoLogon\LoggingEnabled = 0xFF (REG_DWORD) HKLM\SOFTWARE\Oracle\VirtualBox Guest Additions\AutoLogon\LoggingLevel = 0xFF (REG_DWORD)

After the registry modification were made the guest needs to be restarted.

Please provide 1) the VBoxService.log file(s) (will be written to C:\ on the guest) and 2) the appropriate VBox.log file from the host in a zipped archive then. Thanks!

comment:5 Changed 3 months ago by Bard0

In order to send the most unpolluted logfiles, i could get into my hands, i modified the registry (as attached files show) and i did reboot the host first, then attempted to start the guest with autologon, which failed even after minutes of flickering. Then, i simultaneously started another VM (the one which consumes the most resources, processor power, memory) and surprisingly only now the autologin finished successfully. logfile is provided. BUT: There is no logfile from INSIDE the guest, as there just is no file in C:\ (checked with admin priviledges). Hoping, this can help somewhat anyway...

Changed 3 months ago by Bard0

reg files + 1 logfile

comment:6 Changed 3 months ago by pentagonik

Thanks! According to the logs the VBox credential provider on the guest keeps restarting a lot for whatever reason. I'm having a look.

comment:7 Changed 3 months ago by pentagonik

Could you please update the Guest Additions within the VM to the following test build:

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_5.1.25-117109.iso

I've made some improvements which I hope should fix your issue. Thanks.

comment:8 Changed 3 months ago by pentagonik

Please make sure to reboot the guest after the update.

comment:9 Changed 3 months ago by Bard0

i am sorry: although i picked up the update, it is still the same... flickering instead of logging in. But thanks for trying... :-) Maybe bisect the changes since 5.1.22, which used to work just fine? Good luck!

comment:10 Changed 3 months ago by Bard0

Oh! BTW: Since you pointed at a different version of the guest additions, i just came to try to reinstall the 5.1.22 guest additions. And those work just fine (maybe i should have tried that earlier).

comment:11 Changed 3 months ago by frank

  • Version set to VirtualBox 5.1.24

comment:12 Changed 3 months ago by pentagonik

Correct, as for 5.1.24 we made some fixes which were required for Windows 10 guests. I'm still unable to reproduce this here locally -- investigating further ...

comment:13 Changed 3 months ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:14 Changed 3 months ago by pentagonik


@Bard0 I just uploaded a new test build for the (Windows) Guest Additions here which hopefully should fix the issue:

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_5.1.25-117148.iso

After the upgrade the guest needs to be rebooted.

comment:15 Changed 3 months ago by Bard0

pentagonik, well done. without a reproducer, i understand the difficulty.

This time, the GA installed fine (as usual with switch in safe mode). And logon occurs immediately without flickering, as in prior versions.

I would think: You nailed it. Will keep this fix until it finds its way into regular update. :-)

Thanks a lot.

comment:16 Changed 3 months ago by pentagonik

Great, glad it worked for you! The fix will of course be available in the next upcoming maintenance version.

Thanks for testing and the provided information!

comment:17 Changed 3 months ago by pentagonik

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use