VirtualBox

Ticket #15904 (closed defect: fixed)

Opened 7 months ago

Last modified 21 hours ago

Regression: auto logon fails after update from 5.0

Reported by: ucrasher Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.4 Keywords: auto_logon
Cc: Guest type: Windows
Host type: Linux

Description

Hi, auto logon is a nice feature and I used it for many VMs. Now after I upgraded from 5.0.26 to 5.1.4 it does not work anymore. The login screen shows the passed credentials in different fields. Example from user manual:

VBoxManage controlvm "Windows XP" setcredentials "John Doe" "secretpassword" "DOMTEST"

The login screen of Win10-1607 shows two users "John Doe" and "secretpassword" in the left lower corner. The password box contains some text (just dots) and below the box is the text "DOMTEST".

On Win7 it is generally the same, two users. "DOMTEST" does not show up.

It almost looks like the command line is not parsed correctly.

My host is Ubuntu 1604. All the years I used this start script:

VBoxManage startvm "Windows XP" &&  VBoxManage controlvm "Windows XP" setcredentials "John Doe" "secretpassword" "DOMTEST" && exit 0

When I run the parts of the script (startvm and controlvm) separate and with enough time between, it still does not work. It behaves slightly different though. Left lower corner shows two users "John Doe" and and "username". Later (after writing this and going back to the VM) it shows garbage (Chinese chars) instead "username" and below the password box. That proofs something is fishy. In the VB log I saw noting related to auto logon.

I reinstalled GA with /auto_logon, no change.

Attachments

VBox.log Download (111.7 KB) - added by ucrasher 7 months ago.
Logs_StillFails.7z Download (32.4 KB) - added by ucrasher2 7 days ago.
2 logs (working/non-working)
VBox_autologin_failed_even_on64bit.log.7z Download (23.2 KB) - added by ucrasher2 7 days ago.
This time it failed even on 64bit VM

Change History

Changed 7 months ago by ucrasher

comment:1 Changed 6 months ago by bardo

me2, used autologin for several years, now (after upgrade from 5.0.xx to 5.1.6) no longer working:

VBoxManage controlvm "9eb701e9-7e1e-4931-af97-53cbb54ab628" setcredentials "USERxxx" "PWDyyy" "DOMTEST"

comment:2 Changed 6 months ago by josiasmat

Affects me too. Autologon worked in Vbox 5.0.xx but no longer working on 5.1.x, tested on 5.1.4 and 5.1.6. I had to downgrade VBox to version 5.0.26.

Using Linux 64-bits host (CentOS kernel 2.6.32), Windows 7 32-bits guest.

comment:3 Changed 4 months ago by socratis

Works fine with Windows XP:

  • Booted XP in safe mode and updated the GAs with "D:\VBoxWindowsAdditions.exe /with_autologon" switch.
  • To the OP (ucrasher), please note that it's not "/auto_logon", it's "/with_autologon".
  • Rebooted XP, issued the 'VBoxManage controlvm "Windows XP" setcredentials "username" "password" "DOMAIN"' from the host, and I logged in normally.

But it doesn't work with Win7/Win10 (or I couldn't get it to work):

  • Booted Win7/10 and updated the GAs with "D:\VBoxWindowsAdditions.exe /with_autologon" switch.
  • Rebooted Win7/10, issued the 'VBoxManage controlvm "Windows X" setcredentials "username" "password" "DOMAIN"' from the host. It "created" a 2nd user that had its username/password already filled in, but couldn't login.
  • Variations tried were: "DOMAIN", "DOMAIN\Computer", "Computer", "DOMAIN\User", "Computer\User", "DOMAIN\Computer\User", and all the variations in between, including an empty domain ("").
  • In all cases the login screen changed to/added a "Switch user" (there's only one user), and in the user list two identical names appeared. If I selected the 2nd one, it came pre-filled with the correct amount of characters for the password, but couldn't login.
  • Clicking on the 2nd username a 2nd time changed to the list of users screen, with the 2nd user now being "" (as in empty). Clicking a 3rd time on the 2nd username, completely removed it from the list of usernames and switched back to the single-user login screen.

Host: OSX 10.9.5
VirtualBox: 5.1.11 (112052)

comment:4 Changed 2 weeks ago by Bard0

Now, another update came in (5.0.34) that contained a reminder message to upgrade to the 5.1 branch. Carefully, i checked the autologin feature and at first glance, it appeared to work, although no new messages were added to the 6 months old bug report. To be more exact: using autologin worked with a VM configured with guest additions from 5.0, but the software being upgraded to 5.1. So i decided to go for it, upgraded the main OS, still autologin worked...

...but as soon as i followed the advice to upgrade the guest additions to 5.1.16 (of course, using the commandline switch) ... there it was again (among other confusing minor issues), forcing me to go back to a prior backup once again.

Maybe the bug only lives inside the guest additions of the 5.1.x branch?

Host: jessie (debian 7.x) Virtualbox: 5.0.34, 5.1.16

comment:5 Changed 2 weeks ago by frank

What do you mean by "upgrade the Guest Addititions to 5.1.16 using the command line switch"?

comment:6 Changed 2 weeks ago by socratis

Not being Bard0, I assume he means running "D:\VBoxWindowsAdditions.exe /with_autologon", as described in Ch. 9.2.1 Automated Windows guest logons, of the User Manual. I know I had to do this to achieve automated logon.

comment:7 Changed 2 weeks ago by pentagonik

The issue should be fixed with the next upcoming maintenance version.

comment:8 Changed 2 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.1.18.

comment:9 Changed 12 days ago by socratis

Verified with WinXP, Win7-32, Win7-64, Win10-32, Win10-64. "Weird" behavior that I noticed while doing some really non-scientific tests:

  • If you're on a workgroup, the domain can be anything. Except empty, i.e. "" doesn't work with Win7 (and if I remember correctly WinXP).
  • If you logout and you're in the login screen issuing the "setcredentials" again can lead to weird behavior (again Win7). From the command not accepted/ignored, to a crash in the LoginUI.exe. That last one I saw it with a Win7-64 guest.
  • As I don't really (or actually, not at all) use this feature, I'm not going to worry about it that much. I was simply verifying the failure and the fix.

comment:10 Changed 10 days ago by Bard0

fix serves the purpose! Thank you, upgraded with success now

comment:11 Changed 7 days ago by ucrasher2

Hi, fixed in one VM (Win10-64), but another VM with Win10-32 the "VBoxManage controlvm VPN10 setcredentials x y z" seems to be ignored. (I have installed the GA with /with_autologon)

comment:12 Changed 7 days ago by frank

To debug this issue, please create a DWORD registry key in the guest:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VBoxGuest\LoggingEnabled

and set it to 0xFF. And create another DWORD registry key in the guest:

HKEY_LOCAL_MACHINE\SOFTWARE\Oracle\VirtualBox Guest Additions\AutoLogon

and set it to 4.

Then reboot your guest. Now the VBox.log file of that VM should contain additional logging of the guest logon module.

comment:13 Changed 7 days ago by ucrasher2

Hi Frank, I added them in two VM. One works and one doesn't. Both log files will be attached in a minute. In the non-working case I tried it several times(VBoxManage controlvm ....). Normally I have it all in one line: VBoxManage startvm NAME && VBoxManage controlvm NAME setcredentials user pw domain && exit 0

The non-working VM did autologon in old times before the bug showed up.

Changed 7 days ago by ucrasher2

2 logs (working/non-working)

Changed 7 days ago by ucrasher2

This time it failed even on 64bit VM

comment:14 Changed 7 days ago by ucrasher2

Hi Frank, the previously working 64bit VM ignored the setcredentials this time. Debug regkeys are still in place, so I added the log as well. So it is not likely a 32/64bit issue.

comment:15 Changed 21 hours ago by pentagonik

Could you please give the latest 5.1.x Guest Additions (r114195) from the Testbuilds page a try whether this fixes the remaining problems for you?

After installing the Guest Additions, a VM reboot is needed. Thanks!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use