VirtualBox

Ticket #16564 (closed defect: fixed)

Opened 7 months ago

Last modified 6 months ago

Shared folder mount fails with "No such file or directory" after upgrade

Reported by: Aleko Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.1.16 Keywords: shared mount vagrant
Cc: Guest type: Linux
Host type: Windows

Description

I have a Windows 10 host and several Linux (mostly Ubuntu) virtual machines created by Vagrant. After upgrading from 5.1.14 to 5.1.16 shared folder mount stopped working:

# mount -t vboxsf vagrant /vagrant
/sbin/mount.vboxsf: mounting failed with the error: No such file or directory

I noticed that Vagrant registered shared folder paths in the following format:

\\?\C:\Path\To\MyStuff

As soon as I removed the leading "\\?\" from the path, the mount command worked again.

After downgrading back to 5.1.14, the mount works again without any issues, so this looks like a regression in 5.1.16.

Change History

comment:1 Changed 7 months ago by socratis

A quick search could have revealed the following:

  1. There is already an open ticket about this, #14651: Shared folders with long path are not mounted properly.
  2. There is already a fix in the test builds section (>= 113974). Give it a shot.

Duplicate of #14651.

comment:2 Changed 6 months ago by frank

Right. Thanks socratis.

comment:3 Changed 6 months ago by socratis

Thanks for what? Not closing the ticket? Unfortunately I can't close the ticket, you can...

comment:4 Changed 6 months ago by frank

I will leave this ticket open until the new release is available. It is true that the same problem was reported in #14651 but I would have preferred to open a new ticket (like this one) instead of re-opening #14651.

comment:5 Changed 6 months ago by Aleko

Thank you! I did search for tickets but the problem was clearly a regression in the most recent version so I didn't even look at tickets opened against 5.0.4. Also, #14651 itself describes a completely different issue so I disagree it's a duplicate. Yes, the recent comments do bring up the new issue, but one wouldn't easily find those with a quick search.

comment:6 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.1.18.

comment:7 Changed 6 months ago by Aleko

Cool, will check it out when I get a chance! There is a problem with the change log:

Shared Folders: fixed access to long pathes (5.1.16 regression; Windows guests only; bugs #14651, #16564)

Should it say "Windows hosts only"?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use