VirtualBox

Ticket #1637 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Linux unable to mount Shared folder if folder name is same with mount path

Reported by: nnnf Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description

/sbin/mount.vboxsf: mounting failed with the error: Protocol error

The error above will be shown when typing the following command:

sudo mount -t vboxsf vfolder /home/myname/vfolder/ (this is Ubuntu 8.04)

The shared folder settings: Folder name: vfolder Folder path: c:\vfolder

It will work, however, if a different name is given for the mount dst path, eg. /home/myname/abc

Change History

comment:1 Changed 6 years ago by michael

This is a known issue - the mount command thinks that the share name is a file on disk and tries to expand its path - so it expands the sharename "vfolder" to "/home/myname/vfolder/". Try using "mount.vboxsf" instead of "mount -t vboxsf".

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #928, see explanation there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use