VirtualBox

Ticket #16300 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Crash all running machines by typing / in name field of Create-New-Machine

Reported by: real Owned by:
Component: other Version: VirtualBox 5.1.10
Keywords: Crash, filename, path Cc: your mother
Guest type: all Host type: Linux

Description

1) Have at least one machine running. 2) In virtualbox, click *New (as to make a new machine) 3) Type / as the name 4) Backspace 5) Repeat 3 & 4 until all machines crash 6) Step 4, 5, & 6 are not necessary for this bug to break stuff, but it's more fun that way.

Guest Type does not matter, will crash everything from Windows 6.2 to Bimbo's Linux

I have only tested this where the host machine is Linux (kali), not sure if the same bug is present when host is another OS, although I would venture to assume so.

Qt WARNING: QFileInfo::absolutePath: Constructed with empty filename This is a bug. Maybe you can fix it so that when you accidentally type a / in the name field of a new machine, you don't crash every freaking running VM... Just a thought. Perhaps, yeah? You can fix? Okay vunderbar

Change History

comment:1 Changed 5 years ago by real

I apologize for creating a duplicate ticket (#16300 & #16299)


Click new machine


Press /


Close out of create new machine window


Wait a spoonful of seconds & viola


You done crashed

Last edited 5 years ago by real (previous) (diff)

comment:2 Changed 5 years ago by real

How easy it is to crash a machine-- Let's say you have 12 production nodes up


Create New Machine, Accidentally hit /, all your stuff crashes...


at best that's at least 5 minutes of downtime!

comment:3 Changed 5 years ago by real

Extra Note: This is version 5.1.8


VirtualBox Graphical User Interface Version 5.1.8_Debian

comment:4 Changed 5 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #16299, so no point having everything twice.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use