VirtualBox

Ticket #16299 (closed defect: fixed)

Opened 3 months ago

Last modified 3 months ago

Crash all running machines by typing / in name field of Create-New-Machine

Reported by: real Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.10 Keywords: Crash, filename, path
Cc: your mother Guest type: all
Host type: Linux

Description (last modified by frank) (diff)

  1. Have at least one machine running.
  2. In virtualbox, click *New (as to make a new machine)
  3. Type / as the name
  4. Backspace
  5. Repeat 3 & 4 until all machines crash
  6. Step 4, 5, & 6 are not necessary for this bug to break stuff, but it's more fun that way.

Guest Type does not matter, will crash everything from Windows 6.2 to Bimbo's Linux

I have only tested this where the host machine is Linux (kali), not sure if the same bug is present when host is another OS, although I would venture to assume so.

Qt WARNING: QFileInfo::absolutePath: Constructed with empty filename This is a bug. Maybe you can fix it so that when you accidentally type a / in the name field of a new machine, you don't crash every freaking running VM... Just a thought. Perhaps, yeah? You can fix? Okay vunderbar

Change History

comment:1 Changed 3 months ago by real

This is the error that occurs-

A critical error has occurred while running the virtual machine and the machine execution should be stopped.

For help, please see the Community section on  https://www.virtualbox.org or your support contract. Please provide the contents of the log file VBox.log, which you can find in the virtual machine log directory, as well as a description of what you were doing when this error happened. Note that you can also access the above file by selecting Show Log from the Machine menu of the main VirtualBox window.

Press OK to power off the machine.

comment:2 Changed 3 months ago by real


Click new machine


Press /


Close out of create new machine window


Wait a spoonful of seconds & viola

You done crashed.

Last edited 3 months ago by real (previous) (diff)

comment:3 Changed 3 months ago by real

Version 5.1.8


... My apologies for creating a duplicate ticket (#16299 #16300) ... Sorry I was freaking out because I just crashed all my vm's ... they were all doing very important business... just kidding


comment:4 Changed 3 months ago by klaus

WOW... confirmed. Clearly an API bug, but I wonder why the GUI makes the failing API call straight after typing in / - I see no reason for that right now, but maybe looking at the GUI code will tell more.

comment:5 Changed 3 months ago by socratis

Simply amazing! Hosts:

  • OSX 10.9.5 with 5.1.11 rev112223 (Qt5.6.2) Crashes the VMs.
  • Windows 7 with 5.1.10 rev112026 (Qt5.6.2) Does NOT crash any VM!

comment:6 Changed 3 months ago by frank

  • Description modified (diff)

comment:7 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use