VirtualBox

Ticket #16202 (closed defect: fixed)

Opened 4 years ago

Last modified 12 months ago

Unable to start guests on Windows 10 Insider build 14971

Reported by: teh_klev Owned by:
Component: other Version: VirtualBox 5.1.8
Keywords: Cc:
Guest type: all Host type: Windows

Description

Windows 10 Pro (x64) Insider build 14971 arrived today and VirtualBox is know no longer to start any of my VM's

The following appears in a dialogue box:

Title: VirtualBox - Error In supR3HardNtChildPurify

Message:

supHardenedWinVerifyProcess failed with VERR_CR_X509_CPV_NOT_VALID_AT_TIME: (rc=-23033) Please try reinstalling VirtualBox.

where: supR3HardNtChildPurify what: 5 VERR_CR_X509_CPV_NOT_VALID_AT_TIME (-23033) - Certificate path validator: The certificate is not valid at the specified time.

I've tried reverting to VBox 5.1.6 & 5.1.7 and also installing the 5.1.9-111957 test build.

The VBoxHardening.log file reports some kind of certificate validation problem with ntdll.dll in \Windows\System32:

118c.1b38: supHardenedWinVerifyProcess failed with Unknown Status -23033 (0xffffa607): Certificate is not valid (ValidTime=2088-08-14T12:05:18.000000000Z Validity=[2014-05-28T17:33:33.000000000Z...2029-05-28T17:43:33.000000000Z]): \Device\HarddiskVolume4\Windows\System32\ntdll.dll

118c.1b38: Error -23033 in supR3HardNtChildPurify! (enmWhat=5)

118c.1b38: supHardenedWinVerifyProcess failed with Unknown Status -23033 (0xffffa607): Certificate is not valid (ValidTime=2088-08-14T12:05:18.000000000Z Validity=[2014-05-28T17:33:33.000000000Z...2029-05-28T17:43:33.000000000Z]): \Device\HarddiskVolume4\Windows\System32\ntdll.dll

Attachments

VBoxHardening.log Download (10.0 KB) - added by teh_klev 4 years ago.
VBox.log Download (112.9 KB) - added by teh_klev 4 years ago.

Change History

Changed 4 years ago by teh_klev

Changed 4 years ago by teh_klev

comment:1 Changed 4 years ago by Bobbyw87

I am experiencing the same exact problem.

comment:2 Changed 4 years ago by socratis

Please use the search functionality before opening a new bug. This is a duplicate of #16198.

Also, discussion on  https://forums.virtualbox.org/viewtopic.php?f=38&t=80701

comment:3 Changed 4 years ago by teh_klev

Sorry, my search-fu failed me utterly here. Also hadn't noticed the newish "VirtualBox on Windows pre-releases" forum.

comment:4 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #16198, as mentioned before.

comment:5 follow-up: ↓ 6 Changed 4 years ago by klaus

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Duh. Should've checked why #16198 was closed before closing this one as a duplicate.

The fix is in the latest testbuilds, and will be in 5.1.10.

comment:6 in reply to: ↑ 5 Changed 4 years ago by socratis

Replying to klaus:

Duh. Should've checked why #16198 was closed before closing this one as a duplicate.

It's OK, we've had a good 3 minutes of back and forth. Literally... :D

comment:7 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.10.

comment:8 Changed 12 months ago by MattPark

Not trying to zombie this but when I got the error message, this was the first result, and not very helpful.

PSA: If you are running a windows insider preview build, they expire periodically if you don't update. Virtualbox will notice the expired cert and block you from starting your VMS. Check your windows expiration date with winver command.

For me, the build wasn't updating because I had blocked their diagnostic spying at some point. Hope this helps.

Back to the grave....

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use