VirtualBox

Ticket #16155 (closed defect: fixed)

Opened 8 months ago

Last modified 6 months ago

VirtualBox kernel module broken with Linux 4.9 (RC3) and VirtualBox 5.1.8 / 5.1.9 (nightly)

Reported by: aplocher Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.8 Keywords: get_user_pages_remote, kernel, linux-4.9
Cc: Guest type: all
Host type: Linux

Description

Attached is the vbox-install.log

When installing VirtualBox 5.1.8 or 5.1.9 on Linux Kernel 4.9 (RC3 - I think RC2, too), it comes back with an error:

Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.1.9 r111724 (2016-11-03T17:15:53Z) installer
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.

VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual
  /opt/VirtualBox/UserManual.pdf
and in the user FAQ
  http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.


The installation appears to work, but when attempting to boot a VM, I receive the following:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

This seems to be related to the following update to the Linux Kernel in 4.9, which caused the argument signature to change for "get_user_pages_remote":

 https://github.com/torvalds/linux/commit/9beae1ea89305a9667ceaab6d0bf46a045ad71e7

Attachments

vbox-install.log Download (87.1 KB) - added by aplocher 8 months ago.

Change History

Changed 8 months ago by aplocher

comment:1 Changed 8 months ago by socratis

Duplicate of #16116.

comment:2 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 5.1.10.

comment:3 Changed 6 months ago by Vamp898IIIPD

Running Linux Kernel 4.9.0, trying to compile VirtualBox 5.1.10 im still able to reproduce this bug.

I found others using Kernel 4.9.0 and VirtualBox 5.1.10 who are also able to reproduce this bug (especially Gentoo users).

comment:4 Changed 6 months ago by Vamp898IIIPD

Tested again with 5.1.12, neither works there.

Tested again with this pacht  https://598800.bugs.gentoo.org/attachment.cgi?id=454118

now it seems to work.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use