VirtualBox

Opened 8 years ago

Closed 8 years ago

#16085 closed defect (worksforme)

Headless/detachable VM cannot be detached (again)

Reported by: DosAmp Owned by:
Component: guest control Version: VirtualBox 5.1.8
Keywords: Cc:
Guest type: all Host type: other

Description

Summary: Since the upgrade to VirtualBox 5.1.6, any VM started with the "Detachable" or "Headless" (after pressing "Show") option lacks the option "Keep running in the background" from the "Close VM" dialog, which prevents the VM from being (re-)detached.

Host: Windows 7 x64

Guest: various (happens with both graphical Linux desktop clients as well as a console-only router VM)

Versions tested/affected: 5.1.6, test build 5.1.7r110653 (see below), 5.1.8

Additional info: Ticket #15928 seems to have fixed part of the issue where attached VMs do not respond to keyboard input, but the VM window still behaves as if the VM was started normally.

Attachments (1)

VBox.log (98.7 KB ) - added by DosAmp 8 years ago.

Download all attachments as: .zip

Change History (3)

by DosAmp, 8 years ago

Attachment: VBox.log added

comment:1 by Socratis, 8 years ago

Actually it's all version since 5.1 beta. It was a deliberate change. It's under the "File" menu now. See: https://forums.virtualbox.org/viewtopic.php?f=15&t=78516 especially the explanations by "michaln".

This is not a bug. It's by design.

comment:2 by Frank Mehnert, 8 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use