VirtualBox

Ticket #15928 (closed defect: fixed)

Opened 15 months ago

Last modified 13 months ago

keyboard not working

Reported by: infinity Owned by:
Priority: major Component: guest control
Version: VirtualBox 5.1.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

The keyboard does not work for guest when I updated from 5.1.4 to 5.1.6, my host is Windows 10 and guest is Oracle Linux 7.2. When I start the VM using "Headless Start" or "Detachable Start" the keyboard does not work, but if I start the VM using "Normal Start" the keyboard works properly. Also, please refer to the following link (others are experiencing same issue):  https://forums.virtualbox.org/viewtopic.php?f=6&t=79702

Attachments

VBox.log Download (86.3 KB) - added by infinity 15 months ago.
log file

Change History

Changed 15 months ago by infinity

log file

comment:1 Changed 15 months ago by daabm

Same issue here - Host W2012R2, tested VirtualBox 5.1.6 and current testbuild 5.1.7r110653. In headless/detachable, keyboard does not work after pressing host key once. In normal mode, keyboard works.

comment:2 Changed 14 months ago by Dsen

Thank you for noticing that issue.
It should be fixed in the nearest maintenance release.
Could you please confirm that the issue is fixed for you within the following test build:
https://www.virtualbox.org/download/testcase/VirtualBox-5.1.7-110792-Win.exe

comment:3 Changed 14 months ago by daabm

Confirmation: Issue fixed in 5.1.7 as linked above. Thank you!

comment:4 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback! Fix is part of VBox 5.1.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use