VirtualBox

Ticket #1595 (reopened defect)

Opened 6 years ago

Last modified 3 years ago

VERR_SSM_UNEXPECTED_DATA, when I attempt to resume a saved Virtual Machine -> Fixed in SVN

Reported by: maxo Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Sometimes I am getting this error msg: (VERR_SSM_UNEXPECTED_DATA), when I attempt to resume a saved Virtual Machine.

The host is Vista and the guest is a Windows XP.


Unable to restore the virtual machine's saved state from 'M:\VM\Machines\Windows Xp Sviluppo\Snapshots\{ce28664d-45f3-46dd-8468-9ba91a689e7b}.sav'. It may be damaged or from an older version of VirtualBox. Please discard the saved state before starting the virtual machine. VBox status code: -1829 (VERR_SSM_UNEXPECTED_DATA).

Codice&nbspd'uscita: E_FAIL (0x80004005) Componente: Console Interfaccia: IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

Attachments

VBox.log Download (33.4 KB) - added by ian320 6 years ago.
VirtualBox Log File
VBox.2.log Download (39.0 KB) - added by kalin 6 years ago.
host: Gentoo, amd64; guest:WinXPSP3
VBox.3.log Download (41.1 KB) - added by teratorn 6 years ago.
Ubuntu 8.04 (host). XP SP2 (guest).
VBox.log.1 Download (54.3 KB) - added by lakitu 6 years ago.
VBox.log.2 Download (47.7 KB) - added by Leak 5 years ago.
Windows7-2009-06-10-12-02-47.log Download (45.9 KB) - added by pwaller 5 years ago.
Windows 7 vbox.log
VBox.4.log Download (56.4 KB) - added by gfa 4 years ago.
host: debian lenny amd64, guest: win xp sp3
VBox.log.3 Download (61.8 KB) - added by toppi 4 years ago.
Log - fail after changing shared directories
vboxlog.log Download (52.8 KB) - added by danf84 4 years ago.

Change History

comment:1 Changed 6 years ago by sandervl73

Could you retry with 1.6.2 and include the VBox.log file of the failing resume here?

Changed 6 years ago by ian320

VirtualBox Log File

comment:2 Changed 6 years ago by ian320

I also get this error every time I try to restore my saved VM. Here are the exact things I do:

  1. Save my Windows XP Pro SP3 virtual machine.
  2. Shut down my Ubuntu 8.04 host machine.
  3. Boot back into Ubuntu and start VirtualBox.
  4. Start my XP VM.

The progressbar goes all the way across, and then I get this error. It has happened without fail every time and is quite annoying.

I have attached my VirtualBox log file for more information.

comment:3 Changed 6 years ago by ian320

Forgot to mention I am using VirtualBox 1.6.2 (Closed source edition).

Changed 6 years ago by kalin

host: Gentoo, amd64; guest:WinXPSP3

comment:4 Changed 6 years ago by kalin

I started having this error every now and then when I try to restore a saved machine state on VirtualBox-1.6.2 (binary).

It seems that if I save the state, then start the VM there is NO problem, I cannot reproduce it.

If I do something (say restart X), I get this problem sometimes.

Any ideas for further testing?

comment:5 Changed 6 years ago by teratorn

I just got this same error for the first time. Host is Ubuntu Linux 8.04. Guest is Windows XP SP2. I had suspended the VM, them hibernated my Linux host. Upon resuming my Host, I then tried to resume the Guest, and it resulted in the error above.

Only things I can think of would be the facts that one of my shared folders would not have been available on the Host, and my CPU speeds may not have been the same as when the Guest was saved (Intel Core 2 Duo).

My log file is attached.

Changed 6 years ago by teratorn

Ubuntu 8.04 (host). XP SP2 (guest).

comment:6 Changed 6 years ago by frank

Hmm, if a shared folder is not available during resume you would not be able to resume the VM, the GUI would refuse to load the settings (this is another bug which has to be fixed). But your attached log file clearly states that the HGCM unit (which is responsible for shared folders, shared clipboard and some other mechanisms) is causing this problem. The changing CPU frequency doesn't matter here.

comment:7 Changed 6 years ago by frank

  • Component changed from other to VM control

Changed 6 years ago by lakitu

comment:8 in reply to: ↑ description Changed 6 years ago by lakitu

hey. got same error, after doing a snapshot save, & then trying to restore. host Ubuntu Hardy (8.04) & guest Win XP, VBox 2.0.

this worked for me: recompile the package/application.

for my install (a default one), the command in Ubuntu 8.04 was "sudo /etc/init.d/vboxdrv setup"

hope this serves as a temporary fix for some. i haven't checked yet if you must do this everytime or not.

for the techs, i had tried using VBoxManage to start my VM a couple times, & might've thrown something off that way (just used sudo VBoxManage --startvm "winky" - but that didn't work, & seemed to go into some VRDP(?) mode for a bit, so i had to recompile & that fixed it). but you should note, it *WAS WORKING* after i did the command line stuff, so i think it's just the snapshot that did it.

comment:9 Changed 6 years ago by lakitu

thanks for great free software, btw! =)

comment:10 Changed 5 years ago by kcarnold

Just hit this same bug. I had set up an external drive as a shared folder, then did some combination of suspending the VM, unmounting the drive, resuming the VM, etc. (probably several suspend-resume cycles). When I reconnected and mounted the drive again, I got the indicated error message.

Fixed by unmounting the external drive (so the shared folder location didn't exist). That was a workaround...

comment:11 Changed 5 years ago by denilsonsa

I've also stumbled upon this bug. It is probably related to some shared folder that might have changed its state or maybe have become unavailable. I don't remember exactly what folder I had mounted, and what folders I changed.

The lack of useful information at the error message isn't helping either.

Shared folders shouldn't prevent the VM from restoring its state.

VirtualBox 1.6.6 (closed source version) running on Gentoo amd64, with Windows XP as guest.

comment:12 follow-up: ↓ 13 Changed 5 years ago by Tahiti

This happened when there is a temporary shared folder. With XP and XP in virtual box 2.2.2: 1-Start vm (with 2 permanent shared folders), save state : resume ok. 2-Start same vm, add temporary shared folder on c:\, save state : resume error.

comment:13 in reply to: ↑ 12 Changed 5 years ago by denilsonsa

Replying to Tahiti:

This happened when there is a temporary shared folder. [...], add temporary shared folder on c:\, save state : resume error.

Exactly the same here. This is a way to reproduce this bug.

Changed 5 years ago by Leak

comment:14 Changed 5 years ago by Leak

I've also encountered this error today, and the only thing I did different to before was adding a temporary shared folder "Stick" mapped to drive F:\, which was a 2G USB drive I needed to transfer some data.

Here's what happened (full log attached):

00:00:04.007 Changing the VM state from 'CREATING' to 'CREATED'.
00:00:04.007 SharedFolders host service: adding host mapping.
00:00:04.007     Host path F:\, map name Stick, writable 1
00:00:04.007 SharedFolders host service: add mapping result VINF_SUCCESS
00:00:04.007 SharedFolders host service: adding host mapping.
00:00:04.007     Host path C:\Temp, map name Temp, writable 1
00:00:04.008 SharedFolders host service: add mapping result VINF_SUCCESS
00:00:04.008 Changing the VM state from 'CREATED' to 'LOADING'.
00:00:05.443 SSM: File header: Format V1.2, VirtualBox Version 2.2.2 r46594, 32-bit host, cbGCPhys=8, cbGCPtr=8
00:00:08.898 TM: cTSCTicksPerSecond=0x9e8c5a00 (2659998208) fTSCVirtualized=true  fTSCUseRealTSC=false (state load)
00:00:08.903 PIT: mode=2 count=0x4ad (1197) - 996.81 Hz (ch=0) (restore)
00:00:08.903 RTC: stopped the periodic timer (restore)
00:00:08.903 SharedFolders host service: connected, u32ClientID = 1
00:00:08.903 SharedFolders host service: loading state, u32ClientID = 1
00:00:08.903 SSM: LoadExec failed with rc=VERR_SSM_UNEXPECTED_DATA for unit 'HGCM'!
00:00:08.952 Changing the VM state from 'LOADING' to 'LOAD_FAILURE'.

So it looks like restoring state for temporary folders is b0rked - it doesn't matter if I actually re-connect the USB drive or not, I still get the same error.

comment:15 Changed 5 years ago by denilsonsa

I've tested this again on version 2.2.2. It seems to be fixed in that version, because the temporary folders are restored with the machine state.

Not sure if 2.0 has it fixed or not, but I know that 2.2.2 works for me.

comment:16 Changed 5 years ago by Leak

Doesn't seem fixed to me; I added another permanent shared folder to a folder on my C: drive yesterday, closed down the VM with saving it's state and today I'm greeted with yet another

00:00:03.221 VirtualBox 2.2.2 r46594 win.x86 (Apr 27 2009 19:32:09) release log
00:00:03.221 Log opened 2009-05-28T10:33:40.248144300Z
00:00:03.221 OS Product: Windows XP Professional
00:00:03.221 OS Release: 5.1.2600
00:00:03.222 OS Service Pack: 2
00:00:03.222 Package type: WINDOWS_32BITS_GENERIC
[...]
00:00:03.992 SharedFolders host service: adding host mapping.
00:00:03.992     Host path C:\Download, map name Download, writable 1
00:00:03.992 SharedFolders host service: add mapping result VINF_SUCCESS
00:00:03.992 SharedFolders host service: adding host mapping.
00:00:03.992     Host path C:\Temp, map name Temp, writable 1
00:00:03.992 SharedFolders host service: add mapping result VINF_SUCCESS
00:00:03.992 Changing the VM state from 'CREATED' to 'LOADING'.
00:00:05.364 SSM: File header: Format V1.2, VirtualBox Version 2.2.2 r46594, 32-bit host, cbGCPhys=8, cbGCPtr=8
00:00:08.819 TM: cTSCTicksPerSecond=0x9e8a8c00 (2659879936) fTSCVirtualized=true  fTSCUseRealTSC=false (state load)
00:00:08.824 PIT: mode=2 count=0x4ad (1197) - 996.81 Hz (ch=0) (restore)
00:00:08.824 RTC: stopped the periodic timer (restore)
00:00:08.824 SharedFolders host service: connected, u32ClientID = 1
00:00:08.824 SharedFolders host service: loading state, u32ClientID = 1
00:00:08.824 SSM: LoadExec failed with rc=VERR_SSM_UNEXPECTED_DATA for unit 'HGCM'!
00:00:08.835 Changing the VM state from 'LOADING' to 'LOAD_FAILURE'.

comment:17 Changed 5 years ago by mzz

I just triggered this when trying to resume a Windows (2000) guest from my linux host with a (temporary) shared folder that no longer existed. Recreating the shared directory on the host allowed the guest to resume. The error message for this problem is not entirely obvious :)

comment:18 Changed 5 years ago by denilsonsa

Indeed, not fixed. I've stumbled upon this bug again with version 2.2.2.

The "best" fix could be to emulate an empty shared folder for folders that don't exist anymore.

Also, a descriptive error message, explaining exactly what went wrong, and why it went wrong, would be very helpful. Something like: "Could not resume the virtual machine because the shared folder 'foobar' (/home/something/somedir/foobar) is not available."

Changed 5 years ago by pwaller

Windows 7 vbox.log

comment:19 Changed 5 years ago by pwaller

I have the same issue on a Gentoo Amd64 host, Win7 Guest, Virtualbox binary 2.2.4. I believe my problem also relates to a shared folder which was unmounted when I tried to resume the saved VM. VM now refuses to resume the saved VM even after mounting the relevant directory.

comment:20 follow-up: ↓ 21 Changed 5 years ago by sunlover

Could not reproduce the problem. Could you please describe how to reproduce it in details? Thanks.

comment:21 in reply to: ↑ 20 Changed 5 years ago by laro

Same problem with VB 2.2.4 (host is Mac OS X 10.4.11, guest is WinXP SP3).

I deleted a shared folder on my Mac desktop but forgot to remove it from the list of shared folders in VB. Booting the guest was fine without any errors, saving the state was fine without any errors, but starting from saved state always failed (just after loading seemed to finish).

Removing this (non-existant anymore) shared folder within VB solved this issue. (BTW: Didn't try to start from saved state with changed shared folders, just tried a fresh boot without bogus shared folder, save state, load state.)

comment:22 Changed 5 years ago by sunlover

VirtualBox 3.0.0 beta has more detailed logging when such a problem occur. Please could anyone reproduce the problem with VBox 3.0.0 and attach Vbox.log to the ticket? Thanks.

comment:23 Changed 5 years ago by lat

FWIW, I had this same error on Mac OS X 10.4.11 with a VM with 2 shared folders when 1) I had VirtualBox running as a normal application but no virtual machines running, and 2) I attempted to start a virtual machine using loading launchctl item which starts a VM with VBoxVRDP.

After I quit VirtualBox as an application and waited for VBoxXPCOMIPCD and VBoxSVC to exit (not sure they did it voluntarily, I also tried killing them from command line), I could then start the headless VM from launchctl just fine. After launchctl had done its job starting the VM, I could also use VirtualBox as an application just fine to start another VM.

So it looks like there is something wrong in the environment started by launchctl that prevents VBoxVRDP from talking to daemons that already run, but if those daemons are started from launchctl environment, the application will be happy to talk to them. This is of course just speculation. I didn't try 3.0.0 beta nor removing shared folders.

comment:24 Changed 5 years ago by sunlover

  • Version changed from VirtualBox 1.6.0 to VirtualBox 3.0.0
  • Component changed from VM control to shared folders
  • Summary changed from VERR_SSM_UNEXPECTED_DATA, when I attempt to resume a saved Virtual Machine. to VERR_SSM_UNEXPECTED_DATA, when I attempt to resume a saved Virtual Machine -> Fixed in SVN

Finally the problem has been reproduced and fixed. The fix will be available in a next VBox version.

comment:25 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:26 Changed 4 years ago by gfa

  • Status changed from closed to reopened
  • Resolution fixed deleted

i'm seeing this on 3.1.2-56127_Debian_lenny i can restore the vm using the GUI interface, but it doesn't work using VBoxVRDP or VBoxHeadless

Changed 4 years ago by gfa

host: debian lenny amd64, guest: win xp sp3

comment:27 Changed 4 years ago by gfa

if i disable the 3d acceleration, it works

comment:28 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.0.0 to VirtualBox 3.1.2

Confirmed. Fix is pending.

comment:29 Changed 4 years ago by toppi

I got the same problem in Version 3.1.2 still. Here I exactly remember what happened:

  • Booted Win2000
  • While running Win, I removed 2 shared directories and put 1 new in.
  • In Virtual box, this did not show in Win2000.
  • Later I saved the virtual box state
  • today I tried to resume and the error appeared

=> error is caused by changed shared directory. Virtual Box should not prevent from restoring because of that! Is there a solution in sight? I cannot reboot. I could go back to an old save point but then I lose data. Is there a way to access the harddisk-file from outside virtual box?

00:00:07.585 Changing the VM state from 'DESTROYING' to 'TERMINATED'. 00:00:07.685 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Failed to load unit 'HGCM' (VERR_INVALID_PARAMETER)} aWarning=false, preserve=false 00:00:07.685 Power up failed (vrc=VERR_INVALID_PARAMETER, rc=E_FAIL (0X80004005))

comment:30 Changed 4 years ago by sunlover

toppi, you should attach VBox.log. Then we can look at the problem.

Changed 4 years ago by toppi

Log - fail after changing shared directories

comment:31 Changed 4 years ago by frank

Log file attached ...

Changed 4 years ago by danf84

comment:32 Changed 4 years ago by danf84

Same problem in 3.1.6, folders however exist, and never been tampered with. I saved state on 3 machines at once, and later restored all 3, 1 worked, 2 bombed out with the same error messages. Log attached.

comment:33 Changed 4 years ago by danf84

I backup the whole folder for the VM, discarded the savestate with the problem, removed shared folders, rebooted the VM, did a savestate then overwrote the new savestate file with the old one - didn't work :) looks like the shared folders information is saved with the savestate. One thing might be worth trying is to do the above, but ignoring the step of removing shared folders from settings, but I can't do it since I deleted the savestates.

comment:34 Changed 4 years ago by DerDoc

I re-installed my Linux distro and got the same error. Reading the VirtualBox logfile carefully I found out that the GLX X-Server module was not yet loaded / configured.

Thus, there was no OpenGL acceleration in the Linux host. When attempting to start a saved VM, in which 3D acceleration was enabled, the described error occurred. After enabling GLX (indeed after installing the proprietary Nvidia driver from their webpage), the problem was gone.

Regards, Marcus [Frankfurt/Germany]

comment:35 Changed 3 years ago by csbac

Small note: same thing occurs, of course, when a machine that was running with 3D acceleration in VirtualBox is saved, then continued in VBoxHeadless.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use