VirtualBox

Ticket #1594 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Guest hangs randomly installing Windows 2000

Reported by: underx Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords: win2k install hang
Cc: Guest type: other
Host type: other

Description

While installing Windows 2000 server on a Linux host, the guest processes hang at random. It boots from CD and starts installing, but at some random point during the install process the guest hangs and no further progression can occur. Often it hangs during Windows' long periods of "doing something", whether that is copying files or investigating system hardware, but sometimes also during configuration such as date/time formats.

The hangs usually exhibit the guest mouse pointer continuing to move (controlled by my mouse) but it's an hourglass and it stays that way.

Running VirtualBox 1.6.0 on a Linux host, installed from virtualbox_1.6.0-30421_Debian_etch_i386.deb

The host details - Debian lenny, CPU is Intel(R) Pentium(R) 4 CPU 3.20GHz with hyperthreading, (so 2-cpu SMP). It is kernel 2.6.24.5, tickless.

Kernel logs when I modprobe vboxdrv ...

May 22 18:05:47 host kernel: vboxdrv: Trying to deactivate the NMI watchdog permanently... May 22 18:05:47 host kernel: vboxdrv: Successfully done. May 22 18:05:47 host kernel: vboxdrv: Found 2 processor cores. May 22 18:05:47 host kernel: vboxdrv: fAsync=0 u64DiffCores=3552. May 22 18:05:47 host kernel: vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'. May 22 18:05:47 host kernel: vboxdrv: Successfully loaded version 1.6.0 (interface 0x00070001). May 22 22:03:31 host kernel: vboxdrv: Trying to deactivate the NMI watchdog permanently... May 22 22:03:31 host kernel: vboxdrv: Successfully done. May 22 22:03:31 host kernel: vboxdrv: Found 2 processor cores. May 22 22:03:31 host kernel: vboxdrv: fAsync=0 u64DiffCores=3608. May 22 22:03:31 host kernel: vboxdrv: TSC mode is 'asynchronous', kernel timer mode is 'normal'. May 22 22:03:31 host kernel: vboxdrv: Successfully loaded version 1.6.0 (interface 0x00070001).

As you can see I have tried adding force_async_tsc=1 to the module options; the result is the same.

The guest is Windows 2000 server, install from .ISO file. 256 MB memory, 16 MB video memory (I also tried 8), one virtual disk (8 GB, VDI), Audio none (I also tried with ICH AC97), Network Adapter PCnet-FAST III (NAT).

I tried enabling IO-APIC and changing the IDE controller type from PIIX4 to PIIX3. None of the changes I made so far makes any difference in the random hanging. I'll attach the VM log.

Attachments

win2k iinet2-2008-05-23-00-10-43.log Download (38.0 KB) - added by underx 6 years ago.
VirtualBox log of hanging install attempt

Change History

Changed 6 years ago by underx

VirtualBox log of hanging install attempt

comment:1 Changed 6 years ago by colinvv

I am also attempting to install Win2000sp2 on Ubuntu 2.6.24-17 with VBox 1.5.6. Mine just keeps trying to complete the install... reboots and tries again. Any luck with yours?

comment:2 Changed 6 years ago by Lelik

Can you try v1.6.2?

comment:3 Changed 6 years ago by colinvv

Doing that now on Ubuntu, but the non-OpenSource version requires full kernel to compile the vboxdrv module. on a Fedora8 machine I had the same problem with just the wk2 and found this fix for Windows 2000 SP3 install hang ups. Trying that now as well.

vboxmanage setextradata [virtual machine name] "VBoxInternal/Devices/piix3ide/0/Config/IRQDelay" 1

Thanks for the response! CV

comment:4 Changed 6 years ago by colinvv

Sorry that fix is...

vboxmanage setextradata [virtual machine name] "VBoxInternal/Devices/piix3ide/0/Config/IRQDelay" 1

comment:5 Changed 6 years ago by colinvv

Nope that didn't wok either. I may need to piece together a W2k SP4 iso. Do you know how to do that with nLite?

comment:6 Changed 6 years ago by colinvv

I take that back, the "setextradata" fix did work!

comment:7 Changed 6 years ago by underx

I upgraded to v1.6.2 and the problem is now gone. I also removed force_async_tsc=1.

Ok to close this bug.

comment:8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use