Opened 8 years ago

Closed 7 years ago

#15801 closed defect (fixed)


Reported by: Mop Owned by:
Component: other Version: VirtualBox 5.1.2
Keywords: instruction, stmxcsr, vcpp redist Cc: niall.newman@…
Guest type: Windows Host type: Mac OS X


VirtualBox crashes at a predictable point during the installation of Microsoft Visual C++ Resitributable (x64) version 12.0.21005 via the Visual Studio Community Installer.

The machine crashes every time the package tries to install. I have tested with the latest development version and found it was unable to open a session for the virtual machine let alone boot it.

The host is an Intel Macbook Pro circa 2009 and the guest is Windows 7 x64 SP1.

The issue appears to be that the stmxcsr instruction defined in the Intel 80/86 istruction set is not yet implemented in VirtualBox. I am also aware that this instruction is being used more often in windows 10 software so this issue may become worse over time.

I would be very appreciative if you could implement the instruction as it is causing me a small nightmare since I rely on VirtualBox for my work.

Attachments (5) (130.2 KB ) - added by Mop 8 years ago.
VBox Log file for the crash and PNG view in a zip file
VBox Guru (68.7 KB ) - added by dcampbell 8 years ago.
VBox.log of guru crash (50.5 KB ) - added by Marcello Romani 8 years ago.
VBox.log (419.5 KB ) - added by matte 7 years ago. (95.4 KB ) - added by BjoAce 7 years ago.
Log file for my comment

Download all attachments as: .zip

Change History (18)

by Mop, 8 years ago

Attachment: added

VBox Log file for the crash and PNG view in a zip file

comment:1 by awang, 8 years ago

Got the same thing when installing Cygwin on an 8.1 guest. I'm on a mid-2012 Retina Pro.

comment:2 by dcampbell, 8 years ago

I'm having this same error in 5.1.8. The VM works okay for me until I install the 5.1.8 guest additions and then it will no longer fully load the desktop in Windows. I see the desktop and a couple of seconds later it crashes. VBox.log from one of the crashes is attached. This is on a MacBook Pro 17" Early 2009. Guest is Windows 7 x64 SP1. At the point of this log, Windows was patched up to about January 2016.

by dcampbell, 8 years ago

Attachment: VBox Guru added

VBox.log of guru crash

comment:3 by dcampbell, 8 years ago

I was able to get around this error by disabling the "Enable Nested Paging" option on the VM settings. System::Acceleration::Enable Nested Paging. After unchecking that, my VM booted properly and hasn't crashed for almost 20 hours.

comment:4 by Marcello Romani, 8 years ago

I am seeing this error while trying to install vmware ESXi 6.5

VirtualBox version: Version 5.1.14 r112924 (Qt5.6.2)

I have disabled nested paging but that didn't make a difference. The problem surfaces only when I assign 2 CPUs to the virtual machine. If I only assign 1 CPU, the installer goes on fine. It then stops at the end as it requires 2 CPUs.

by Marcello Romani, 8 years ago

Attachment: added

comment:5 by matte, 7 years ago

I'm seeing this same error and a VM crash on a Mac host with a Win10 VM: VERR_IEM_INSTR_NOT_IMPLEMENTED

00:34:49.756337  FF: 00 00 00
00:34:49.756349 !!
00:34:49.756350 !! {vgagr}
00:34:49.756350 !!
00:34:49.756355 VGA Graphics Controller (3CF): GR index 3CE:05
00:34:49.756360  GR00:00 GR01:00 GR02:00 GR03:00 GR04:00 GR05:50 GR06:05 GR07:0F GR08:FF
00:34:49.756407 !!
00:34:49.756408 !! {vgapl}
00:34:49.756409 !!
00:34:49.756413 read mode     : 0     write mode: 0
00:34:49.756421 set/reset data: 00    S/R enable: 00
00:34:49.756429 color compare : 00    read map  : 0
00:34:49.756436 rotate        : 0     function  : 0
00:34:49.756444 don't care    : 0F    bit mask  : FF
00:34:49.756451 seq plane mask: 0F    chain-4   : on
00:34:49.756459 !!
00:34:49.756459 !! {vgasr}
00:34:49.756460 !!
00:34:49.756464 VGA Sequencer (3C5): SR index 3C4:04
00:34:49.756469  SR00:03 SR01:00 SR02:0F SR03:00 SR04:0A
00:34:49.756496 !!
00:34:49.756496 !! {vgatext}
00:34:49.756497 !!
00:34:49.756501 Not in text mode!
00:34:49.756504 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:34:49.756541 emR3Debug: rc=VERR_IEM_INSTR_NOT_IMPLEMENTED

by matte, 7 years ago

Attachment: VBox.log added

comment:6 by BjoAce, 7 years ago

Same problem here with a VM running a MS SQL Server Express 2012 App (Linear Vereinsverwaltung Premium, a VPN Client). It crashes sometimes, mostly over night.

Host: Mac Mini Mid 2010, macOS Sierra 10.12.3, Core 2 Duo 2,4Ghz, 16 GB DDR3 1067 RAM, 250 GB SSD, VirtualBox 5.1.14 r112924 (QT5.6.2), hibernate is disabled, connected to a Panasonic TV via HDMI which I power off if not needed Guest: Windows 7 Pro with latest updtes, 1 Core, 4GB RAM, 64 MB Graphics Memory, disabled Audio, bridged network, guest additions installed without Direct3D, guest folder on local ssd CPU limit 100%, Paravirtualization legacy, PAE / NX off, nested paging off

Sometimes I access the host via TeamViewer. Now I'll check how to attach a log...

by BjoAce, 7 years ago

Log file for my comment

comment:7 by BjoAce, 7 years ago

Any news?

The problem persists. Now I've found that the installer for MS SQL management studio "ssms-setup-deu.exe" crashes constantly. And it seems that the bug comes more often when the VM is running background tasks... BTW: The interface thing seems to add ~5ms ping time.

Last edited 7 years ago by BjoAce (previous) (diff)

comment:8 by BjoAce, 7 years ago

Solved it with the forum user's help. Solution for those who find this: Managed to downgrade the VirtualBox installation (including tools etc) to v5.0.32 r112930. Over the last 3 days, the problem didn't occur anymore. And I could run the installer I noticed below...

comment:9 by Frank Mehnert, 7 years ago

Sorry, no fix yet. VBox 5.1.x depends a bit more on the nested paging feature, at least on Mac OS X. But this will be fixed eventually.

comment:10 by Socratis, 7 years ago

At least there's a workaround for now. I'm not bitten by that bug personally, I simply have seen the issue come up more often with the adoption of 5.1.x. And I'm taking this as a chance to Cc: myself to the ticket...

comment:11 by Marcello Romani, 7 years ago

I can confirm that after downgrading from 5.1.x to 5.0.32 I did not see the VERR_IEM_INSTR_NOT_IMPLEMENTED error any more.

Another issue has come up though:

HARDWARE_VIRTUALIZATION WARNING: Hardware Virtualization is not a feature of the CPU, or is not enabled in the BIOS

Installation went on nonetheless but eventually stopped with:

Unable to successfully execute 'tryFormatDevice' after 3 tries
Version 3, edited 7 years ago by Marcello Romani (previous) (next) (diff)

in reply to:  11 comment:12 by Socratis, 7 years ago

Replying to virtualtux:

Another issue has come up though:

@virtualtux: the bug report discussions are specific to each bug. If you have questions/problems/issues, please go to the forums and open an appropriate thread in an appropriate forum. If it is deemed to be a bug (95% are not), then you could open an appropriate bug report.

comment:13 by Frank Mehnert, 7 years ago

Resolution: fixed
Status: newclosed

Should be fixed in 5.1.22.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use