VirtualBox

Ticket #15713 (closed defect: duplicate)

Opened 14 months ago

Last modified 12 months ago

guest additions do not build with 4.8 kernel -> duplicate of #15695.

Reported by: robatino Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.2 Keywords:
Cc: Guest type: Linux
Host type: other

Description

Got an error message while attempting to install guest additions in a Fedora Rawhide guest for the 4.8.0-0.rc0.git2.1.fc26.x86_64 kernel (worked with the last 4.7 kernel).

vboxadd.sh: failed: Look at /var/log/vboxadd-install.log to find out what went wrong.

There was more, but I only wrote down the above. With the old pre-5.1 vbox, I could reproduce the error with "dkms install", but I don't know how to do it with the new vbox, short of removing and reinstalling the new kernel.

Attachments

vboxadd-install.log Download (75.4 KB) - added by robatino 14 months ago.
/var/log/vboxadd-install.log
VBox.log Download (120.3 KB) - added by robatino 14 months ago.
vboxadd-install.2.log Download (232.7 KB) - added by robatino 13 months ago.
/var/log/vboxadd-install.log
VBox.2.log Download (125.4 KB) - added by robatino 13 months ago.

Change History

Changed 14 months ago by robatino

/var/log/vboxadd-install.log

Changed 14 months ago by robatino

comment:1 Changed 14 months ago by robatino

Full message:

vboxadd.sh: failed: Look at /var/log/vboxadd-install.log to find out what went wrong.
vboxadd.sh: failed: Please check that you have gcc, make, the header files for your Linux kernel and possibly perl installed.

As I said, it worked with the previous 4.7 kernel, and I had VB 5.1.2 installed at the time, so I'm sure that all necessary packages are installed.

comment:2 Changed 14 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from guest additions do not build with 4.8 kernel to guest additions do not build with 4.8 kernel -> duplicate of #15695.

Duplicate of #15695.

comment:3 Changed 13 months ago by robatino

#15695 has been closed, but building guest additions for a 4.8 kernel failed in VirtualBox 5.1.4. Attaching /var/log/vboxadd-install.log.

Changed 13 months ago by robatino

/var/log/vboxadd-install.log

Changed 13 months ago by robatino

comment:4 Changed 13 months ago by robatino

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:5 Changed 13 months ago by robatino

The odd thing is that when I initially installed the guest additions the other day using the VBoxLinuxAdditions.run command, it worked. But when I installed a new 4.8 kernel today, triggering an automatic attempt to build the guest additions, it failed.

comment:6 Changed 13 months ago by robatino

The problem appears to be gone with VirtualBox 5.1.6. When installing the latest kernel in my Rawhide guest, the error does not occur.

comment:7 Changed 13 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the information!

comment:8 Changed 12 months ago by el_schalo

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have still the same issue using the latest VirtualBox Version (5.1.6 r110634) on a Windows 7 Host running the lates SLES12 Version (SLE-12-SP1-Server-DVD-x86_64-GM). What am I doing wrong?

BTW: the bidirectional usage of the clipboard doesn't work neither - is there a correlation?

comment:9 Changed 12 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

el_schalo, if you will ever open tickets which are opened as duplicates for no good reason then I will ban you.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use