VirtualBox

Ticket #15714 (closed defect: fixed)

Opened 23 months ago

Last modified 3 months ago

Ctrl-click acts as right-click

Reported by: imgse Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.2 Keywords: ctrl click
Cc: Guest type: Windows
Host type: Mac OS X

Description

With VirtualBox 5.1.2 on OSX 10.11.6 with a Win xp VM, Ctrl-click acts as right-click. Problem! • With VirtualBox 5.0.26 on OSX 10.11.6 with the same Win xp VM, Ctrl-click acts as Ctrl-click. No problem.

Attachments

VBox.log Download (108.9 KB) - added by imgse 23 months ago.

Change History

Changed 23 months ago by imgse

comment:1 Changed 23 months ago by socratis

comment:2 Changed 23 months ago by twinhats

I can confirm this is also a problem in 5.1.2 with an OS X 10.11.13 Host and a Windows 10 Guest. Worked in 5.1.0. Makes some aspects of Windows Apps unusable.

comment:3 Changed 23 months ago by socratis

Since everyone that reports this seems to be on 10.11.x, add my voice too, on OSX 10.9.5. All guests show this behavior, independent of GAs. Even Linux LiveCDs.

comment:4 Changed 23 months ago by gdt95

Me too. OS X 10.11.6, VB 5.1.2, Windows 10 Guest. I don't remember this on the previous VB version 5.0.?.

comment:5 Changed 23 months ago by tekrum

Same here, OSX 10.11.6 VB 5.1.0, WIndows 8.1 Guest

comment:6 Changed 22 months ago by gdt95

This is still a problem in 5.1.4.

comment:7 Changed 22 months ago by romanz

Confirmed. Still a problem. OSX 10.11.6 VB 5.1.4, Windows 8.1 Guest

comment:8 Changed 22 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.6. Please reopen if necessary.

comment:9 Changed 3 months ago by wnm3

Using 5.2.9 on macOS 10.13.4 and right mouse click is not possible. Also, not possible on Version 5.2.8 r121009 (Qt5.6.3). This is attempting to use the touch pad. A bluetooth mouse works fine...

This is fixed by changing the touchpad setting in the MacOS System Preferences. There is a link under Secondary (which should be checked) to select how the right click is recognized. Select to use the bottom right button and it works fine.

Described in the forum here:  https://forums.virtualbox.org/viewtopic.php?f=8&t=66365&p=314258&hilit=right+mouse+click+touchpad+mac#p314258

Last edited 3 months ago by wnm3 (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use