VirtualBox

Ticket #15659 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

PCM missing warning on all VMs, independent of sound controller.

Reported by: socratis Owned by:
Component: audio Version: VirtualBox 5.1.2
Keywords: Cc:
Guest type: all Host type: Mac OS X

Description

Warning at startup of every VM under the sun:

The virtual machine execution may run into an error condition as described below. We suggest that you take an appropriate action to avert the error.

The Details differ, depending on the sound controller.

AC97

Some AC'97 audio streams (PCM Output) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem.

Error ID: HostAudioNotResponding

Severity: Warning

Attachments

5.1.2-Mint17-PCMWarning.zip Download (58.6 KB) - added by socratis 4 years ago.
Mint 17 with builds 108857 (OK) and 108931 (Problem)
VBox.log Download (132.4 KB) - added by thorhall 4 years ago.
VBox.log with same error using Win 10 guest and intel HD audio setting in guest OS
110033-10.8-VBox.logs.zip Download (51.7 KB) - added by socratis 4 years ago.
VBox.log is with the NULL controller, VBox.log.1 is with the HDA controller. Host 10.9.5, guest 10.8.

Change History

comment:1 Changed 4 years ago by socratis

Workaround for crashes: Change the Host Driver to "Null Audio Driver".


And this is what happens when I press Submit instead of Preview. Continuing...

HDA

Same text, except where it says 'AC'97' is says 'HDA'

SB16

No audio devices could be opened. Selecting the NULL audio backend with the consequence that no sound is audible.

I was trying dev builds and I happened to have available some. The problem occurs between builds 108857 and 108931.

Attaching a sample session from a Mint 17, 64-bit client. They're all the same in any event.

Last edited 4 years ago by socratis (previous) (diff)

Changed 4 years ago by socratis

Mint 17 with builds 108857 (OK) and 108931 (Problem)

comment:2 Changed 4 years ago by pteeson

Same under OS X Yosemite 10.10.5 on a Mac Pro, 4,1 host for Debian, OpenBSD, And Win XP SP3 guests.

A similar message "Some HDA audio streams (PCM Output) could not be opened...." for OS X Mavericks 10.9 and Snow Leopard 10.6 guest machines.

Changed 4 years ago by thorhall

VBox.log with same error using Win 10 guest and intel HD audio setting in guest OS

comment:3 in reply to: ↑ description Changed 4 years ago by thorhall

This Same problem happens with Intel HD Audio and AC97 Audio under Mac OS 10.11.6

Replying to socratis:

Warning at startup of every VM under the sun:

The virtual machine execution may run into an error condition as described below. We suggest that you take an appropriate action to avert the error.

The Details differ, depending on the sound controller.

AC97

Some AC'97 audio streams (PCM Output) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem.

Error ID: HostAudioNotResponding

Severity: Warning

comment:5 Changed 4 years ago by pteeson

FWIW I reverted to 5.0.26 and there were no warnings for the guest machines I mentioned in comment2

I have the logs from 5.1.2 as well as 5.0.26 if they could be of help....

comment:6 Changed 4 years ago by Mastiff

Same problem encountered for MacOS 10.11.5 (MacBook Pro Retina, 13-inch, Early 2015), after upgrade from 5.1.0 to 5.1.2.

comment:7 Changed 4 years ago by gollum12345678

I am experimenting the same issue on OSX 10.11.6 after upgrading form 5.1.0 to 5.1.2

comment:8 Changed 4 years ago by Marketing Software Australia

Confirmed, same issue with HostAudio not being available.

Host: Mac OS X El Capitan (10.11.6) on MacBook Pro (17-inch, Early 2011)

Guest: Brand New Windows 10 (64-bit) VM (No OS installed, blank VDI); + All established VMs.

Please note, although the warning message states the guest OS may crash, they appear to operate normally as though the audio output device is set to NULL. This would seem to indicate a regression where the audio output device is not initialised properly.

comment:9 Changed 4 years ago by jvanderb

Same problem for me, although I didn't see this ticket at the time. I opened ticket 15686 for this issue as well.

comment:10 Changed 4 years ago by kpower

Same problem. Worked perfectly on VB 5.1.0. Tried upgrading, reinstalling with old guest's HDD reusing, clean reinstalling (even used CleanMyMac to clear all possible data).

Host: OS X El Capitan 10.11.6 on Mac Mini late 2012.

Guest: Windows XP (32-bit)

comment:11 Changed 4 years ago by VKH

Same problem for me. Have win7 x64 and win10 x64 guests and both have the issue with 5.1.2 on OS X El Capitan 10.11.6 on MacBook Pro Early 2015. Rolled back to 5.1 and the problem does not exist.

comment:12 Changed 4 years ago by nfolken

Same problem.
Host: Mac OS 10.11.6
Guest: OpenSuse and WindowsXP
Virtualbox 5.1.2 (with same guest additions version)
Guest claims to see the virtual sound card, but no audio makes it out of VirtualBox. Checking the VirtualBox log file shows this:

00:00:01.860811 Audio: Initializing Core Audio driver
00:00:01.874287 Audio: Initializing VRDE driver
00:00:01.874309 AC97: Reset
00:00:01.874421 CoreAudio: Using recording device: Built-in Microphone (UID: AppleHDAEngineInput:1B,0,1,0:1)
00:00:01.884818 CoreAudio: Using recording device: Built-in Microphone (UID: AppleHDAEngineInput:1B,0,1,0:1)
00:00:01.886781 AC97: WARNING: Unable to open PCM output for LUN #0!
00:00:01.886800 VM: Raising runtime error 'HostAudioNotResponding' (fFlags=0x0)
00:00:01.886813 Console: VM runtime error: fatal=false, errorID=HostAudioNotResponding message="Some AC'97 audio streams (PCM Output) could not be opened. Guest applications generating audio output or depending on audio input may hang. Make sure your host audio device is working properly. Check the logfile for error messages of the audio subsystem"
...
00:00:10.351708 AC97: Reset
00:00:10.352649 CoreAudio: Failed to add the default playback device changed listener (1852797029)
00:00:10.352668 CoreAudio: Failed to add the playback device state changed listener (1852797029)

comment:13 Changed 4 years ago by MatrixNathan

Same problem here. Mac OS 10.11.3, VirtualBox 5.1.2 (same and 5.1.0 guest additions). No problems under VirtualBox 5.1.0. Applies to Windows 7 32-bit and Windows 10 64-bit guests regardless of sound device settings.

comment:14 Changed 4 years ago by iatsiuk

I am experimenting the same issue on macos 10.11.6 after upgrading form 5.1.0 to 5.1.2

comment:15 follow-up: ↓ 16 Changed 4 years ago by pedelar

I have the same problem using VBox v5.1.3, r109189 on an 15" MBP OS-X 10.11.6 (El Capitan) host with Windows 10Pro. Sound doesn't work at all. No way to solve this issue after doing many changes in more than a week.

The Audio Settings are: Null Audio Driver, Intel HD Audio.

What to do?.

comment:16 in reply to: ↑ 15 ; follow-up: ↓ 17 Changed 4 years ago by socratis

Replying to pedelar:

The Audio Settings are: Null Audio Driver, Intel HD Audio.

Of course you have no sound. You have selected the "Null Audio Driver", which means "mute". Try changing it to "CoreAudio". If it works, let us know please. If it doesn't, you'll have to wait for a fix, just like the rest of us. If you don't know what the settings do, either read about them, or don't change them randomly.

comment:17 in reply to: ↑ 16 ; follow-up: ↓ 18 Changed 4 years ago by pedelar

Replying to socratis:

Replying to pedelar:

The Audio Settings are: Null Audio Driver, Intel HD Audio.

Of course you have no sound. You have selected the "Null Audio Driver", which means "mute". Try changing it to "CoreAudio". If it works, let us know please. If it doesn't, you'll have to wait for a fix, just like the rest of us. If you don't know what the settings do, either read about them, or don't change them randomly.

Thanks for your light speed comment. According your instructions I did following: 1- Windows 10 Power Shut down 2- In main VirtualBox -->Settings-->Audio-->Changed to CoreAudio. Audio Controller: Intel HD.Audio. 3- OK 4- Start. 5- Two seconds after appeared the well known Warning: ..." The Virtual Machine execution may run on error ...". 6- When Windows 10Pro shown the main screen, the Speaker Icon (right-down place) was with an small red X---> No audio Output is installed.

My conclusion is that we all need to wait, asap, that VB fix this terrible error.

To try to solve this problem, I was trying to get and install the DirectSound Audio Driver, but I never found it. Perhaps do you know where I can download it & how must be installed, to have one more option when you select the VM Audio Settings. Thanks.

comment:18 in reply to: ↑ 17 ; follow-up: ↓ 19 Changed 4 years ago by jvanderb

Replying to pedelar:

Replying to socratis:

Replying to pedelar:

The Audio Settings are: Null Audio Driver, Intel HD Audio.

Of course you have no sound. You have selected the "Null Audio Driver", which means "mute". Try changing it to "CoreAudio". If it works, let us know please. If it doesn't, you'll have to wait for a fix, just like the rest of us. If you don't know what the settings do, either read about them, or don't change them randomly.

Thanks for your light speed comment. According your instructions I did following: 1- Windows 10 Power Shut down 2- In main VirtualBox -->Settings-->Audio-->Changed to CoreAudio. Audio Controller: Intel HD.Audio. 3- OK 4- Start. 5- Two seconds after appeared the well known Warning: ..." The Virtual Machine execution may run on error ...". 6- When Windows 10Pro shown the main screen, the Speaker Icon (right-down place) was with an small red X---> No audio Output is installed.

My conclusion is that we all need to wait, asap, that VB fix this terrible error.

To try to solve this problem, I was trying to get and install the DirectSound Audio Driver, but I never found it. Perhaps do you know where I can download it & how must be installed, to have one more option when you select the VM Audio Settings. Thanks.

The audio drivers usually are bundled in with the guest additions. You can install it by launching the VM, then once it loads go to the Devices menu (in VirtualBox), and select "Insert Guest Additions CD Image."

comment:19 in reply to: ↑ 18 Changed 4 years ago by socratis

Replying to pedelar:

... get and install the DirectSound Audio Driver ... to have one more option when you select the VM Audio Settings.

You cannot "download" your hardware options, your audio cards. VirtualBox present a number of pre-defined audio cards. That's what that option is about. It's not about a driver. It's about what audio card VirtualBox will "have" and present to the guest.

Replying to jvanderb:

The audio drivers usually are bundled in with the guest additions.

No, they are not. Guest Additions have absolutely nothing to do with the audio. And the audio drivers are bundled with the guest OS, not with the GAs.

comment:20 Changed 4 years ago by TH3rb5t

Link to Ticket #15761 - Same Issue, after Upgrading to version 5.1.2 on three machines, with different hardware, operating system on the hosts side, also different versions of VirtualBox before upgrading - but same result.

comment:21 Changed 4 years ago by socratis

Just FYI, there are a couple of changes as of the latest test build 110033.

1) The message displayed has changed to:

No audio devices could be opened. Selecting the NULL audio backend with the consequence that no sound is audible.
Error ID: HostAudioNotResponding
Severity: Warning

which pretty much is the message that was shown if you had the SB16 as your audio controller.

2) VMs are now crashing hard. Big time. Especially on OSX guests. Attached are the logs of two successful runs of a 10.8 guest. VBox.log is with the NULL controller, VBox.log.1 is with the HDA controller.

Changed 4 years ago by socratis

VBox.log is with the NULL controller, VBox.log.1 is with the HDA controller. Host 10.9.5, guest 10.8.

comment:22 Changed 4 years ago by thunksalot

I'm having the same issue. The guest has become so unstable it's pretty much unusable. I'm no expert, but perhaps having this extra data point is helpful to those of you who are:

Host: OSX 10.11.6 Guest: Win 10 (upgraded from Win7 64 bit) Guest Additions: 5.1.2r108956

comment:23 Changed 4 years ago by socratis

Hallelujah!!! YES!!!

This seems to be fixed with 5.1.4, although there was no mention in the release notes! It works for me, OSX 10.9.5 host. Can anyone verify/confirm this please?

comment:24 Changed 4 years ago by MatrixNathan

Fixed here with VirtualBox 5.1.4 on El Capitan, no more warnings and working audio in VMs! Thanks to the VirtualBox team.

comment:25 Changed 4 years ago by alanbirtles

seems to be working for me with 5.1.4

comment:26 Changed 4 years ago by alanbirtles

but #15602 is back

comment:27 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I will close this ticket for now. Please reopen if still relevant with 5.1.4.

comment:28 Changed 4 years ago by Allieway

Just wanted to say thank you for the fix! Makes my VM's much more usable now!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use