VirtualBox

Ticket #15646 (closed defect: obsolete)

Opened 4 years ago

Last modified 2 years ago

Use Unscaled HiDPI causes broken display behavior

Reported by: Ben2D2 Owned by:
Component: GUI Version: VirtualBox 5.1.0
Keywords: Cc:
Guest type: Windows Host type: Mac OS X

Description

When I enable Use Unscaled HiDPI and run my Win10 VM, the screen starts off normal, but after 1 or 2 seconds stretches vertically to about 125% height but normal width, with the bottom of the virtual screen clipped off inside the VM window. When I start moving the mouse inside the VM window, the screen scaling jumps around and I get strange artifacts.

This happens when Unscaled HiDPI is enabled, and not when it is disabled. Things that do not affect this behavior: 3D acceleration, 2D video acceleration, VM ram, video ram

MacbookPro Retina mid-2014 OSX 10.11.6 running VirtualBox 5.1.0 and a Windows 10 guest with latest additions.

Attachments

VirtualBox_win10_26_09_2016_15_59_27.png Download (487.9 KB) - added by Ben2D2 4 years ago.
initial view
Screen Shot 2016-09-26 at 4.03.59 PM.png Download (331.5 KB) - added by Ben2D2 4 years ago.
after interacting at all

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by Mad

comment:2 in reply to: ↑ 1 Changed 4 years ago by Ben2D2

Replying to Mad:

This seems related: https://www.virtualbox.org/ticket/15355

This bug seems different from that one, since this bug is unrelated to changing the window size of the VM on the host.

Changed 4 years ago by Ben2D2

initial view

Changed 4 years ago by Ben2D2

after interacting at all

comment:3 Changed 4 years ago by Ben2D2

Interestingly, when I use the Take Screenshot menu command in virtualbox, the output screenshot looks perfect, even if the on-screen display looks totally stretched, smeared, and corrupted. So I have to use the OSX screenshot tool to capture the messy on-screen image.

comment:4 Changed 4 years ago by d.w.chung

Perhaps this is more related: https://www.virtualbox.org/ticket/14349 It's a bit outdated, though. I'm having the same issue and going to try this solution. I'll post update here afterwards.

comment:5 Changed 4 years ago by d.w.chung

Confirmed @DreamPiggy's solution working - installing Guest Addition 5.0.0_BETA4 ( http://download.virtualbox.org/virtualbox/5.0.0_BETA4/VBoxGuestAdditions_5.0.0_BETA4.iso) worked for me, but of course with potential risks. Also as a note, Guest Addition 5.0.0 stable did NOT work, causing the same problem. Let's hope the team will take a look on this issue in upcoming versions.

comment:6 follow-up: ↓ 7 Changed 4 years ago by Ben2D2

I can confirm that installing the 5.0.0_BETA4 Guest Additions fixes this problem for me for my win10 guest. But it causes my ubuntu16_04 guest to have worse problems with screen corruption.

Last edited 4 years ago by Ben2D2 (previous) (diff)

comment:7 in reply to: ↑ 6 ; follow-up: ↓ 8 Changed 4 years ago by socratis

Replying to Ben2D2:

I can confirm that installing the 5.0.0_BETA4 Guest Additions fixes this problem for me for my win10 guest. But it causes my ubuntu16_04 guest to have worse problems with screen corruption.

Why did you "update" your Ubuntu guest to use the old GAs? You didn't have to. The old GAs are a workaround for the problem in the Windows guest only.

comment:8 in reply to: ↑ 7 Changed 4 years ago by Ben2D2

Replying to socratis:

Why did you "update" your Ubuntu guest to use the old GAs? You didn't have to. The old GAs are a workaround for the problem in the Windows guest only.

Good question... I had been having problems with my ubuntu VM in HiDPI mode a few VB versions ago. I just returned to the latest GA for that VM and it seems to be working well. So, please ignore my complaining about the ubuntu VM. My original problem is fixed by using the old GA in the win10 VM. So hopefully we can figure out what changed between 5.0.0_BETA4 and 5.0.0 windows GAs that broke this.

comment:9 follow-up: ↓ 10 Changed 4 years ago by Ben2D2

unfortunately, using the old 5.0.0beta4 GAs with VB 5.1.6 causes me other problems. USB not working, and some applications failing to load. So I'm back to standard DPI and hoping for a fix in 5.1.8.

comment:10 in reply to: ↑ 9 Changed 4 years ago by socratis

Replying to Ben2D2:

USB not working, and some applications failing to load.

USB has absolutely nothing to do with the GAs. It works just fine on systems that have no GAs at all. Just saying...

comment:11 Changed 3 years ago by Ben2D2

Unfortunately this is still broken for me in 5.1.10 VB and GAs in my windows 10 guest.

comment:12 Changed 2 years ago by Dsen

Is it still the case with recent 5.1.x?

comment:13 Changed 2 years ago by Dsen

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use