VirtualBox

Ticket #15355 (new defect)

Opened 5 years ago

Last modified 5 years ago

Auto-resize guest (Win 8.1 and 10) not working with Guest additions 5.0.18

Reported by: Biite Owned by:
Component: guest additions Version: VirtualBox 5.0.18
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

Auto-resize guest using the Guest additions 5.0.18 does not work in a Win 8.1 and Win 10 VM. I've verified that:

  • Auto-rezie guest display is enabled
  • Maximum guest screen size is automatic

What I've done (and did NOT help):

  • Downgrading to 5.0.16 from 5.0.18 (and reinstalling the matching GA)
  • Reinstalling/upgrading Guest Additions

What I've done (and DID help):

  • Downgrading to 5.0.14 (and matching GA)
  • Using vBox 5.0.18 with the 5.0.14 GA

Attachments

Windows 8 Werk-2016-04-19-15-36-31.log Download (121.8 KB) - added by Biite 5 years ago.
Windows 8.1 vbox.log
Windows 10-2016-04-19-16-32-02.log Download (141.5 KB) - added by Biite 5 years ago.
Windows 10 vbox.log
Win 8.1 Test-2016-04-26-18-09-08.log Download (202.6 KB) - added by Biite 5 years ago.
Win 8.1 test VM (fresh install, no updates)

Change History

Changed 5 years ago by Biite

Windows 8.1 vbox.log

Changed 5 years ago by Biite

Windows 10 vbox.log

comment:1 Changed 5 years ago by frank

Not able to reproduce. Both Windows 10 and Windows 8.1 do proper screen resize here with 5.0.18 Guest Additions installed (just double-checked). And I used a very similar configuration to yours (e.g. 3D disabled).

comment:2 Changed 5 years ago by Biite

Tried it on a fresh Win 8.1 VM (Windows 8.1 Enterprise Build 9600). Installed 5.0.18 GA on it. What works:

  • Resizing smaller then 1152 x 864 and back

What does not work:

  • Resizing to larger then 1152 x 864 (by dragging or by maximizing the VM window)

What is strange:

  • I can select a larger resolution than 1152 x 864 in the VM, which is the resolution of the resized window. I can also apply it and it resizes to the resized window.
  • From that resized window I can resize down, but not up again.

I've uploaded a new vbox log for this fresh VM

Changed 5 years ago by Biite

Win 8.1 test VM (fresh install, no updates)

comment:3 Changed 5 years ago by Mad

I also see this on a Windows 8.1 enterprise guest install. Tested on a 5.1.2 linux host virtualbox both with 5.1.2 guest additions and 5.1.3 build 110032 guest additions.

comment:4 Changed 5 years ago by Mad

Hm, now it seems like this might have something to do with scaling with Qt, because things work if I run the VM without any scale factors involved...

comment:5 Changed 5 years ago by Mad

To sum it up, these are the issues with using Virtualbox 5.1.2 on a 4k monitor with scaling enabled in kcm_kscreen:

Scaling factor set to 2 and resolution to 3840x2160 in kcmshell5 kcm_kscreen (plasma 5.7.2):

  • With 3D accel disabled, max resolution 1152x864, but the screen looks okay up to that resolution.
  • With 3D accel enabled, then max resolution gets right in regards to scale factor (e.g 3840x2160 with scale factor 2 equals max resolution 1920x1080), but it doesn't upscale the resulting output. Meaning that the 1920x1080 image gets shown in top left covering 1/4 of the output screen, but the mouse pointer acts like the output covers the whole screen.

Example: http://imgur.com/Jy72Kh1

If you disable scaling in kcmshell5 kcm_kscreen and set the actual resolution to 1920x1080, things works as normal.

comment:6 Changed 5 years ago by Mad

Same genre bug reported here it seems. But other types of symptoms.

Last edited 5 years ago by Mad (previous) (diff)

comment:7 Changed 5 years ago by Mad

I found a work-around that might be of use for people who do not want to disable hidpi resolutions.

Given a global scale factor of 2 set in kcmshell5 kcm_kscreen, start your vm like this:

QT_SCALE_FACTOR=0.5 VBoxManage startvm "vm name"

and after booting has finished (and guest additions are up and running), set Scale factor to 200%. Those two settings together makes it so that you aren't left with a small screen top left.

comment:8 Changed 5 years ago by Mad

It's a bit slow though, I have a sneaking suspicion that this makes it first scale with factor 2 (qt), then with 0.5 (qt), and then with 2 again (virtualbox).

comment:9 Changed 5 years ago by g_tirloni

Tested on:

  • i7 6700K, 16GB RAM, GTX 1070 GPU
  • Host & Guest: Windows 10 (Anniversary Update)
  • VirtualBox 5.1.5 (110344)

Results:

  • Cannot reproduce issue: resizing always works.
  • With 3D acceleration off: sometimes it shows some weird graphics and takes up to 10sec to redraw
  • With 3D acceleratio on: no weird graphics while waiting to redraw (and it takes <1sec)
Last edited 5 years ago by g_tirloni (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use