VirtualBox

Ticket #15356 (closed defect: worksforme)

Opened 5 years ago

Last modified 16 months ago

VirtualBox reboots CentOS 6.5 (disabling VMXE at CR4)

Reported by: vboxtrial Owned by:
Component: other Version: VirtualBox 5.0.16
Keywords: CentOS headless Cc:
Guest type: all Host type: Linux

Description

I have installed VirtualBox 5.0.16 on CentOS 6.5 using the following commands under root:

yum-config-manager --add-repo http://download.virtualbox.org/virtualbox/rpm/el/virtualbox.repo
yum install VirtualBox-5.0

The server is headless, has no UI/Desktop manager installed, run-level 3.

Important thing is that I run qemu/kvm virtual machine on that server. It uses the hardware virtualization, but I still expect VirtualBox to be able to run in software virtualization mode, so I set

VBoxManage modifyvm testvm --hwvirtex off
VBoxHeadless --startvm testvm

But when I start such VM (under root or non-root user) , the host instantly reboots[[BR]]

No VBox.log is generates, no /var/log/messages entries.

The /var/crashes/<date>/vmcore ~700Mb and vmcore-dmesg.txt files are generated - should they be helpful in the investigation of the issue, tell me and I will find a way to deliver it to you. Or tell me how to extract info from that.

The following Vargant config reproduces the problem for me and might be convenient if you want to reproduce the issue:

Vagrant.configure("2") do |config|
  config.vm.box = "ubuntu/trusty32"
  config.vm.hostname = "mybox"
  config.vm.network :private_network, ip: "192.168.0.42"

  config.vm.provider :virtualbox do |vb|
    vb.customize ["modifyvm", :id, "--hwvirtex", "off"]
  end
end

Note1: I have found some alike issues #12923 and #14278, but they appear to be UI(QT) related or other version of CentOS and not rebooting the host and not resolved

Note2: Why would it reboot the host OS instead of "just" segfault as described in other tickets?

Note3: tested with Win and Linux guests - same result - instant host reboot

Attachments

ldd-26-04-2016.out Download (4.2 KB) - added by vboxtrial 5 years ago.
in case you need ldd -r /usr/lib/virtualbox/VirtualBox.so

Change History

Changed 5 years ago by vboxtrial

in case you need ldd -r /usr/lib/virtualbox/VirtualBox.so

comment:1 Changed 5 years ago by frank

Having the vmcore and vmcore-dmesg.txt files would be a start. If you could provide a URL that would be nice. You could also contact me via private email at frank _dot_ mehnert _at_ oracle _dot_ com.

comment:2 Changed 5 years ago by vboxtrial

Thanks for the prompt reply Frank! I've sent you an email with a download link for the vmcore and vmcore-dmesg.txt files.

comment:3 Changed 5 years ago by frank

I've got the files. Could you also attach the vboxdrv.ko module?

comment:4 Changed 5 years ago by vboxtrial

I've sent you the link again as it was ~7Mb

The file was found in

/lib/modules/2.6.32-431.20.3.el6.x86_64/misc/vboxdrv.ko

comment:5 Changed 5 years ago by frank

  • Summary changed from VirtualBox reboots CentOS 6.5 to VirtualBox reboots CentOS 6.5 (disabling VMXE at CR4)

Thanks. We know what happens: VirtualBox is about to clear the VMXE bit from CR4 which is not allowed in root mode (KVM active). This needs more investigation but I think we have all information we need.

comment:6 Changed 5 years ago by vboxtrial

Thanks Frank!
Does that mean that there is going to be a fix for that in some future VirtualBox version?

comment:7 Changed 5 years ago by frank

Sorry, I cannot do any promises. You might be aware of the amount of open issues in this bugtracker.

comment:8 Changed 16 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use