VirtualBox

Ticket #12923 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Segmentation Fault on Linux (CentOS 6.5)

Reported by: termite Owned by:
Component: GUI Version: VirtualBox 4.3.10
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

I have been using VirtualBox to run a Windows 7 guest on CentOS for a couple of years. After updating to CentOS 6.5 I get a Segmentation fault error right after I start the VirtualBox. It does not open the GUI.

I can still run the guest with the SDL option, (VBoxManage startvm --type sdl OR with VBoxSDL) but I cannot get it to start it with the GUI.

Attachments

gdb-out.txt Download (7.3 KB) - added by lfmeloman 4 years ago.
stacktrace
core.7918.xz Download (425.5 KB) - added by lfmeloman 4 years ago.
vbox5 core file
ldd-out.txt Download (4.6 KB) - added by lfmeloman 4 years ago.

Change History

comment:1 Changed 5 years ago by termite

I restored a backup, and it solved the problem. Probably something was wrong with the previous system update. Everything works just fine now.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks. Please reopen this ticket if you encounter further issues. If so, please do also add log files, for example ~/.VirtualBox/selectorwindow.log, ~/.VirtualBox/VBoxSVC.log and VBox.log files from the machine you try to start.

comment:3 Changed 5 years ago by toralf

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I've also had this problem for a while, and I've come a cross others that have experienced it via the CentOS mailing list, so I think there is more to this than a failed system update.

Note that the crash occurs before logs are written or anything. Some info from the debugger:

Core was generated by `/usr/lib/virtualbox/VirtualBox'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000356589ecb7 in get_thread_data () at thread/qthread_unix.cpp:182
182	    return currentThreadData;
Missing separate debuginfos, use: debuginfo-install VirtualBox-4.3-4.3.10_93012_el6-1.x86_64
(gdb) thread apply all where

Thread 1 (Thread 0x7fa788a47720 (LWP 1445)):
#0  0x000000356589ecb7 in get_thread_data () at thread/qthread_unix.cpp:182
#1  0x000000356589ed4a in QThreadData::current ()
    at thread/qthread_unix.cpp:208
#2  0x000000356589c24f in QThread::currentThread () at thread/qthread.cpp:395
#3  0x00000035659dda25 in QCoreApplicationPrivate::QCoreApplicationPrivate (
    this=0x261f120, aargc=@0x7fffb64edcec, aargv=0x7fffb64ee118, flags=263682)
    at kernel/qcoreapplication.cpp:464
#4  0x000000356642ee8a in QApplicationPrivate::QApplicationPrivate (this=
    0x261f120, argc=@0x7fffb64edcec, argv=0x7fffb64ee118, type=
    QApplication::GuiClient, flags=263682) at kernel/qapplication.cpp:182
#5  0x0000003566430ea0 in QApplication::QApplication (this=0x7fffb64ede10, dpy=
    0x26138e0, argc=@0x7fffb64edcec, argv=0x7fffb64ee118, visual=39971600, 
    colormap=0, _internal=263682) at kernel/qapplication.cpp:952
#6  0x00007fa782347b4e in TrustedMain () from /usr/lib/virtualbox/VirtualBox.so
#7  0x00000037de81ed1d in __libc_start_main () from /lib64/libc.so.6
#8  0x0000000000401159 in ?? ()
#9  0x00007fffb64ee108 in ?? ()
#10 0x000000000000001c in ?? ()
#11 0x0000000000000001 in ?? ()
#12 0x00007fffb64ee87b in ?? ()
#13 0x0000000000000000 in ?? ()

comment:4 Changed 5 years ago by toralf

BTW, I thought I might rebuild VirtualBox on my machine to see if that made any difference, as I'm wondering if the problem is some kind of incompatiblity between by pthread version and the statically linked (?) Qt library used by vbox. This would be a lot easier with a source rpm package, though. Is this available anywhere?

Note that I'm using the "VirtualBox-4.3-4.3.10_93012_el6-1.x86_64" rpm from virtualbox.org.

comment:5 Changed 5 years ago by toralf

Hmmm... I assumed Qt was statically linked because it doesn't show up in the ldd output for VirtualBox, but perhaps it is instead accessed via dlopen()?

Last edited 5 years ago by toralf (previous) (diff)

comment:6 Changed 5 years ago by frank

Sorry, there is no source rpm available. No, Qt is dynamically linked:

$ rpm -qpR VirtualBox-4.3-4.3.10_93012_el6-1.x86_64.rpm  |grep Qt
libQtCore.so.4()(64bit)
libQtGui.so.4()(64bit)
libQtNetwork.so.4()(64bit)
libQtOpenGL.so.4()(64bit)

Which Qt version do you have installed? To see the Qt libraries VirtualBox is linked against, do 'ldd /usr/lib/virtualbox/VirtualBox.so (not 'ldd /usr/lib/virtualbox/VirtualBox').

comment:7 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

No response, closing.

comment:8 Changed 4 years ago by lfmeloman

Upgrading from 4.3.18. Downloaded and installed VirtualBox-5.0-5.0.0_101573_el6-1.x86_64.rpm The command VirtualBox instantly dies with segfault.

The crash is similar to the one in comment 3. Do you have a debug rpm to download?

installed QT version:

qt-4.6.2-26.el6_4.x86_64 qt-x11-4.6.2-26.el6_4.x86_64

Not CentOS, but RHEL 6.5.

Last edited 4 years ago by lfmeloman (previous) (diff)

comment:9 Changed 4 years ago by lfmeloman

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Changed 4 years ago by lfmeloman

stacktrace

Changed 4 years ago by lfmeloman

vbox5 core file

comment:10 Changed 4 years ago by frank

Cannot reproduce. Can you provide the output of

ldd -r /usr/lib/virtualbox/VirtualBox.so

?

Changed 4 years ago by lfmeloman

comment:11 Changed 4 years ago by lfmeloman

Forgot to say: I'm using ssh x11 forwarding

comment:12 Changed 4 years ago by lfmeloman

If you still fail to reproduce, please download this vbox machine:  https://drive.google.com/file/d/0B40Hp1Tx6I6eX3JVTUE5b09mcGM/view?usp=sharing

root password empty

comment:13 Changed 3 years ago by lfmeloman

Upgrade to Rhel 6.7 fixed the issue

comment:14 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for letting us know.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use