VirtualBox

Ticket #1531 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Keyboard in guest very sluggish, some key strokes not captured

Reported by: gnowak Owned by:
Priority: critical Component: GUI
Version: VirtualBox 1.6.0 Keywords: sluggish guest keyboard
Cc: Guest type: other
Host type: Windows

Description

This problem has been described in full on the vbox-users mailing list.

 http://vbox.innotek.de/pipermail/vbox-users/2008-May/003217.html

Since sending that post, I've downgraded to virtualbox 1.5.6, and things are working just as they used to. This leads me to believe the problem is with vbox 1.6.0 itself, and not with my hardware. I also installed a winxp guest for testing purposes to see if I have the same problem there, and the keyboard works just fine in the winxp guest under vbox 1.6.0. So, the problem seems to be with the gnu/linux guest only.

I've attached a log of my gnu/linux guest vm running under vbox 1.6.0. The problem was so bad that I couldn't even type root <enter> my_password <enter> in order to login, and shut down the machine properly via halt. I had to use "vboxmanage controlvm debian poweroff".

Attachments

VBox.log Download (42.3 KB) - added by gnowak 6 years ago.

Change History

Changed 6 years ago by gnowak

comment:1 Changed 6 years ago by gnowak

I've installed 1.6.2, and found a slight improvement, in that if I type with about a 5 second delay between key strokes, I have an 85-90% chance of having the guest pick up all of my key strokes correctly. What this also means is that if I strike a balance between typing slowly enough, but also fast enough for the login not to time-out, I can type "root" <enter> "password" <enter> most of the time to log into my gnu/linux guest. This is still bad enough that I downgraded to 1.5.6 again. When I find the problem to be fixed in future versions, I will post here again stating that fact. If a log of my running under 1.6.2 would help, I'll be glad to post that as well.

comment:2 Changed 6 years ago by frank

  • Host type changed from other to Windows
  • Component changed from other to GUI
  • Summary changed from When running a gnu/linux guest under virtualbox 1.6.0 on a winxp pro host, the keyboard in the guest is very sluggish, and some key strokes go through to the host, instead of the guest to Keyboard in guest very sluggish, some key strokes not captured

comment:3 Changed 6 years ago by gnowak

I've upgraded to vbox 1.6.4, and find the problem still hasn't been resolved. I did some digging around, which led me to discover that this issue appears during startup, while my startup scripts are being run for the default runlevel but things work just fine when the vm first starts. I removed all the startup scripts from my default runlevel, and added them one by one, until I came across the problem. The issue seems to be caused by running speech-dispatcher  http://www.freebsoft.org/speechd in vbox 1.6.0-current. I run speech-dispatcher on 2 other physical machines here, and none of them exhibit this problem. Also, the problem didn't exist when running on pre-1.6.0 versions of virtualbox. It should also be noted that speech-dispatcher doesn't need to be used to provide speech output, for this to happen, it's simply enough for speech-dispatcher to be running, and not processing speech requests from clients like speechd-up to TTS engines like espeak. The versions of speech-dispatcher effected are 0.6.6 (I believe that was the current version when virtualbox 1.6.0 first came out) to the current version, 0.6.7 as of this writing. I've resolved the problem by replacing the combination of speech-dispatcher/speechd-up with the recently released espeakup, (as opposed to downgrading to vbox 1.5.6 once again), but ideally, this issue should be still addressed for those folks wishing to run speech-dispatcher in their guests. Under espeakup, I have no problem typing inside of the guest system. However, if I type very fast (my maximum typing speed is about 45 WPM), some keystrokes still do get captured by the host, while ending up in the guest as well. What I mean when I say the keystrokes get captured by the host, is simply that my host's screen reader speaks them, along with the guest's screen reader. This happens not too frequently though, even with fast typing, and it seems to have no effect on the host keyboard as was the case previously. My advice for anyone wishing to use espeak for software speech inside gnu/linux guests with speakup is to go for espeakup, instead of speech-dispatcher/speechd-up if you can, until this issue is addressed.

comment:4 Changed 5 years ago by gnowak

I've just revisited this issue, to see if there's been any change, and discovered that speech-dispatcher 0.6.7 seems to be running just fine once again as of virtualbox 2.1.4. I do not know if this is the result of something being fixed in 2.1.4, or in a earlier version of virtualbox. I would venture to suggest that this ticket may now be closed.

comment:5 Changed 5 years ago by attoparsec

  • Status changed from new to closed
  • Resolution set to fixed

Alright. Of course you can reopen this report should the effect manifest itself again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use