VirtualBox

Ticket #15189 (closed defect: fixed)

Opened 18 months ago

Last modified 4 weeks ago

scratchy/crackling audio in Windows 10 guest (Linux host)

Reported by: nbi Owned by:
Priority: major Component: other
Version: VirtualBox 5.0.14 Keywords: audio
Cc: Guest type: Windows
Host type: Linux

Description

Audio is scratchy/crackling.

Attachments

VBox.log Download (111.7 KB) - added by nbi 18 months ago.

Change History

Changed 18 months ago by nbi

comment:1 Changed 18 months ago by nbi

My host audio is ALSA only (no PulseAudio).

A Windows 7 guest has *no* sound problems whatsoever. Same settings, also 5.0.14 guest additions.

comment:2 Changed 18 months ago by nbi

The upgrade to the March 1st build of Windows 10 has not helped. I should point out that LatencyMon is showing the VirtualBox Guest Additions as having the highest latency on the system. It seems the Guest Additions need to be tuned/re-factored for Windows 10.

comment:3 Changed 18 months ago by nbi

 https://msdn.microsoft.com/en-us/library/windows/hardware/mt298187%28v=vs.85%29.aspx

In implementing the guest additions were any low latency APIs used as described in this link?

comment:4 Changed 18 months ago by pentagonik

The Guest Additions itself do not provide any audio-related code / improvements for the guest, as the guest utilizes the virtual audio hardware for that directly.

Did you already try whether 5.0.16 makes a difference for you in that regard?

comment:5 Changed 18 months ago by nbi

5.0.16 has the same problem.

Not sure what your comment about GA is about as I did not imply or suggest that. Something (and I don't know what that is) in GA is exhibiting very high latency and that is impacting the rendering of real time audio.That's why I asked about the low latency APIs. Until they are used the evidence suggests that the audio problem is caused or at least significantly contributed to by VirtualBox software. If they were used then this problem needs to be reported to MS as their code is not behaving as intended.

comment:6 Changed 17 months ago by nbi

I tested the latest Win 10 1511 version (as of 3/17/16). Sound is still broken with GA 5.0.16.

Also discovered that the GA needs to be uninstalled and reinstalled after applying an upgrade in order to preserve the pre-upgrade screen resolution. Not a big deal, but I don't recall this being necessary previously.

comment:7 Changed 16 months ago by nbi

Still broken in 5.0.20.

comment:8 Changed 9 months ago by getaceres

I'm having the same issue with VirtualBox 5.1.8 in Manjaro Linux and the latest build of Windows 10

comment:9 Changed 9 months ago by klaus

Is this still happening exclusively for pure ALSA configs? Just asking explicitly in case some of the "me too" reports are actually for a totally different piece of code (the PulseAudio variant).

Last edited 9 months ago by klaus (previous) (diff)

comment:10 Changed 9 months ago by nbi

Still broken in 5.1.10. Pure Alsa. Same Windows 10 build as comment 6.

Debian testing host:

uname -a Linux nehalem 4.1.17 #2 SMP Sun Feb 14 22:42:14 CST 2016 x86_64 GNU/Linux

comment:11 Changed 8 months ago by RMH

Hello VirtualBox!

Running multiple Windows 10 guests on Debian Host @ 5.12 host and additions software. We have the clicking also. System is now useless for creating training vids... any outlook that can be provided on this? Is the defect in active development for latest release???

Thanks so much, Rob

comment:12 Changed 8 months ago by nbi

I can confirm crackling/scratching in Debian Stretch kernel 4.9.1, VirtualBox 5.1.12 for Win 10 guest. I agree with last poster that this is a very serious issue effectively crippling Win 10 guests. Considering how long this problem has persisted how about giving it the attention it deserves? Thank you.

comment:13 Changed 7 months ago by nbi

Problem still present in 5.1.14.

comment:14 Changed 5 months ago by nbi

Problem still present in 5.1.18.

comment:15 Changed 4 months ago by callmejoe

i have same issue on linux mint host

comment:16 Changed 4 months ago by RvB

as long as I have been using VirtualBox I've had this problem... is there any outlook on getting this fixed?

comment:17 Changed 4 months ago by globus68

Same issue here. Both in Mint 18.1 and Ubuntu 17.04-Gnome hosts

comment:18 Changed 3 months ago by RvB

5.1.22 same problem. Seems to have gotten worse. Is there any chance this will be fixed at all?

comment:19 Changed 3 months ago by pentagonik

There's a new 5.1 test build on the Testbuilds page (r115730) which should have audio improvements regarding HDA emulation in combination with Windows 10 AU (Anniversary Update) + CU (Creators Update) guests.

comment:20 Changed 3 months ago by ivanfig

Same problem here: VB 5.1.22r115126(Qt5.6.1)

comment:21 Changed 3 months ago by socratis

@ivanfig

Did you even read the thread??? The comment from pentagonik just before yours, mentioned the experimental test build 115740. That is what you should try, not the standard 115126 build.

comment:22 Changed 6 weeks ago by Alden W

The current linux64 test build 5.1.x revision 116680 fixed this issue for me on a KDE Neon 5.10 host.

comment:23 Changed 4 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.24.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use