VirtualBox

Ticket #15183 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

3D accel rendering -> duplicate of #12738

Reported by: littlerunningdeer Owned by:
Component: guest additions/x11/graphics Version: VirtualBox 5.0.14
Keywords: 3D acceleration rendering Cc:
Guest type: Linux Host type: other

Description

Rendering bug when 3D accel enabled. Attached image shows VLC playing video in a window overlapped with File manager window. Probably not as intended.

Attachments

Screen Shot 2016-02-26 at 1.51.48 PM.jpg Download (289.6 KB) - added by littlerunningdeer 6 years ago.
3D accel rendering bug

Change History

Changed 6 years ago by littlerunningdeer

3D accel rendering bug

comment:1 Changed 6 years ago by littlerunningdeer

defect duplicated with Ubuntu 14.04 host as well as OSX 10.11.3 host. Guest shown is Xubuntu 14.04

comment:2 Changed 6 years ago by batarang

Same here.

Steps to confirm:

  1. Boot live cd ubuntu 16.04 or 15.10
  2. Enable universe and apt-get mesa-utils
  3. run glx-gears
  4. Drag terminal window over glx-gears window. Terminal window should cover the running gears. (Working as intended)
  5. Redo steps 1-4 on running guest with vbox addition Running gears will always be on top of terminal window.

This issue affects all applications using hardware acceleration such as google-chrome and atom-editor.

  • Host: Windows 10 Insider Build 14316
  • VirtualBox 5.0.17 r106344 (taken from #15245)
  • Vbox Extension 5.0.16 r105871
  • VBOXADDITIONS_5.0.17_106333
  • Host Ubuntu 15.10 4.2.0-35-generic x86_64 GNU/Linux

Edit: Still an issue.

ubuntu 16.04 guest

vbox 5.0.21

Toggling 3D acceleration off in vbox guest graphic settings does not reproduce this behavior.

Last edited 6 years ago by batarang (previous) (diff)

comment:3 Changed 6 years ago by Curtis

I had this exact same problem with VirtualBox 5.0.24 and VBoxGuestAdditions_5.0.24. When I installed VBoxGuestAdditions_5.0.16 the problem went away. So it was something changed after the 5.0.16 version of Guest Additions.

Host: Windows 10
VirtualBox: 5.0.24
VBoxGuestAdditions_5.0.24
Guest: Ubuntu 16.04

Last edited 6 years ago by Curtis (previous) (diff)

comment:4 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from GUI to guest additions/x11/graphics
  • Summary changed from 3D accel rendering to 3D accel rendering -> duplicate of #12738

The main change to X11 guest 3D which occurred with 5.0.18 is that as of that version many guest application use 3D acceleration which previously used software rendering. Might that be the problem here?

Other than that, I think this is a duplicate of #12738 (re-open if you disagree).

And sorry, but please see our wiki page about (lack of) X11 guest 3D support.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use