VirtualBox

Ticket #12738 (new defect)

Opened 4 years ago

Last modified 5 weeks ago

OpenGL windows are always on top of everything else in linux guest

Reported by: solaris235 Owned by:
Priority: major Component: guest additions/x11/graphics
Version: VirtualBox 4.3.8 Keywords: OpenGL
Cc: Kamiel Guest type: Linux
Host type: Windows

Description

System: Host = windows 7 home premium Guest = ubuntu 12.04 LTS

Virtualbox versions 4.3.6r91406 4.3.8r92456

Hardware: AMD, INTEL, 32 and 64 bit, nvidia ati amd chromium

OpenGL windows from any application are always topmost, that is they are always on top of everything else. In applications such as Blender, FreeCad etc drop down menus disappear behind the opengl window which is the main frame of the application. This makes it very difficult to use the program. All opengl features seem to work. I have reproduced this on at least 3 completely different hardware systems. 32 bit and 64 bit When you run glxgears and drag the application to another location on the screen the application window moves with the cursor but the opengl window doesn't move until the mouse button is released. Also all screenshots come out black, probably due to reversed window layering. This must be a virtualbox bug as none of this behaviour occurs in Ubuntu 12.04 LTS when run natively. There are no errors reported nothing noted in any logs. I've been trying to find a solution to this for almost 2 years. There are a lot of similar bug reports which all claim it is fixed. Yet all I need to do is install virtualbox on any windows machine then install Ubuntu 12.04 LTS, install guest additions and I have the same problem. All other 3d acceleration works fine it's just the opengl window layering. Compiz cube works. I think I started using virtualbox at version 4.2 and have always had this problem. Running identical Ubuntu 12.04 LTS installations, one natively the other in a virtualbox on a windows 7 host on the same hardware platform. The native installation has no issues. The virtualbox guest installation always has this issue with opengl windows. Please help...

Attachments

Screen Shot 2016-04-22 at 8.19.07 PM.png Download (164.3 KB) - added by nightprowler 20 months ago.

Change History

comment:1 Changed 4 years ago by edoardo

Same here, I can confirm the bug for Ubuntu 13.10 "saucy salamander" for both 32 bit and 64 bit architectures (VirtualBox 4.3.8r92456 on Windows 7 64bit host, with Ubuntu 13.10 guests). I also tried to reinstall GA (Guest Additions) and make them compile with my correct kernel headers, installed latest nVidia video drivers, rebooted both systems, but nothing seems to work...

Please help, it's very very annoying, and as stated before one can't work on many applications (Google Chrome, Blender, Qt Creator [welcome tab], etc.), i.e. with all applications that uses an OpenGL rendered viewport.

Best regards

comment:2 Changed 3 years ago by dww

Setting LIBGL_ALWAYS_SOFTWARE=1 solved this problem for me

comment:3 Changed 3 years ago by ccrome

Yep, also found this problem: Windows 8.1 64-bit host, linux Mint, 64-bit vm.

I can also confirm that: export LIBGL_ALWAYS_SOFTWARE=1

before starting the program works. Performance seemed okay for me with my (custom python opengl) application.

comment:4 Changed 2 years ago by jon1234

I've seen other people from years ago complaining about this problem. (for example:  https://forums.virtualbox.org/viewtopic.php?f=3&t=36963). I found this issue on fresh installs of Ubuntu 15.04/Gnome and Mint 17.2.

VMWare player with Mint 17.2 works fine though.

(Host: Windows 8.1 HP 8570p).

Changed 20 months ago by nightprowler

comment:5 Changed 20 months ago by nightprowler

Hi there,

I seem to be running into this issue as well and am wondering if there's a workaround?

I'm running FreeCAD on Ubuntu 15.10 as guest OS using Virtual Box 5.0.8.

The host OS is Mac OS X 10.11.3.

Any help would be much appreciated!

comment:6 Changed 20 months ago by mizzao

comment:7 Changed 18 months ago by jackdyson31

Guys,

this might be of use: disable desktop effects while 3D is enabled - things like VLC seem to behave better ... (KDE 4, Kubuntu LTS 14.04, Vbox 5xxx22)

Last edited 18 months ago by jackdyson31 (previous) (diff)

comment:8 Changed 18 months ago by Paul Bransford

Confirmed this with VirtualBox 5.0.22, Windows 8.1 host, Ubuntu 15.10 guest, exhibited with Atom editor 1.8.

Note: setting LIBGL_ALWAYS_SOFTWARE=1 or disabling desktop effects is all just outright disabling accelerated OpenGL. That is not a fix or workaround any more than just turning hardware OpenGL acceleration off entirely. The feature (hardware accelerated OpenGL for guests) is still broken.

This bug is TWO YEARS OLD and it hasn't been triaged at all. Sad.

comment:9 Changed 18 months ago by michael

  • Component changed from 3D support to guest additions/x11/graphics

As a VirtualBox developer I can confirm that this is a known issue. I am sure there must be a number of duplicates of it, but for now I will comment here. The short answer (we have a wiki page with more detail) is that Linux and X11 guest 3D is more or less user-supported just now due to lack of resources. So most issues are unfortunately not going to get fixed unless we get patches for them.

This particular issue is sadly probably not the easiest to investigate and fix. My guess is that the easiest way to solve it for recent guest distributions may be to reimplement the libgbm/libEGL combination. We do have an X11-based but very threadbare libEGL reimplementation which might do as a basis.

comment:10 Changed 18 months ago by michael

By the way, see this entry in the trac wiki:

 https://trac.edgewall.org/wiki/ThisTicketWasOpenedTenYearsAgo

comment:13 Changed 17 months ago by michael

  • Cc Kamiel added

comment:14 Changed 15 months ago by pisux

I had the same issue with one of my two Windows10 hosts, running the same guest (Linux Mint 17.3) but different Guest Additions.

Fixed downgrading the Guest Additions from 5.0.22 to 5.0.16 as suggested by user isapa1984 in a comment to this ticket  https://github.com/atom/atom/issues/11574.

comment:15 follow-up: ↓ 16 Changed 7 weeks ago by basti.wolf

I still have the same issue with the current version of VirtualBox 5.1.30 (Windows 10 host and CentOS 7.4 guest). I could not solve it with the mentioned workarounds.

comment:16 in reply to: ↑ 15 Changed 5 weeks ago by DennisVB

Replying to basti.wolf:

I still have the same issue with the current version of VirtualBox 5.1.30 (Windows 10 host and CentOS 7.4 guest). I could not solve it with the mentioned workarounds.

Can only upvote (if anyone of the devs is reading this). Have also this issue and it is very "inconvenient" to work with it on our virtualized CI cluster

comment:17 Changed 5 weeks ago by michael

Just to be clear again: this is not going to be fixed by us in the foreseeable future due to lack of development resources. We do have longer term plans for 3D, but if you need this now or soon you will have to find someone else who can fix it. We will still take contributions if we can integrate them with a reasonable effort and are confident that they do not break things which already work. One way in which anyone could help here would be by finding people who can do this sort of work for contract and raising funds to pay them. They should be willing to communicate with us to lower effort (and cost) on both sides of course. I am not aware of anyone reporting problems who has actually done this research though.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use