VirtualBox

Ticket #15071 (closed defect: invalid)

Opened 4 years ago

Last modified 3 years ago

USB devices are not recognized on Linux Debian v6.0.10 with VB 5.0.14 -> usage issue

Reported by: ManWithNoName Owned by:
Component: USB Version: VirtualBox 5.0.14
Keywords: USB Cc:
Guest type: Linux Host type: Windows

Description

I would like to read my SD card with Gparted but my USB devices are not recognized with my HOST by using a Linux Debian v6.0.10 Virtual Machine. I'm using Vbox 5.0.14 and my host is an ultra book ASUS UX32LN-R4011H with Windows 8.1

Please see the error message below :

Échec de la connexion du périphérique USB Alcor Micro Corp. Multi Flash Reader [0100] à la machine virtuelle Debian v6.0.10 Squeeze.

USB device 'Alcor Micro Corp. Multi Flash Reader' with UUID {39c0b9eb-ec40-4b63-aa7a-d775e4d65df2} is busy with a previous request. Please try again later.

Code d'erreur : E_INVALIDARG (0x80070057) Composant : HostUSBDeviceWrap Interface : IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89} Fonction appelée : IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Thanks in advance

Regards

Attachments

VBox.log Download (146.9 KB) - added by ManWithNoName 3 years ago.
Debian v6.0.10 Squeeze Log File
Capture d’écran (80).png Download (107.2 KB) - added by ManWithNoName 3 years ago.
Error message Screen shot
Capture d’écran (138).png Download (212.0 KB) - added by ManWithNoName 3 years ago.
New Capture with different SD Ctrl (Generic Flash Card Reader)
Capture d’écran (140).png Download (48.9 KB) - added by ManWithNoName 3 years ago.
VBoxmanage list usbhost
Capture d’écran (141).png Download (82.4 KB) - added by ManWithNoName 3 years ago.
Error message appear when I click on Alcor Micro Corp. Multi Flash Reader
Capture d’écran (144).png Download (241.4 KB) - added by ManWithNoName 3 years ago.
Adding a global USB filter
Capture d’écran (143).png Download (358.7 KB) - added by ManWithNoName 3 years ago.
Capture d’écran (143).2.png Download (358.7 KB) - added by ManWithNoName 3 years ago.
I can't see my SD Card drive with Gparted
Capture d’écran (151) - LS.png Download (484.7 KB) - added by ManWithNoName 3 years ago.
Final Screen Shot : It works now !!!

Change History

comment:1 Changed 4 years ago by frank

Please attach a VBox.log file of a VM session when you tried to attach that USB device to the VM.

Changed 3 years ago by ManWithNoName

Debian v6.0.10 Squeeze Log File

Changed 3 years ago by ManWithNoName

Error message Screen shot

Changed 3 years ago by ManWithNoName

New Capture with different SD Ctrl (Generic Flash Card Reader)

comment:2 Changed 3 years ago by ManWithNoName

Tested with WIndows 10 Host : Same error message (Please see Capture d’écran (138).png)

comment:3 follow-ups: ↓ 4 ↓ 11 Changed 3 years ago by socratis

99% you have not enabled a USB filter for your device and the host captures it and doesn't release it. See User Manual  Chapter 3.10.1 USB settings and look for USB filters and how to use them.

Changed 3 years ago by ManWithNoName

VBoxmanage list usbhost

Changed 3 years ago by ManWithNoName

Error message appear when I click on Alcor Micro Corp. Multi Flash Reader

Changed 3 years ago by ManWithNoName

Adding a global USB filter

Changed 3 years ago by ManWithNoName

Changed 3 years ago by ManWithNoName

I can't see my SD Card drive with Gparted

comment:4 in reply to: ↑ 3 Changed 3 years ago by ManWithNoName

Replying to socratis:

99% you have not enabled a USB filter for your device and the host captures it and doesn't release it. See User Manual  Chapter 3.10.1 USB settings and look for USB filters and how to use them.

You're right I forgot it ! But even adding a global USB filter, it seems always not work. Please see other screenshot files. Thanks

comment:5 Changed 3 years ago by ManWithNoName

Just a question : Do I need install Guest Additions to use USB Devices on a linux guest ?

comment:6 Changed 3 years ago by socratis

  1. You don't need to attach HiDPI screenshots when a simple copy/paste of the text is more informative.
  2. If you do attach a screenshot, please scale them down to 1/2 the size. Not everyone is using HiDPI monitors ;)
  3. The device in question shows as "Captured" in the list usbhost. Don't know why.
  4. Try to unplug and re-plug the device. The filter works when the USB in inserted. I'll post my usual troubleshooting guide from the forums. Usually that's where you should ask for advice, not open a bug report immediately, because it might be a wrong setting, not a bug.

Anyway, here it goes. Follow the steps below. If there is a failure, please state which step failed:

  1. Make sure that the Extension Pack is installed on the host. The same version as VirtualBox.
  2. Make sure that at least USB 2.0 is enabled in your VM settings.
  3. Create a USB filter in your guest settings while the device is plugged in the host. Delete all values except Name, VendorID and ProductID. Check also  http://www.linux-usb.org/usb.ids to make sure that you have the numbers correct.
  4. Unplug the device.
  5. Start your guest (the one that you applied the filter to). Let it start completely. Log in if you have to.
  6. Plug your device. The filter should capture it and pass control to your guest.
  7. If the device shows up in your host and is not captured by the filter, either the filter is incorrect, or there might be a problem with your filter installation.
  8. If the device shows up, but as unavailable, "eject" it from your host (if you can), but leave it plugged in. It should show up as available.
  9. Shut down the VM and now zip and post the VBox.log.zip.
  10. If on a Linux host, are you a member of the 'vboxusers' group? If not, add yourself with the following and then reboot.
    sudo usermod -a -G vboxusers <your username>
    

comment:7 Changed 3 years ago by ManWithNoName

Ok That's done now !!!

  • I need to add a custom filter (select only the USB SD Card reader device). Adding a global (empty) filter doesn't work.
  • I must eject the SD card from the Host first (in my case Windows 10) before launch the VM.

Thanks

Changed 3 years ago by ManWithNoName

Final Screen Shot : It works now !!!

comment:8 Changed 3 years ago by ManWithNoName

I have also a question : Is there a way to remove screeshot previously posted by mistake here ?

comment:9 Changed 3 years ago by ManWithNoName

As a suggest, maybe a popup message should advise us to check some settings instead of display this error message. Regards

comment:10 Changed 3 years ago by socratis

  1. Glad you solved it.
  2. As I said, next time first ask at the forums and then file a bug report. It's usually faster/better/more efficient.
  3. I can't delete your screenshots. I'm a simple user. Maybe an admin can.
  4. Please ask the admins/developers to close this bug as Invalid.

comment:11 in reply to: ↑ 3 Changed 3 years ago by ManWithNoName

You're right, this is not always usefull having a screenshot with Hi Def. but this is faster for me to take it (not need to manually resize it). In some case, this is nice to read some small text on an image with a good resolution. But I can understand that could be more difficult for people who don't have Hi Def monitors. I will take care in future. My last screen shot is a 720p instead 1080p size, do you think this is a correct size ?

Last edited 3 years ago by ManWithNoName (previous) (diff)

comment:12 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from USB devices are not recognized on Linux Debian v6.0.10 with VB 5.0.14 to USB devices are not recognized on Linux Debian v6.0.10 with VB 5.0.14 -> usage issue
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use