VirtualBox

Ticket #15072 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Dependency libvpx2 not in Ubuntu 16.04 (xenial)

Reported by: mightyiam Owned by:
Component: other Version: VirtualBox 5.0.14
Keywords: ubuntu xenial Cc: mightyiampresence@…
Guest type: all Host type: Linux

Description

VirtualBox for 15.10 (wily) is not installable on 16.04 (xenial) because the package libvpx2 is no longer there. It seems libvpx3 is included in xenial.

Attachments

Screenshot_2016-02-24_02-47-27.png Download (20.1 KB) - added by mightyiam 4 years ago.
ss.png Download (126.9 KB) - added by bhartendu 3 years ago.
Unable to install virtualbox 5.0.18 on Ubuntu 16.04 LTS Gnome variant.

Change History

comment:1 Changed 4 years ago by johnlee

but 16.04 is still only an alpha (just) so using it as a vb host doesn't really make sense? j

comment:2 Changed 4 years ago by mightyiam

@johnlee, I've been using the development version of Ubuntu as my daily driver for several versions now, all the while using VirtualBox releases.

Whether now or later, VirtualBox developers will want to support 16.04. So they will probably want to fix this.

comment:3 Changed 4 years ago by michael

I would say you both have fair points, though I can't say how soon we will solve this. Thanks for the warning in any case.

Changed 4 years ago by mightyiam

comment:4 Changed 4 years ago by 3vi1J

Any update on this? 16.04 will be released next month and become the new Long Term Support release, and 5.0.16 won't install on it due to this issue.

BTW: The workaround is to just install the old libvpx2 from the Wily repos:  http://packages.ubuntu.com/wily/amd64/libvpx2/download. It can coexist with libvpx3.

Last edited 4 years ago by 3vi1J (previous) (diff)

comment:5 Changed 4 years ago by frank

As you say: It will be released next month. We will probably provide a package dedicated to that Ubuntu release. In the meantime you can still use the universal .run installer.

comment:6 Changed 4 years ago by SantoDio

Sorry frank but I do NOT think this kind of behaviour is helping the community or VirtualBox software.

More than a month passed since your message, only 4 (FOUR) days are missing to the final Xenial Xerus 16.04 release, and nothing has been done on this serious problem.

I have installed VirtualBox on 16.04 with the .run installer, but I don't think that most noobs can do it.

Moreover upgrading Wily to Xenial will probably break VirtualBox dependencies and a lot of problems could raise in a few days.

comment:7 Changed 4 years ago by frank

There is absolutely no reason for ranting here.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

There is a 5.0.18 package for Xenial available now.

comment:9 Changed 4 years ago by mightyiam

Thank you!

comment:10 Changed 3 years ago by bhartendu

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi frank,

Can you please provide the link to that particular 5.0.18 package that can be installed on Xenial successfully.

I have tried these two and they still give the same error that Package libvpx2 is not installed on ubuntu 16.04 LTS Gnome variant.

 http://download.virtualbox.org/virtualbox/5.0.18/virtualbox-5.0_5.0.18-106667~Ubuntu~wily_amd64.deb

and

 http://download.virtualbox.org/virtualbox/5.0.18/virtualbox-5.0_5.0.18-106667~Ubuntu~trusty_amd64.deb

Changed 3 years ago by bhartendu

Unable to install virtualbox 5.0.18 on Ubuntu 16.04 LTS Gnome variant.

comment:11 Changed 3 years ago by socratis

Not being able to find a specific build is no reason to reopen a bug report, especially when the build exists. A simple comment would suffice. Here you go. At the very bottom:

 http://download.virtualbox.org/virtualbox/5.0.18/

comment:12 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Added the link to the Xenial packages to the corresponding downloads page as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use