VirtualBox

Ticket #1484 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

VirtualBox 1.6 cant start VM (Solaris10 Update4 VERR_FILE_NOT_FOUND)

Reported by: ts@… Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: Solaris

Description

When startinga VM via VirtualBox or VBoxHeadless i get

Unable to load R3 module /opt/VirtualBox/VBoxDD. VBox status code: -102 (VERR_FILE_NOT_FOUND).

Machine/Solaris10u4 is amd64 - 64bit

ldd for VBoxDD.so shows a problem with LIBDLPI.SO - which only exists as 32-bit library.

I tried to follow a hit in the forum, to dowload a newer SUNWclsr and put libdlpi.so and libdladm.so beneath VirtualBox via setting LD_LIBRARY_PATH. It solved the "ldd VBoxDD.so" error output ( libdlpi.so.1 -> not found ) but still i get this "unable to load ..." error.

What is missing? Do i need to upgrade to Sol10update5?

Change History

comment:1 Changed 6 years ago by wernerschonborn

No solution trying to install on Solaris 10 Update 5, error message is the same.

comment:2 Changed 6 years ago by ramshankar

You may be missing libGL.so and such. If you have a reduced installation of Solaris 10 you won't be have these libraries. You need to install Solaris 10 with a working X server for running VirtualBox GUI.

The libraries are in SUNWxorg-mesa package (but may have other dependencies).

If you didn't install the Desktop Software Group while installing Solaris 10, then you should probably re-install it (or find a way to install it).

comment:3 Changed 6 years ago by ts@…

@ramshankar :

  • no, the virtualbox gui works perfectly with sol10, starting a VM gives the error.
  • i have a fullinstall of sol10
  • i also tried to start a VM with VBoxHeadless,which doesn't need any gui / libGL etc

-- problem is loadling the VBoxDD.so -- ldd gives for VBoxDD.so : libdlpi.so.1 => (file not found) -- in sol10 under /usr/lib is a 32bit libdlpi.so , in /lib/64 not. And there the problem begins...

thomas

comment:4 Changed 6 years ago by ramshankar

Are you sure you put the correction version of libdlpi in the correct place? 64-bit libdlpi should go under amd64 subdirectories of /lib and /usr/lib respectively.

To check if you really have the 64-bit version, do "file /lib/amd64/libdlpi.so" and it should show you "ELF 64-bit...".

Once you have the lib in place it should work.

comment:5 Changed 6 years ago by tore

no amd64 here, Solaris10_u4 x86 running 32bit on a virtual machine

ldd /opt/VirtualBox/VBoxDD.so

libdlpi.so.1 => /lib/libdlpi.so.1 libdlpi.so.1 (SUNW_1.1) => (version not found)

/lib/libdlpi.so pvs -s libdlpi.so.1; SUNWprivate_1.1;

comment:6 Changed 6 years ago by tore

SUNWxorg-mesa installed and service ogl-default is online I had to set a symlink to /usr/X11R6/lib/libGL.so maybe VirtualBox should be linked to /usr/lib/libGLcore.so.1 ???

xstat(2, "/usr/sfw/lib/libGL.so", 0x08046BB0) Err#2 ENOENT xstat(2, "/lib/libGL.so", 0x08046BB0) Err#2 ENOENT xstat(2, "/usr/lib/libGL.so", 0x08046BB0) Err#2 ENOENT ld.so.1: VirtualBox: fatal: libGL.so: open failed: No such file or directory

comment:7 Changed 6 years ago by ramshankar

Yes it's normal to have those libs. libGL and libGLCore get pulled into the link, ldd VirtualBox | grep GL:

	libGL.so =>	 /usr/lib/64/libGL.so
	libGLcore.so.1 =>	 /usr/lib/64/libGLcore.so.1

A link in the folder where the linker looks for the lib should be fine. So yes /usr/lib/64 link is required.

comment:8 Changed 6 years ago by ramshankar

Since you're on 32-bit it that would be /usr/lib and not /usr/lib/64.

comment:9 Changed 6 years ago by ts@…

@ramshankar : The libdlpi.so in /lib is 32bit. in /lib/64 there was none. I dowloaded from somewhere a SUNWcslr package, stripped out the libdlpi.so and and it into /lib/64. That solved the ldd error - but the "Unable to load R3 module /opt/VirtualBox/VBoxDD. VBox status code: -102 (VERR_FILE_NOT_FOUND)." still exists. Must be something else be wrong too - maybe this lib of this package doesnt fit to sol10u4.

Did you get it run in sol10???? If yes, please desribe your environment

comment:10 Changed 6 years ago by ts@…

SOLVED!

using this workaround solves the problem:  http://forums.virtualbox.org/viewtopic.php?t=6149

Problem is the missing 64-bit libdlpi.so

@innotec will you or the SUN solaris team fix this missing 64-bit lib problem?

comment:11 Changed 6 years ago by syalcin

I'm having the same problem When i use VBoxHeadless but VirtualBox works fine. This is what i'm getting: VBoxHeadless -s "W2k3 Server"VirtualBox Headless Interface 1.6.0 (C) 2008 Sun Microsystems, Inc. All rights reserved

Listening on port 3389 Error: failed to start machine. Error message: Unable to load R3 module /opt/VirtualBox/VBoxDD. VBox status code: -102 (VERR_FILE_NOT_FOUND)

I have already applied the libdlpi and this is the kernel I'm using: 5.10 Generic_127112-05 i86pc i386 i86pc

anyone else having the same problem?

comment:12 Changed 6 years ago by sandervl73

Reopen if it still happens with 1.6.2 please. That release should work better with Solaris 10.

comment:13 Changed 6 years ago by ts@…

Where do i get VirtualBox 1.6.2 ? On the download i see only 1.6.0.

comment:14 Changed 6 years ago by elhefe1982

Same problem here, workarround fixed it. Any idea on the VirtualBox 1.6.2 planned release date?

comment:15 Changed 6 years ago by frank

  • Host type changed from other to Solaris

comment:16 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Tis problem was solved with VirtualBox 1.6.2, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use