VirtualBox

Ticket #14785 (closed defect: fixed)

Opened 5 years ago

Last modified 15 months ago

4.3.30 -> 5.0.6: aborted VMs, host lockups

Reported by: hmo Owned by:
Component: VM control Version: VirtualBox 5.0.8
Keywords: Cc:
Guest type: all Host type: Windows

Description

Recently migrated from 4.3.30 to 5.0.6. Since that, I occasionally observe "aborted" VMs when saving state of a a virtual machine. Sometimes but not always a <VM>\Snapshots\*.SAV file is created as expected. Host is Win7 x64, guests are Win7 x64, XP x86 and FreeBSD x86.

No clear indication to what this might be related. Logfiles don't show anything unusual either. Upgrade to 5.0.8 did not help.

In addition, the host has completely locked up several times since the upgrade: Screen remains lit, but no mouse move, no disk indication, etc.

Downgraded to 4.3.30 (with a bit of pain due to not downward compatible configuration), and everything is rock solid again.

Guest additions always at the host's VBox revision.

The host is a 1st gen i5 mobile.

Let me know which logs / debugs I should provide.

Change History

comment:1 Changed 5 years ago by hmo

I did some testing with other releases. It seems the issue is also not visible in 5.0.4. On the other hand, it shows up in 4.3.32.

Conclusion: There seems to be a change applied between 4.3.30 and 4.3.32 as well as between 5.0.4 and 5.0.6 which triggers the issue. The Changelog doesn't indicate anything though.

Note there are several forum postings reporting the same issue with matching revision observations, for example:

 https://forums.virtualbox.org/viewtopic.php?f=6&t=74290

 https://forums.virtualbox.org/viewtopic.php?f=3&t=74037

comment:2 Changed 5 years ago by frank

For debugging the reason for aborted VMs we would need to have access to memory dumps, see here, scroll down to the Windows section.

comment:3 Changed 5 years ago by hmo

Unfortunately no memory dumps are created.

I guess same issue as in #14841?

comment:4 Changed 5 years ago by Binome

It seems that enabling the IO-APIC option (in System) makes the VMs running correctly. It's worth trying.

comment:5 Changed 5 years ago by frank

True. Most likely the same issue as #14841. There was a change between 4.3.30 and 4.3.32 which was not visible for users but which caused a regression. Same as with VBox 5.0.6. In theory it affects all hosts but the bug (actually a race) was mainly visible on Windows. The latest 4.3.x and 5.0.x test builds for Windows include the fix (revision >= 104224 for 5.0.x and >= 104225 for 4.3.x).

comment:6 Changed 5 years ago by johnlee

There is no mention of this fix in the help heading 5.0.12 xxx for of latest test build win 104224. Is it included pls?

John

comment:7 Changed 5 years ago by frank

Sorry, I don't get you. Please install the test build as I advised in comment 5. Or wait for the 5.0.12 maintenance release (no ETA yet).

comment:8 Changed 5 years ago by johnlee

As I thought was clear, I HAVE installed win 104224, ran vm manager and looked in help contents at sect 15 under 5.0.12 xxx or similar - no mention of the fix. Maybe it is just omitted from the help which is bit confusing, or is it in build? j

comment:9 Changed 5 years ago by frank

The fix is part of this build. As this build is only a test build, the changelog is not complete.

comment:10 Changed 5 years ago by hmo

I have installed the 4.3 test build, and I have not seen the issue since. Time to move on to 5.0, finally.

FWIW, my VMs have always had IO-APIC enabled, so this is unrelated (see also #14841).

Thanks a lot for your decent support despite the odd and sparsely described error scenario!

comment:11 Changed 5 years ago by frank

Thanks for the feedback!

comment:12 Changed 15 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use