VirtualBox

Ticket #1473 (closed defect: worksforme)

Opened 6 years ago

Last modified 4 years ago

Upgrade to 1.6 capped max resolution for XP guest

Reported by: Linuxuser Owned by:
Priority: major Component: GUI
Version: VirtualBox 1.6.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I upgraded virtualbox from 1.5.6 to 1.6 (including the guest additions) on my 32-bit Ubuntu Hardy host and so far have only one problem with my Windows XP install:

The max resolution offered for the guest is at 1152x864 whereas in vbox 1.5.6 I could switch to 1280x1024 without any problems.

Fullscreen and Seamless mode function normally, I don't see any other problems.

1GB assigned to the guest on my Athlon Dualcore 3800+ 2GB + nvidia 7600 box and powered up the virtual graphics card's memory to the max of 128MB as well.

Attachments

VBox.log Download (41.0 KB) - added by milanmk 6 years ago.
VBox Log File

Change History

comment:1 Changed 6 years ago by Linuxuser

Oh, I left the priority at "major" while this is not a major issue (for me). Feel free to lower priority.

comment:2 Changed 6 years ago by sandervl73

That's ok. I'll have somebody look into this next week.

comment:3 follow-up: ↓ 4 Changed 6 years ago by frank

The reason for this is that the the guest video driver asks the host frontend if a desired graphics mode is valid/supported or not. Up to 1.5.6 the Qt GUI reported every graphics mode to be supported. Starting with 1.6.0 we report only the space which the Qt library reports as desktop space. This space is a little bit smaller than the screen resolution (KDE/GNOME panel, menu, ...). In my case (KDE), the desktop space is 1580x950 although the screen is 1680x1050. So 1280x1024 will be reported as not supported because 1024 > 950. This restriction does not play when going to fullscreen. We are currently discussing if we should change this restriction and how. Perhaps make it configurable as many (but obviously not all) users might prefer that the guest resolution is never bigger than the host desktop space.

comment:4 in reply to: ↑ 3 Changed 6 years ago by milanmk

Replying to frank:

I have WinXP host at 1024x768 and guest WinXP is only showing 800x600 after upgrading to 1.6 including guest additions.

This is really annoying as the logic should be 1024 >= 950 and not 1024 > 950 so that the guest OS can have the same resolution as the host OS.

comment:5 follow-up: ↓ 7 Changed 6 years ago by frank

I don't understand you. Which resolution with 950 are you referring to? If you use the screen settings of your WinXP guest you can select only 800x600 because this is the next screen resolution smaller than 1024x768. As I wrote, your host desktop needs some space for the control panel and perhaps the menu. On the other hand, you can select arbitrary resolutions just by resizing the VM window if you have guest additions installed. So what is your exact problem?

comment:6 Changed 6 years ago by sandervl73

Frank is right. If you really want 1024x768, then use the full screen option. That works fine.

comment:7 in reply to: ↑ 5 Changed 6 years ago by milanmk

Replying to frank:

Which resolution with 950 are you referring to?

I am referring to your #comment:3 where you said:

So 1280x1024 will be reported as not supported because 1024 > 950.

This screen availability logic should be changed to 1024 >= 950 so that host and guest OS can have the same or less screen resolutions.

On the other hand, you can select arbitrary resolutions just by resizing the VM window if you have guest additions installed.

Please check the screenshot:

 http://img74.imageshack.us/img74/7125/screenshot11zy2.jpg

Replying to sandervl73:

Even fullscreen mode does not allow me 1024x768 guest resolution.

comment:8 Changed 6 years ago by frank

Even if 1024 >= 950 you cannot set a resolution of 1024x768 on a 1024x768 desktop because your host takes some space for the panel + menu (on GNOME desktops).

And did you really try to go fullscreen with Host+F? If that does not work, then this is indeed a bug. Please could you try going fullscreen with Host+F and attach your VBox.log file of that session here?

Changed 6 years ago by milanmk

VBox Log File

comment:9 Changed 6 years ago by milanmk

Replying to frank:

And did you really try to go fullscreen with Host+F? If that does not work, then this is indeed a bug. Please could you try going fullscreen with Host+F and attach your VBox.log file of that session here?

Yes i did try Host+F and here is the log file.

comment:10 in reply to: ↑ description Changed 6 years ago by Krotow

Replying to Linuxuser:

I upgraded virtualbox from 1.5.6 to 1.6 (including the guest additions) on my 32-bit Ubuntu Hardy host and so far have only one problem with my Windows XP install:

The max resolution offered for the guest is at 1152x864 whereas in vbox 1.5.6 I could switch to 1280x1024 without any problems.

Confirmed on OpenSUSE 10.3 host with Windows XP quest. Video mode after VirtualBox upgrade and VirtualBox Additions upgrade on guest was exactly 1152x864 (as you say). In my case VBox guest window was maximized before VBox upgrade. Seems, VBox guest can't determine host video mode, if VBox window is maximized at first run after VirtualBox Additions upgrade to 1.6.0. And 1152x864 is largest possible default video mode for VBox guest.

Possible solution around this bug (works for me):

  • exit from Fullscreen or Seamless mode to normal screen;
  • restore VirtualBox guest window (maximize/restore button or what your GUI windows has);
  • maximize VirtualBox guest window back. Now VirtualBox WinXP guest must have video mode, that fills all free space after Linux GUI and VBox window elements (what we needed).

That's all. Happy living in virtualized world =:]

comment:11 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:12 Changed 4 years ago by Technologov

  1. Retry with VBox 3.1.0 (upgrade guest additions too)
  1. please post VBox log
  1. please post screenshot

-Technologov

comment:13 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use