VirtualBox

Ticket #1468 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Windows Host networking doesnt work => Fixed in 1.6.2

Reported by: goldiebahia Owned by:
Priority: critical Component: other
Version: VirtualBox 1.6.0 Keywords: virtualbox 1.6.0 windows host networking issues
Cc: Guest type: other
Host type: other

Description

I have two environments on my Dual boot machine 2003 Server 32 bit + Ubuntu 8.04 64bit (2GB RAM, X2 AMD processor)

I have Windows 2003 32bit Host & XP + 2003 server + DSL as clients

I have Ubuntu 8.04 64bit Host & XP + 2003 server + DSL as clients

(I share common images of the above 3 clients & have stored all on Windows partition which Linux can access & write to)

I upgraded from 1.5.6 to 1.6.0 on both the Hosts.

On Linux every thing is OK like before, but on Windows host the Host interface had to be reconfigured so that the clients act as individual computers on a router and they share the ADSL from host ... earlier everything was fine after upgrade and after again configuring the network I cant even ping each other machines let alone go to the net through host, no ping between host & clients or between clients. NAT works fine. (Now if i uninstall 1.6.0 & go back to 1.5.6 I am back to normal, I spent 6 hrs yesterday night) . Think there is a bug in 1.6.0 in Host Networking, anyone else has a problem ?

Note: Have been using VBox for a long time and I know what I am doing (Please don't take it otherwise), but I need serious help.

Thx

Change History

comment:1 Changed 6 years ago by sandervl73

Also see #1471

comment:2 Changed 6 years ago by sandervl73

  • Priority changed from major to critical

comment:3 Changed 6 years ago by goldiebahia

(I have also created a Topic under "virtualbox.org Forum Index -> VirtualBox on Windows Hosts -> Windows Host networking doesnt work in 1.6.0")

one of my friends there said "use the Intel Pro network interface and install the intel drivers", well I did that & it resolved half of the issue. I was able to ping from Windows guest to Windows host and vice versa but since I have a ADSL (pppoe) Internet connection it wont connect ... its ok till I create several instances of vbox0, vbox1, vbox2 ..., but the moment I bridge them I'm not able to connect using my ADSL which uses my LAN & which is also a part of the bridge, also even after sharing it, it wont connect.

Note: It used to work in 1.5.6.

So my guess is that there are 2 bugs ... One in the default PCI LAN drivers, Second in the VBoxManage.exe which creates instances of vbox0, vbox1 ... or maybe some drivers are installed in Windows which after bridging is interfering with my PPPOE connection. (I did restarted my modem also just in case if the MAC address of the Bridge changes and my network is locked to the old MAC, it doesn't help, but this modem restart helps in Linux)

These are serious issues which need urgent attention ...

Thx

comment:4 Changed 6 years ago by frank

  • Summary changed from Windows Host networking doesnt work in 1.6.0 to Windows Host networking doesnt work => Fixed in 1.6.2

Same problem as in #1471. Regression, fixed in SVN.

comment:5 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use