VirtualBox

Ticket #1471 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

host interface networking broken on linux hosts => Fixed in 1.6.2.

Reported by: appelo Owned by:
Priority: critical Component: other
Version: VirtualBox 1.6.0 Keywords: bridging host interface networking
Cc: Guest type: other
Host type: other

Description

Since upgrading to 1.6 there are problems with guests that have host interface networking configured. I get the following behaviour from time to time: I can see that network traffic leaves the guest (dhcp requests for example) and that my dhcp server sends dhcp offers packets. The dhcp offer never arrives at the guest. According to the statistics the nic receives zero packets. (using a static ip doesn't help either) I am running ubuntu 8.04 i386. The problem occurs on linux guests and windows guests. However, strangely enough I do not have this problem every time, but it occurs randomly (!!?) If i need to supply more info, let me know! There are also some posts on the forum about this:  http://forums.virtualbox.org/viewtopic.php?t=6092  http://forums.virtualbox.org/viewtopic.php?t=6146

Attachments

VBox.log Download (37.6 KB) - added by pofufo 6 years ago.
VBox.log file
VBox.2.log Download (29.1 KB) - added by eculpepper 6 years ago.
SLES10 host, Windows XP SP3 guest.

Change History

comment:1 Changed 6 years ago by sandervl73

Probably a duplicate of 1468, but I'll leave it open for now.

comment:2 follow-up: ↓ 3 Changed 6 years ago by sandervl73

  • Priority changed from major to critical

comment:3 in reply to: ↑ 2 Changed 6 years ago by goldiebahia

Replying to sandervl73:

reply regarding post # 1468

part 2:

one of my friends below said "use the Intel Pro network interface and install the intel drivers", well I did that & it resolved half of the issue. I was able to ping from Windows guest to Windows host and vice versa but since I have a ADSL (pppoe) Internet connection it wont connect ... its ok till I create several instances of vbox0, vbox1, vbox2 ..., but the moment I bridge them I'm not able to connect using my ADSL which uses my LAN & which is also a part of the bridge, also even after sharing it, it wont connect.

Note: It used to work in 1.5.6.

So my guess is that there are 2 bugs ... One in the default PCI LAN drivers, Second in the VBoxManage.exe which creates instances of vbox0, vbox1 ... or maybe some drivers are installed in Windows which after bridging is interfering with my PPPOE connection. (I did restarted my modem also just in case if the MAC address of the Bridge changes and my network is locked to the old MAC, it doesn't help, but this modem restart helps in Linux)

These are serious issues which need urgent attention ...

Thx

Last edited by goldiebahia on Sun May 04, 2008 4:41 pm; edited 2 times in total

comment:4 Changed 6 years ago by frank

Please could you attach your VBox.log file here? Which Linux guest is this exactly?

Changed 6 years ago by pofufo

VBox.log file

comment:5 Changed 6 years ago by pofufo

Hi, I've attached my VBox.log file. I updated Virtualbox this morning and can't use networking.

comment:6 follow-up: ↓ 9 Changed 6 years ago by eculpepper

I'm having the problem with the host interface being broken in linux hosts. My host is Suse Linux Enterprise 10 sp1 and the guest is Windows XP SP3. The host interface was working properly on 1.5.6, updated via rpm to 1.6 and the interface stops and Windows complains of limited(no) network connectivity. Only able to use Intel Pro/1000 driver with NAT to get *any* networking to work in the Windows guest.

Changed 6 years ago by eculpepper

SLES10 host, Windows XP SP3 guest.

comment:7 Changed 6 years ago by frank

  • Summary changed from host interface networking broken on linux hosts to host interface networking broken on linux hosts => Fixed in 1.6.2.

Thanks for these reports. We just found a regression in the PCNet implementation. This is fixed in SVN and the fix will be contained in the next release.

comment:8 Changed 6 years ago by JshWright

Confirming that PCNet host networking 'worksforme' with SVN build 8619

comment:9 in reply to: ↑ 6 Changed 6 years ago by nanocosm

Replying to eculpepper:

I'm having the problem with the host interface being broken in linux hosts. My host is Suse Linux Enterprise 10 sp1 and the guest is Windows XP SP3. The host interface was working properly on 1.5.6, updated via rpm to 1.6 and the interface stops and Windows complains of limited(no) network connectivity. Only able to use Intel Pro/1000 driver with NAT to get *any* networking to work in the Windows guest.

Host Network is running fine here with Intel PRO/1000 and Linux Host Bridge...

comment:10 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use