VirtualBox

Ticket #1464 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Windows XP guest hangs on boot with network adapter enabled on Ubuntu 8.04 host

Reported by: kc8tbe Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.0 Keywords: ubuntu 8.04 hardy heron xp hang
Cc: Guest type: other
Host type: other

Description

I have installed Virtualbox 1.6.0 on an x86_64 Intel machine running Ubuntu 8.04 Hardy Heron as a host. After installing Windows XP Professional (the 32-bit version) as a guest, the guest hangs when it boots up. The guest boots normally and does not hang if the emulated network adapter is disabled.

Both of the PCnet-FAST adapters cause the guest to hang. The Intel network adapter doesn't cause a hang, but that's probably only because I haven't installed Windows XP drivers for it. In fact, if the driver for any network adapter is installed after the guest boots then it works fine, and it won't hang until the guest is rebooted. This bug applies to Virtualbox 1.5.6, 1.6.0, and possibly other versions that I haven't tested. This is not a regression in 1.6.0; it is a new problem that started after I upgraded from Ubuntu 7.10 Gutsy Gibbon to Ubuntu 8.04 Hardy Heron.

There is a workaround:

  1. Install the guest with the network adapter disabled.
  2. Enable the PCnet-FAST III adapter.
  3. Boot the guest.
  4. The guest will automatically install drivers for the interface after it boots up. Now you can use the network normally.
  5. Before you shut down the guest, go into the Windows device manager and uninstall the driver for the network adapter (disabling it isn't good enough).
  6. Return to step 3 when desired.
  7. If you forget to do step 5, disable the network adapter and boot the guest. Make sure the driver has been uninstalled from the device manager, then shut the guest down and return to step 2.

This bug may be related to, or a duplicate of, bug #1460. Others have not reported any problems with the Hardy Heron host, so this bug may be specific to x86_64.

I've attached logs of the PCnet-Fast adapters causing a hang.

Attachments

Am79C970A.log Download (43.4 KB) - added by kc8tbe 6 years ago.
Am79C973.log Download (43.3 KB) - added by kc8tbe 6 years ago.

Change History

Changed 6 years ago by kc8tbe

Changed 6 years ago by kc8tbe

comment:1 Changed 6 years ago by frank

I think we fixed your issue. If you have access to the SVN and are able to compile VirtualBox yourself your might check the latest SVN revision.

comment:2 Changed 6 years ago by frank

Please make sure that you test r8610 or later from the public SVN.

comment:3 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use