VirtualBox

Ticket #14583 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

IntegrityError: (1062, "Duplicate entry 'regiol@mail.ru' for key 'PRIMARY'")

Reported by: iraduga Owned by:
Component: other Version: VirtualBox 5.0.4
Keywords: Cc:
Guest type: other Host type: other

Description

How to Reproduce

While doing a POST operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'acdc16296dc4af48c8f28a24',
 'nick': u'I_raduga',
 'referer': u'https://www.virtualbox.org/login'}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 126, in process_request
    ret = self._do_login(req)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 231, in _do_login
    @self.env.with_transaction()
  File "/usr/lib/python2.4/site-packages/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 236, in store_authnick
    (remote_user, nick))
  File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib64/python2.4/site-packages/MySQL_python-1.2.4b4-py2.4-linux-x86_64.egg/MySQLdb/cursors.py", line 202, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.4/site-packages/MySQL_python-1.2.4b4-py2.4-linux-x86_64.egg/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry 'regiol@mail.ru' for key 'PRIMARY'")

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #12460.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use