VirtualBox

Ticket #12460 (closed defect: obsolete)

Opened 6 years ago

Last modified 4 years ago

IntegrityError: (1062, "Duplicate entry 'terrylhorton@charter.net' for key 'PRIMARY'")

Reported by: fugitivebuster Owned by:
Component: other Version: VirtualBox 4.3.4
Keywords: Cc:
Guest type: other Host type: other

Description

How to Reproduce

While doing a POST operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'22010021b9db8a232bc380de',
 'nick': u'fugitivebuster56',
 'referer': u'https://www.virtualbox.org/login'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2; rv:11.0) like Gecko

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 124, in process_request
    ret = self._do_login(req)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 229, in _do_login
    @self.env.with_transaction()
  File "/usr/lib/python2.4/site-packages/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.4/site-packages/trac/web/auth.py", line 234, in store_authnick
    (remote_user, nick))
  File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib64/python2.4/site-packages/MySQL_python-1.2.4b4-py2.4-linux-x86_64.egg/MySQLdb/cursors.py", line 202, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.4/site-packages/MySQL_python-1.2.4b4-py2.4-linux-x86_64.egg/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry 'terrylhorton@charter.net' for key 'PRIMARY'")

Change History

comment:1 Changed 5 years ago by klaus

Do you have any idea how you could be using nick fugitivebuster56 all of a sudden? Because your nick is fugitivebuster, and the "new" one is what causes the database trouble, it rightfully complains about trying to create an ambiguous situation.

Did you get a page asking you to pick a new nick?

This affects about 40 people so far, and we can't immediately spot what could cause it.

comment:2 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

No answer, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use