VirtualBox

Ticket #1456 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

VirtualBox 1.6 keyboard issue

Reported by: TurboTalicska Owned by:
Priority: blocker Component: other
Version: VirtualBox 1.6.0 Keywords: international, keyboard, accent , key sequence
Cc: Guest type: other
Host type: Linux

Description

Hi, this problem did exist in 1.5.6 as well, but I did not bother reporting. I see that 1.6 has the same problem, so I guess it is time to report it. So. Finnish keyboard layout. In order to get the letter á, I have to press two keys in a row: ´ then a. Similarly ¨ + u = ü, etc. Start the ubuntu 8.04 installer, select English language, Finland as location, Finnish/Finnish keyboard. When I installed ubuntu 8.04 on my laptop, it was working properly. In VirtualBox it does not seem to work. There are ö and ä keys on the Finnish keyboard layout - these work; it is only the key sequences that do not work. Could You look into it, please? I marked it a "blocker" bug for now because I cannot type any letters that require such key sequences. Thank You.

Change History

comment:1 Changed 6 years ago by Burana

I have a similar problem under OpenSolaris 2008.05 (Host) and Windows XP (Guest)

My Keyboard is Swiss-German. Under Windows äüö do not work, but using ¨ + ä|ü|ö it works.

Using " + a|o|u does not work (it should)

Other characters not working:

§°~ => under AltGr+4 AltGr+5 ` ~

comment:2 Changed 6 years ago by nakaima

Hi guys i have the same problem here, i tried to change vboxkeyboard.so with the vboxkeyboard.so of version 1.5.6 and no run. can you help here??? The problem with my keyboard is the accentuation '`~ . Thanks on advanced

comment:3 Changed 6 years ago by futuresplash

Hi,
I also have a problem with accented characters, but on a portuguese keyboard. The 'dead keys' ( ` ' ^ ~ ) are not working.
I love Virtualbox, but this problem is a showstopper for me. Being unable to type accented characters like á,à,ã,â, etc, makes it impossible to use Virtualbox for many tasks.
My host system is Ubuntu Hardy and it is configured for the English language (i.e. it's not localized) except for the keyboard, which is configured for the portuguese keyboard layout.
Seeing this bug still present in this new version 1.6 worries me that I may not be able to use virtualbox again for a long time...
I hope you can fix it soon!

comment:4 follow-up: ↓ 5 Changed 6 years ago by nakaima

hi guys, i think have found the solution, do this in

KDE->System Configuration -> Language-> Keyboard : Keyboard portuguese, pt.

And selecting the checkbox which says

"include latin design/layout".

In Gnome just go to

System -> Administration -> Language Support and click on "Enable support to enter complex characters".

All this for portuguese and i think for other language. Greetings.

comment:5 in reply to: ↑ 4 Changed 6 years ago by futuresplash

Hi nakaima!
Thank you very much for your solution!! It worked!
But I had to do the following additional steps:

  1. Install translation support for the portuguese language
  2. Restart Gnome
  3. Select Portuguese on the login language selector.


Unfortunately, this means I have to use Ubuntu with a translated interface, which I don't like very much, because it mixes translated applications with half-translated (or not translated at all) applications. This is not ideal for me but, at least, now I can use Virtualbox!...

I think one should not consider this bug as really solved, for the following reasons:
a) I cannot use the O.S. in english (untranslated) with a portuguese keyboard
b) No other application on my system had similar problems, not even VMWare, so why does it happen with Virtualbox?

So I would like to make a suggestion to the Virtualbox developers:
It would be much better if a future version of Virtualbox:
a) would not depend on the "Enable support to enter complex characters" system setting and on the O.S. interface language,
b) or, at least, detect if the keyboard layout is not English and warn the user that he may need to change those system settings to get a proper keyboard behavior (the warning could be shown when launching a virtual machine).
Perhaps the best solution would be for Virtualbox to send the original raw key codes (as received from the keyboard hardware) to the guest O.S. That way, the guest would handle the keyboard using its own locale and drivers.

Best regards

comment:6 Changed 6 years ago by TurboTalicska

Hi nakaima!

Trouble is: I am trying to install Linux. The workaround you mention is not available. IMHO the workaround should not be needed at all: Linux does support the accented keys - problem is that VirtualBox does not pass the scan codes. Just try installing Linux on a real machine, or try it under VMWare and you will see.

comment:7 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of ticket #599.

comment:8 follow-up: ↓ 10 Changed 6 years ago by michael

A possible workaround for this problem (for Gnome users, as there is already a decent workaround for KDE hosts) may be to set the keyboard mapping using setxkbmap. Examples (note that nothing follows "-option":

Finnish keyboard: setxkbmap -model pc105 -layout fi,us -option Swiss-German: setxkbmap -model pc105 -layout ch,us -variant de -option

Other things to check: there may be a message in the log file relating to keyboard; make sure that you have selected the right keyboard layout in the guest OS.

comment:9 Changed 6 years ago by frank

  • Host type changed from other to Linux

comment:10 in reply to: ↑ 8 Changed 6 years ago by r_mano

Replying to michael:

Finnish keyboard: setxkbmap -model pc105 -layout fi,us -option

This didn't work for having my dead-keys (on a Spanish keyboard, gnome, Ubuntu 8.04) but it was a useful hint. Doing

setxkbmap -model pc105 -layout us -option

the keyboard is set globally to us-layout, making the (Spanish!) layout on the VirtualBox client work ok, dead key included, although now all the other application see (obviously) a us-keyboard. To go back, I can use the same command with "es" layout. It's a horrible hack but it works. Unfortunately, using the gnome applet to switch layout (which does it on a window per window base) does not work.

Nevertheless, this is a big problem. I understand it is an interaction with a new behavior in qt libraries, as told on #599... it is not possible to stick to old qt libraries till the problem is solved? This bug makes VirtualBox a lot of damage, much friends of mine simply dismissed it with a "don't work, back to VMware".

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use