VirtualBox

Ticket #14545 (reopened defect)

Opened 21 months ago

Last modified 10 months ago

"Failed to create host network interface" on Windows 10 => Fixed in SVN

Reported by: BlueRaja Owned by:
Priority: blocker Component: other
Version: Keywords:
Cc: Guest type: other
Host type: Windows

Description

I'm trying to get Xamarin Android Emulator working on Windows 10. It's failing because VirtualBox does not have a host network adapter set up. It worked fine on Windows 8.

When I attempt to create a host network adapter in Virtual Box, I get this error:

"Failed to create the host network interface Result Code: E_FAIL (0x80004005)"

I've tried doing a uninstalling/reinstalling, and doing a repair install. I don't know if this is related to #14040, but I'm using the latest beta, which supposedly fixed that issue..

Version: 5.0.3-102322-Win

Attachments

VMBox.txt Download (195.7 KB) - added by Sae1962 21 months ago.
Result of commands

Change History

comment:1 Changed 21 months ago by BlueRaja

I should mention the installer acts like the host-only networking interface is installed correctly, but it's definitely not.

Are there any logs I can provide to help debug?

Update: I also tried version 5.0.3-102467-Win, with the same results.
Update2: Also tried 5.0.2-102096-Win for good measure, same results.

Last edited 21 months ago by BlueRaja (previous) (diff)

comment:2 Changed 21 months ago by frank

Please check if VBox 5.0.4 fixes your problem.

comment:3 Changed 21 months ago by KevinS80

Still an issue with 5.0.4

Edit: I tried to uninstall Virtual box. Then reinstall 5.0.4. It wouldn't finish the install. I then figured out how to get a log file of the install. Best I can tell, this is the install error that causes the rollback.

MSI (s) (CC:F8) [14:17:46:731]: Executing op: ActionStart(Name=ca_CreateHostOnlyInterfaceNDIS6) MSI (s) (CC:F8) [14:17:46:731]: Executing op: CustomActionSchedule(Action=ca_CreateHostOnlyInterfaceNDIS6,ActionType=3073,Source=BinaryData,Target=Ndis6CreateHostOnlyInterface,CustomActionData=C:\Program Files\Oracle\VirtualBox\drivers\network\netadp6\) MSI (s) (CC:3C) [14:17:46:762]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI3BC3.tmp, Entrypoint: Ndis6CreateHostOnlyInterface CreateHostOnlyInterface: Creating host-only interface CreateHostOnlyInterface: NetAdpDir property = C:\Program Files\Oracle\VirtualBox\drivers\network\netadp6\ CreateHostOnlyInterface: Resulting INF path = C:\Program Files\Oracle\VirtualBox\drivers\network\netadp6\VBoxNetAdp6.inf CreateHostOnlyInterface: Calling VBoxDrvCfgInfInstall(C:\Program Files\Oracle\VirtualBox\drivers\network\netadp6\VBoxNetAdp6.inf) CreateHostOnlyInterface: VBoxDrvCfgInfInstall returns 0x0 UpdateHostOnlyInterfaces: VBoxNetCfgWinUpdateHostOnlyNetworkInterface failed, hr = 0xe000020b CreateHostOnlyInterface: calling VBoxNetCfgWinCreateHostOnlyNetworkInterface Querying NetCfgInstanceId failed (0x00000000) CreateHostOnlyInterface: VBoxNetCfgWinCreateHostOnlyNetworkInterface returns 0x80004005 CreateHostOnlyInterface: VBoxNetCfgWinCreateHostOnlyNetworkInterface failed, error = 0x80004005 CreateHostOnlyInterface: Almost done... CreateHostOnlyInterface: Returns success (ignoring all failures)

Last edited 21 months ago by KevinS80 (previous) (diff)

comment:4 Changed 21 months ago by aleksey

Do I understand it correctly that after VBox installation there is no host-only adapter on your system? Please provide the output of

ipconfig /all

and

driverquery /fo list /v

and

VBoxManage hostonlyif create

with VBox 5.0.4. It would be great if you provided VM log (preferably one bridged to physical Ethernet adapter) and VBoxSVC.log too.

comment:5 Changed 21 months ago by aleksey

KevinS80,

there is no need to provide all the info I asked for in comment 4. I wrote it before I saw your latest edit of comment 3. It already provides enough information to identify the error. Thanks a lot!

comment:6 Changed 21 months ago by Sae1962

Hello!

I want to run the VMBox under Windows 10, but have problems having the four "Adapter 0"s in the Network setting after the message

Could not start the machine FW732_1a (OPC Serv. Simulator) because the following physical network interfaces were not found:

VirtualBox Host-Only Ethernet Adapter (adapter 2)

You can either change the machine's network settings or stop the machine.

Deactivating the adaptors does not solve the problem.

When I select an "Heedless" or a "Detachable" start, the progress bar goes to 100%, ending with the same error message (E_FAIL (0x80004005)) at the end.

Do you have a (beta) version for Windows 10? I attached the results of the commands ipconfig /all and driverquery /fo list /v into the VMBox.txt file.

There is good news for Windows 10 users, however, as VMBox 4.3.30 runs without problems!

Last edited 21 months ago by Sae1962 (previous) (diff)

Changed 21 months ago by Sae1962

Result of commands

comment:7 Changed 21 months ago by aleksey

Sae1962, could you provide the failing VM log and VBoxSVC.log, please?

comment:8 Changed 21 months ago by BlueRaja

I ended up uninstalling Windows 10 because I cannot wait for this to be fixed. But please leave this issue open, since others are able to repro it.

comment:9 Changed 20 months ago by klapperkopp

I have the same prob also on Win 10. I was updating from 4.x to 5.0.4 and had the adapter first. Laravel homestead wanted to create new ones and didn't work so I uninstalled. Now I can't install anymore because I get the same error on install. The weird thing is it worked before... the adapter was there... :(

comment:10 Changed 20 months ago by fangtr

When I was updating from 5.0.4 to 5.0.6,it problems also arise. My OS is windows 10 pro 64bit 10240.

Last edited 20 months ago by fangtr (previous) (diff)

comment:11 Changed 19 months ago by travassos

Hi,

this problem still occurs on version 5.0.10.

comment:12 Changed 18 months ago by keklabs

I have the same issue on Windows 7, VirtualBox 5.0.10, when I try to create Docker virtual machine.

It is related to

 https://github.com/docker/machine/issues/1754

Failed to open a session for the virtual machine test-docker11.

Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter #3' (VERR_INTNET_FLT_IF_NOT_FOUND).

Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

But the report from IPCONFIG is:

Ethernet adapter VirtualBox Host-Only Network #3:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter #3
   Physical Address. . . . . . . . . : 0A-00-27-00-00-00
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::1023:4a8d:66ed:896%35(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.36.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 587857959
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-21-BB-9B-F0-DE-F1-97-4D-2C
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Same issue occures, when I remove all HostOnly adapters and create nad configure new one for VM. I disable the AVG antivirus, and still the same issue.

comment:13 Changed 18 months ago by keklabs

I resolved my issue

the  https://forums.virtualbox.org/viewtopic.php?f=6&t=68590&start=450#p345381

"After re-installing VB I switched on "VirtualBox NDIS6 Bridged Networking Driver" in properties network connection."

Now it is working.

comment:14 Changed 18 months ago by aleksey

Please try build 104592. It is important to uninstall VirtualBox before installing the test build as it will ensure that all unbound host-only adapters are removed.

comment:15 Changed 18 months ago by frank

Or test the latest 5.0.x Windows test build.

Last edited 18 months ago by frank (previous) (diff)

comment:16 Changed 18 months ago by aleksey

  • Summary changed from "Failed to create host network interface" on Windows 10 to "Failed to create host network interface" on Windows 10 => Fixed in SVN

comment:17 Changed 18 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.0.12.

comment:18 Changed 17 months ago by Vito

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry to say the issue is not fixed with VBox 5.0.12.
I did not have this issue with 5.0.10, until I upgraded to 5.0.12.
Then I had the issue.
I tried uninstalling and reinstalling, but no success until I fixed it following the  https://forums.virtualbox.org/viewtopic.php?f=6&t=68590&start=450#p345381
(I added VirtualBox NDIS6 Bridged Networking Driver element to the VirtualBox Host-Only Ethernet Adapter). Windows 10 Professional 64 bit here.

comment:19 Changed 16 months ago by proxenus

In case it can help to fix the issue, this is the workarround I apply when I encounter this issue.

On my side is always related to an upgrade from 4.x to 5.x. The machines started or created in the "upgraded" systems fail to start.

the issue is related to the stored "default" virtual box adapter in the host.

the workarround to solve the issue is.

1- File > Preferences > net

2- Select Host only network.

3- Create a new Host only network (it shall appear with a new name and a prefix at the end like #2)

4- Open the virtual machine configuration

5- VM > configuration > net

6- Select the interface and change the name to the new created one in step 3.

it fix the issue 100% of the times this issue happens.

hope this helps to find the root cause.

Last edited 16 months ago by proxenus (previous) (diff)

comment:20 Changed 10 months ago by Ajedi32

FYI, I encountered this same error while trying to create a VirtualBox VM through Vagrant:

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'bento/ubuntu-14.04' is up to date...
==> default: Clearing any previously set network interfaces...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Querying NetCfgInstanceId failed (0x00000002)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage.exe: error: Context: "enum RTEXITCODE __cdecl handleCreate(struct HandlerArg *)" at line 71 of file VBoxManageHostonly.cpp

I was able to work around this problem for me with the following steps:

  1. Open the VirtualBox Manager GUI.
  2. Go to File -> Preferences -> Network -> Host-only Networks
  3. Delete all entries in that list
  4. Run vagrant up again
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use