VirtualBox

Ticket #14287 (closed defect: obsolete)

Opened 5 years ago

Last modified 8 months ago

Experienced problems with usb devices. I checked the log file to find the following.

Reported by: silverbody Owned by:
Component: USB Version: VirtualBox 4.3.30
Keywords: usb Cc:
Guest type: Solaris Host type: Windows

Description

OHCI#0: Lagging too far behind, not trying to catch up anymore. Expect glitches with USB devices

I am unsure if the above is the source of my problem but I am trying to attach a usb card reader to my guest os. I can capture the device but it never shows a check mark by the device and when I try to click again it either hangs or I recieve this error:

Failed to attach the USB device MobileMate SD+ [9404] to the virtual machine Solaris.

USB device 'MobileMate SD+' with UUID {e9630b23-3b8b-4504-8153-fba03ffde727} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057) Component: HostUSBDevice Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a} Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

I have tried this with and without the usb extension pack to no avail.

Attachments

VBox.log Download (93.6 KB) - added by silverbody 5 years ago.
VBox.2.log Download (55.6 KB) - added by silverbody 5 years ago.
log file for 7/212015
VBox.3.log Download (89.5 KB) - added by silverbody 5 years ago.
with usb extension installed

Change History

Changed 5 years ago by silverbody

comment:1 Changed 5 years ago by silverbody

I found a workaround for my usb problem on the virtual box windows forums from user nayasis. The follow is his post from  https://forums.virtualbox.org/viewtopic.php?f=6&t=39104

I've got solution finally... T-T

(It seems like problem of window 7)

  1. My Host is window 7 32bit home premium. But, 64bit's solution may be same because problem was caused by USB filtering function of WINDOW 7.
  1. first of all, edit your registry
  • Open the Windows registry, by clicking on Start > Run and typing regedit
  • Navigate to the following location [b] HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}b
  • In the right hand panel, if the the UpperFilters entry exists, then delete it
  1. Install virtualbox USB driver manually.
  • Goto folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filterb
  • Click right mouse button on file named [b]VboxUSBMon.infb
  • Check Install(I) (maybe.. My window is korean so it dose not exact. )
  1. Rebooting
  1. Unplug your USB memory (or joystick..)
  1. Open VirtualBox and Close it rightly. ( it will remove your USB device from VM's seized list. )
  1. Plug your USB memory.
  1. Open VirtualBox and Run Virtual Machine.
  1. Click right mouse button on USB icon placed in status bar which is below VM window.
  1. Check USB device what you want to plug in.
  1. Enjoy !!

notice !!

Do not chain your USB device like snake. for example... A usb bridge <- B usb device... and check B usb device in VM. like this...

to use B usb device, you must check A usb bridge first !... it's so complicate..

The log error, OHCI#0: Lagging too far behind, not trying to catch up anymore. Expect glitches with USB devices, is still occurring.

Changed 5 years ago by silverbody

log file for 7/212015

comment:2 Changed 5 years ago by frank

Please attach a nother VBox.log file when you installed the Extension Pack and enabled USB 2.0 in the VM settings.

Changed 5 years ago by silverbody

with usb extension installed

comment:3 Changed 5 years ago by TimOr

Ticket #11251 looks similar. Solution from  https://forums.virtualbox.org/viewtopic.php?f=6&t=39104 also worked for me. Except it's not explained what exactly it does, and whose bug is it.

Last edited 5 years ago by frank (previous) (diff)

comment:4 Changed 8 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use