VirtualBox

Ticket #14288 (closed defect: fixed)

Opened 21 months ago

Last modified 7 months ago

Regression: VirtualBox 5.0 lost ability to convert Hyper-V Windows 2012 (non-R2) => fixed in SVN/next maintenance

Reported by: Kriston Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 5.0.0 Keywords: vmdk hyper-v regression
Cc: Guest type: Windows
Host type: Mac OS X

Description

Regression: VirtualBox 5.0 lost ability to convert Hyper-V Windows 2012 (non-R2).

In VirtualBox 4.3 and earlier, this command functions normally: VBoxManage showhdinfo file.vhdx VBoxManage clonehd file.vhdx newfile.vmdk --format VMDK

In VirtualBox 5.0, these error with these messages (transcribed here): VBoxManage: error: VHDX: Can not load the image because both headers are corrupt (VERR_VD_GEN_INVALID_HEADER). VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MediumWrap, interface IMedium, callee nsISupports VBoxManage: error: Context: "OpenMedium(Bstr(pszFilenameOrUuid),raw(), enmDevType, enmAcessMode, fForceNewUuidOnOpen, pMedium.asOutParam())" at line 177 of file VBoxManageDisk.cpp

Change History

comment:1 Changed 21 months ago by Kriston

Downgrading back to VirtualBox 4.3 completely resolves the problem. Consider this as a regression that should be brought forward and fixed in VirtualBox 5.x.

comment:2 Changed 20 months ago by njaehner

Confirmed. I have noticed the same problem:

VirtualBox 5.0:

MyAccount$ VBoxManage clonehd --format VHD Laptop.VHDX Laptop.VHD
VBoxManage: error: Could not open the medium '/Volumes/ExternalDisk/Laptop.VHDX'.
VBoxManage: error: VHDX: Can not load the image because both headers are corrupt (VERR_VD_GEN_INVALID_HEADER).
VBoxManage: error: VD: error VERR_VD_GEN_INVALID_HEADER opening image file '/Volumes/ExternalDisk/Laptop.VHDX' (VERR_VD_GEN_INVALID_HEADER)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MediumWrap, interface IMedium, callee nsISupports
VBoxManage: error: Context: "OpenMedium(Bstr(pszFilenameOrUuid).raw(), enmDevType, enmAccessMode, fForceNewUuidOnOpen, pMedium.asOutParam())" at line 177 of file VBoxManageDisk.cpp

VirtualBox 4.3.30:

MyAccount$ VBoxManage clonehd --format VHD Laptop.VHDX Laptop.VHD
Password:
0%...

comment:3 Changed 12 months ago by btreeq

Still a problem in VirtualBox 5.0.14 r105127:

'C:\Users\xxxx\Desktop>vboxmanage clonehd --format VDI boot_drive.vhxd boot_drive.vdi
VBoxManage.exe: error: Could not open the medium 'C:\Users\xxxx\Desktop\boot_drive.vhxd'.
VBoxManage.exe: error: VHDX: Can not load the image because both headers are corrupt (VERR_VD_GEN_INVALID_HEADER).
VBoxManage.exe: error: VD: error VERR_VD_GEN_INVALID_HEADER opening image file 'C:\Users\xxxx\Desktop\boot_drive.vhxd' (VERR_VD_GEN_INVALID_HEADER)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component MediumWrap,interface IMedium, callee IUnknown
VBoxManage.exe: error: Context: "OpenMedium(Bstr(pszFilenameOrUuid).raw(), enmDevType, enmAccessMode, fForceNewUuidOnOpen, pMedium.asOutParam())" at line 178 of file VBoxManageDisk.cpp'

Note: .vhxd created with disk2vhd v2.01.
Host: Win 7 x64 SP1 + RSAT Tools with Hyper-V activated.

Last edited 12 months ago by btreeq (previous) (diff)

comment:4 Changed 11 months ago by quantumburnz

Still a problem in VirtualBox 5.0.16 r105871 as well:

C:\Program Files\Oracle\VirtualBox>vboxmanage clonehd --format VHD "E:\Hyper-V\Virtual Hard Disks\Ubuntu.vhdx" "E:\Hyper-V\Virtual Hard Disks\Ubuntu.vhd" VBoxManage.exe: error: Could not open the medium 'E:\Hyper-V\Virtual Hard Disks\Ubuntu.vhdx'. VBoxManage.exe: error: VHDX: Can not load the image because both headers are corrupt (VERR_VD_GEN_INVALID_HEADER). VBoxManage.exe: error: VD: error VERR_VD_GEN_INVALID_HEADER opening image file 'E:\Hyper-V\Virtual Hard Disks\Ubuntu.vhdx' (VERR_VD_GEN_INVALID_HEADER) VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component MediumWrap, interface IMedium, callee IUnknown VBoxManage.exe: error: Context: "OpenMedium(Bstr(pszFilenameOrUuid).raw(), enmDevType, enmAccessMode, fForceNewUuidOnOpen, pMedium.asOutParam())" at line 178 of file VBoxManageDisk.cpp

comment:5 Changed 8 months ago by aeichner

  • Summary changed from Regression: VirtualBox 5.0 lost ability to convert Hyper-V Windows 2012 (non-R2) to Regression: VirtualBox 5.0 lost ability to convert Hyper-V Windows 2012 (non-R2) => fixed in SVN/next maintenance

Thanks for the report, I was able to reproduce and fix the issue. Will be part of the next maintenance release. In the meantime you can use the vbox-img tool for the conversion.

comment:6 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use