VirtualBox

Ticket #1368 (closed defect: invalid)

Opened 6 years ago

Last modified 4 years ago

Problem to build VirtualBox on Slackware 12.0 => Fixed in 1.6.2

Reported by: iguito Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: other

Description

When I tried to build VirtualBox 1.5.6 from the source code (tar.bz2), the follow message error appeared after command "kmk all":

kBuild: Compiling VBoxREM - translate-op.c In file included from /usr/src/virtualbox/vbox/src/recompiler/translate-op.c:70: /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h: In function 'dyngen_code': /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4596: error: 'memcpy' redeclared as different kind of symbol /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4597: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4613: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4630: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4646: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4662: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4803: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4819: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4835: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4851: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4951: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4967: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4983: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:4999: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:5016: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:5030: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:5044: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:5058: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:7156: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:7245: error: called object 'memcpy' is not a function /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/op.h:7334: error: called object 'memcpy' is not a function kmk[2]: * usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/translate-op.o Error 1 The failing command: @gcc -c -O2 -Wall -g -fomit-frame-pointer -fno-gcse -IInnoTek -IInnoTek/crt -Itarget-i386 -Ifpu -I/usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM -I/usr/src/virtualbox/vbox/src/VBox/VMM -I/usr/src/virtualbox/vbox/src/recompiler -I/usr/src/virtualbox/vbox/include -I/usr/src/virtualbox/vbox/out/linux.x86/release -DVBOX -DVBOX_OSE -DREM_PHYS_ADDR_IN_TLB -DRT_OS_LINUX -D_FILE_OFFSET_BITS=64 -DRT_ARCH_X86 -DX86 -DIN_REM_R3 -DREM_INCLUDE_CPU_H -DIN_RING3 -DLOG_USE_C99 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT -Wp,-MD,/usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/translate-op.o.dep -Wp,-MT,/usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/translate-op.o -Wp,-MP -o /usr/src/virtualbox/vbox/out/linux.x86/release/obj/src/recompiler/VBoxREM/translate-op.o /usr/src/virtualbox/vbox/src/recompiler/translate-op.c kmk[2]: Leaving directory `/usr/src/virtualbox/vbox/src/recompiler' kmk[1]: * [pass_dlls_before] Error 2 kmk[1]: Leaving directory `/usr/src/virtualbox/vbox/src' kmk: * [pass_dlls_before] Error 2

I solved my problem getting the binary on  https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_SMI-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=innotek-1.5.6-G-F@CDS-CDS_SMI

thanks :)

Attachments

translate-op.i.gz Download (36.3 KB) - added by eilart 6 years ago.
translate.op.i
vbox.build.log.gz Download (1.2 KB) - added by eilart 6 years ago.
kmk log
diff_dyngen Download (528 bytes) - added by frank 6 years ago.
Patch against dyngen.c

Change History

comment:1 Changed 6 years ago by frank

Which gcc version is that?

comment:2 Changed 6 years ago by d00p

got the same issue on Gentoo, neither the ebuild app-emulation/virtualbox-1.5.6 USE="additions alsa pulseaudio -sdk" nor the current svn-trunk compiles for me.

gcc-config -l shows "i486-pc-linux-gnu-4.2.3",

i have gcc compiled with the following options:

sys-devel/gcc-4.2.3 USE="fortran mudflap nls openmp (-altivec) -bootstrap -build -doc -gcj -gtk (-hardened) -ip28 -ip32r10k -libffi (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla"

regards, Michael

comment:3 Changed 6 years ago by d00p

hi, me again, strange thing:

works perfectly with "i686-pc-linux-gnu-4.2.3" :)

comment:4 Changed 6 years ago by ppr-kut

I can confirm this compilation error on Slackware 12.1rc2 with glibc 2.7 and gcc 4.2.3 with both version 1.5.6 as well as trunk r8331.

comment:5 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Problem solved then.

comment:6 Changed 6 years ago by ppr-kut

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry, but no. Using the binary does indeed solve the problem of not having a runnable Virtualbox, but the OSE version does still NOT compile. The problem was therefore not solved, but merely avoided. The bug remains.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to invalid

Report this to the developers mailinglist please. This is not a bug.

Changed 6 years ago by eilart

translate.op.i

Changed 6 years ago by eilart

kmk log

Changed 6 years ago by frank

Patch against dyngen.c

comment:8 Changed 6 years ago by frank

  • Summary changed from Problem to build VirtualBox on Slackware 12.0 to Problem to build VirtualBox on Slackware 12.0 => Fixed in 1.6.2

Finally fixed the problem in the SVN. Thanks for the help, eilart.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use