VirtualBox

Opened 10 years ago

Closed 7 years ago

#13504 closed defect (obsolete)

4.3.18 - Unable to load R3 module

Reported by: marebul Owned by:
Component: other Version: VirtualBox 4.3.18
Keywords: r3 module Cc:
Guest type: all Host type: Windows

Description

Hi, getting this message for ALL my VMs since updating to 4.3.18. Can't launch any of them. Went back to 4.3.16.

NEVER had any bug with any previous versions of VB until 4.3.14. Now, I'm getting different issues (some are solved) with ALL the new versions... What's going wrong ? Is Windows 7 concerned ?

"Échec de l'ouverture de session pour la machine virtuelle xxx.

Unable to load R3 module C:\Program Files\VirtualBox/VBoxDD.DLL (VBoxDD): GetLastError=1790 (VERR_UNRESOLVED_ERROR).

Code d'erreur : E_FAIL (0x80004005) Composant : Console Interface : IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}"

Attachments (3)

VBoxSVC.log (8.1 KB ) - added by marebul 10 years ago.
VirtualBox - Hiba.png (39.6 KB ) - added by Gabee 10 years ago.
VBoxStartup.log (507.8 KB ) - added by regs 10 years ago.
4.3.19 r96825 VBoxStartup.log

Download all attachments as: .zip

Change History (27)

by marebul, 10 years ago

Attachment: VBoxSVC.log added

comment:1 by Petr Vones, 10 years ago

See https://forums.virtualbox.org/viewtopic.php?f=6&t=64111 and post it there including information about installed anti-virus software.

Basically 4.3.12 is last version that works reliably.

Last edited 10 years ago by Petr Vones (previous) (diff)

comment:2 by Frank Mehnert, 10 years ago

The really interesting bit of information is the VBoxStartup.log file.

by Gabee, 10 years ago

Attachment: VirtualBox - Hiba.png added

comment:4 by regs, 10 years ago

Tryed test build 4.3.19 r96825. Wouldn't start virtual machines as well.

comment:5 by Frank Mehnert, 10 years ago

I'm sorry, I must have missed your VBoxStartup.log. Could you attach the VBoxStartup.log to this ticket when you try to start your VM with the latest 4.3.19 Windows test build? Compress the file if it's too big. Thank you!

by regs, 10 years ago

Attachment: VBoxStartup.log added

4.3.19 r96825 VBoxStartup.log

comment:6 by regs, 10 years ago

same with r96945

comment:7 by marebul, 10 years ago

Indeed, same with 4.3.20.

My Uxtheme.dll IS patched, and I won't roll it back. I'll keep 4.3.12 or 4.3.16 but things are going very bad since 4.3.14 with lots of unsolved bugs.

comment:8 by annaparker, 10 years ago

Confirm there's problem. I've tried to install on 4.3.20 and got error: "Unable to load R3 module C:\Program Files\VirtualBox/VBoxDD.DLL". However it was on my friend's computer, so I don't have log.

Host is updated Win7 x64, Intel i5. The guest I've tried Win7 x32. (don't know it's up to gues, I don't think so).

comment:9 by Sparkpin, 9 years ago

Can confirm that the problem remains on 4.3.22 on host Win7 x64 SP1; guests MS-DOS 6.22, Windows 2000, and Windows XP.

comment:10 by Maverix, 9 years ago

Problem remains with build 4.3.24-98716 on host Win7 x64 SP1 with XP and Win7 x32 and x64 guests.

comment:11 by Christian Rilke, 9 years ago

Same problem with build 4.3.26 r98988 win.amd64 (Mar 16 2015 17:35:35)

Unable to load R3 module C:\Program Files\Oracle\VirtualBox/VBoxDD.DLL (VBoxDD): GetLastError=1790 (VERR_UNRESOLVED_ERROR).

Fehlercode:E_FAIL (0x80004005) Komponente:Console Interface:IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

comment:12 by Maverix, 9 years ago

On my system, if the following files are patched by the Universal Theme Patcher (by DeepXW), this consistently generates the "Unable to load R3 module" problem even when the v4.3.26 r98988 host is installed:

themeservice.dll themeui.dll uxtheme.dll

Generally, you can ensure that these files are not patched or corrupted by running the following command at the DOS command prompt: sfc /scannow.

The Universal Theme Patcher is used to enable third party themes in Windows 7. A different theme patcher (UXTheme Multi-Patcher v14.2) enables third part themes but does not patch the theme files on your hard drive. Instead, it patches the files after they are loaded into memory. When the multi-patcher is installed, I can successfully install and run Windows guests in the Virtual Box.

This problem is now resolved on my system with build 4.3.26 r98988. I'm running a Win7 x64 SP1 host on an HP dv7-4283cl laptop with 8Gb memory and switchable AMD/HP graphics. XP and Win7 x64 VM guests are running flawlessly. I have not tested it with other OS VMs.

Last edited 9 years ago by Maverix (previous) (diff)

comment:13 by marebul, 9 years ago

You're right Maverix, I'm using the "Universal Theme Patcher", which patches the .DLL directly, but I don't want to use the "UxTheme Multi-Patcher", which patches the .DLL through a service executed in the background. Meanwhile, using VMWare... Until Oracle resolves this (opened this ticket 6 months ago.....). Still not corrected in 5.0b1 ! Getting this :

Code d'erreur :
E_FAIL (0x80004005)
Composant :
ProgressProxy
Interface : 
IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}
Last edited 9 years ago by marebul (previous) (diff)

comment:14 by Sapioit, 9 years ago

Why is this still not patched and why do I have to downgrade to 4.3.12 every time you update VirtualBox? Such a great software unable to be used due to such a bug the devs don't allocate their time to correct...

And NO, I am NOT interested in installing a tirth-party software/service to be able to use custom themes in Win7! I am still using a downgraded version of your software because you're not willing you fix a bug you made'''

Version 0, edited 9 years ago by Sapioit (next)

comment:15 by Stanislav, 9 years ago

I support Sapioit! Please fix this bug, it is not real to use VirtualBox version upper than 4.3.16!

We want to use newer version without deletion of custom theme. I think it is not really hard to fix this BUG.

Thank you!

comment:16 by latoremu, 9 years ago

The bug is still present in VirtualBox-5.0.4-102546.

comment:17 by xzuttz, 9 years ago

I created a virtual machine on one computer and copied it to another. When trying to start it I recieve this error. The 'other' computer runs VirtualBox ver. 5.0.4-r102546

comment:18 by Aaron Cdc, 9 years ago

The "bug" still persists in version 5.0.6 r103037

Unable to load R3 module D:\Program Files\Oracle\VirtualBox/VBoxDD.DLL (VBoxDD): GetLastError=1790 (VERR_UNRESOLVED_ERROR).


Result code: 
E_FAIL (0x80004005)
Component: 
ConsoleWrap
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I also have patched themes, running this on Windows 8.1. I highly doubt Oracle is to blame on this. This doesn't seem like a bug in the program, we are the ones modifying our systems to allow unofficial themes. In other words, this is not a bug in the program, so there is nothing for them to fix. If anyone is to blame is Microsoft, for not allowing a better customization on their systems, forcing us to alter the system in a probably not even legal way to make it look better. Perhaps we should go to Microsoft and complain directly to them instead.

As for now, I think we only have four choices:

  • Unpatch Windows themes, and stick to the classic theme. Boring, but functional.
  • Unpatch Windows themes, and use a custom shell. Loads the system with more services and processes, but looks better and is also functional.
  • Do not unpatch Windows themes. Use another virtualization software, or use a Linux distribution instead for virtualization.
  • The hardest: grab the source, make a clone, and do it in a way that bypasses this error somehow, if it's possible.
Last edited 9 years ago by Aaron Cdc (previous) (diff)

comment:19 by latoremu, 9 years ago

I came up with the genius solution of restoring and patching the files before and after each run. It takes 3 clicks both ways if you have the patcher at hand.

comment:20 by code_monkey, 9 years ago

There is a tool which can resolve the problem while it is in Chinese. You can download it from http://pan.baidu.com/s/1eQtgLKA then copy and paste the .dll backups into windows/System then you can select “恢复” which means "restore" in English. And I have solved my problem.

comment:21 by BelieverUfa, 9 years ago

Hello all)

This is a very easy to resolve.

Root of problem - file in %WINDIR%/system32/uxtheme.dll This file are patched by many builders of torrent windows insallers. If you lucky, you find original backuped version of this file that name is uxtheme.dll.backup. Just replace this backup file and this error in VirtualBox (unable to load R3 module) goes away.

If you not found backuped version of this file, this url is one of places there located original dll: https://drive.google.com/file/d/0B8_buLPe3IyPbURiVm9xSXJnNTA/view

comment:22 by blast0id, 8 years ago

still a problem with latest version (as of the date of this posting) seriously guys... you shouldn't have to unpatch a system to use a virtual machine... completely absurd, what the hell!

comment:23 by ludo007, 8 years ago

According to: https://www.virtualbox.org/ticket/13767 they do not intend to fix anything b/c it is a security issue ... Time to change solution for virtualisation at least for me. Bye bye virtual box

comment:24 by Frank Mehnert, 7 years ago

Resolution: obsolete
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use