VirtualBox

Ticket #13461 (closed defect: obsolete)

Opened 7 years ago

Last modified 15 months ago

Unable to start VM from saved state

Reported by: Uku Loskit Owned by:
Component: other Version: VirtualBox 4.3.16
Keywords: Cc:
Guest type: other Host type: other

Description


Attachments

VBox.log Download (91.2 KB) - added by Uku Loskit 7 years ago.
VBox.log.new Download (89.7 KB) - added by Uku Loskit 7 years ago.

Change History

Changed 7 years ago by Uku Loskit

comment:1 Changed 7 years ago by Uku Loskit

Hello!

I'm unable to start a vm using

VBoxManage startvm vmname --type headless

This issue is 100% reproducible after restarting OSX and no user is logged in via the GUI and I connect via SSH.

From the log I think the problem might be with the clipboard service, in particular:

1051	00:00:18.974435 HGCM: restoring [VBoxSharedClipboard]
1052	00:00:18.974438 AssertLogRel /Users/vbox/tinderbox/4.3-mac-rel/src/VBox/Main/src-client/HGCM.cpp(1257) static int HGCMService::LoadState(SSMHANDLE*): pSvc
1053	00:00:18.974442 rc=VERR_HGCM_SERVICE_NOT_FOUND, VBoxSharedClipboard
1054	00:00:18.974463 SSM: LoadExec failed for 'HGCM' instance #0 (version 2, pass 0xffffffff): VERR_SSM_UNEXPECTED_DATA
1055	00:00:18.974477 VMSetError: /Users/vbox/tinderbox/4.3-mac-rel/src/VBox/VMM/VMMR3/SSM.cpp(8349) int ssmR3LoadExecV2(VM*, SSMHANDLE*); rc=VERR_SSM_UNEXPECTED_DATA
1056	00:00:18.974479 VMSetError: Failed to load unit 'HGCM'
1057	00:00:18.974492 Releasing keys...

VBoxSharedClipboard service seems to fail to start, which is weird since there is no Guest additions support for OSX and the feature is disabled for the VM.

Last edited 7 years ago by Uku Loskit (previous) (diff)

comment:2 follow-up: ↓ 3 Changed 7 years ago by frank

Did you start the 4.3.14 VM where you take this saved state from with the same command (VBoxManage startvm vmname --type headless)? Was it running on the same host?

comment:3 in reply to: ↑ 2 Changed 7 years ago by Uku Loskit

Replying to frank:

Did you start the 4.3.14 VM where you take this saved state from with the same command (VBoxManage startvm vmname --type headless)? Was it running on the same host?

If the log has different versions mixed, i'm sorry. I tried upgrading to the latest version to see if this bug had been fixed. The issue was present in 4.3.14 (regardless of any upgrades), and persists in the latest version.

Last edited 7 years ago by Uku Loskit (previous) (diff)

comment:4 Changed 7 years ago by frank

I'm sorry, could you actually answer my two questions? The log file shows only that your VM was saved with VBox 4.3.14 but not how the saved state was created.

comment:5 Changed 7 years ago by Perryg

If I may add to this discussion. I have on occasion updated VBox while a guest was in a saved state and had this issue. All I needed to do was discard the saved state in the guest and it booted normally. I tend to make sure that the guest/s are shut down now.

Changed 7 years ago by Uku Loskit

comment:6 Changed 7 years ago by Uku Loskit

I've added a new log. In this log the saved state is for 4.3.16. For this log I created the snapshot from scratch using the GUI (so no --type headless used). Everything is done on the same host. After creating the snapshot, powering off the guest and restarting the host OS (not logging in via GUI), starting the using --type headless does not work no longer.

Thanks for your fast responses!

Last edited 7 years ago by Uku Loskit (previous) (diff)

comment:7 Changed 6 years ago by Black No.1

Similar results. Confirmed with 4.3.28 r100309, Linux 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux Scenario:

  1. Start VM on computer (GUI).
  2. Save machine state.
  3. Attempted to start the VM in headless mode (CLI). (failed).
  4. Start the VM normally (GUI).
  5. Shutdown the VM via the OS (or ACPI Shutdown). (Complete shutdown).
  6. Start the VM in headless (CLI). (success).

This is very annoying since users save machine states while in the middle of work but at the end of the day. Attempting to do any maintenance on the VM in the saved state is impossible without discarding the VM. This will cause the loss of the users work.

comment:8 Changed 15 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use